summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-23 22:51:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-23 22:51:04 +0000
commitb32339fe7c35d0c5e7eb8fce0fc5f30b36f6c675 (patch)
treebef20a06521cbd3e2455c667442782974e831402 /app-emulation/point2play
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-b32339fe7c35d0c5e7eb8fce0fc5f30b36f6c675.tar.gz
gentoo-2-b32339fe7c35d0c5e7eb8fce0fc5f30b36f6c675.tar.bz2
gentoo-2-b32339fe7c35d0c5e7eb8fce0fc5f30b36f6c675.zip
patch this hippy crap #35755
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog6
-rw-r--r--app-emulation/point2play/files/1.3-fix-sound-test.patch19
-rw-r--r--app-emulation/point2play/point2play-1.3.ebuild7
3 files changed, 30 insertions, 2 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 54663e90141a..e841acb9cdf6 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.10 2004/06/23 22:24:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.11 2004/06/23 22:51:04 vapier Exp $
+
+ 23 Jun 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.3-fix-sound-test.patch, point2play-1.3.ebuild:
+ Patch the sound test to actually work #35755.
*point2play-1.3 (23 Jun 2004)
diff --git a/app-emulation/point2play/files/1.3-fix-sound-test.patch b/app-emulation/point2play/files/1.3-fix-sound-test.patch
new file mode 100644
index 000000000000..edd728860636
--- /dev/null
+++ b/app-emulation/point2play/files/1.3-fix-sound-test.patch
@@ -0,0 +1,19 @@
+--- usr/lib/transgaming_point2play/tests/test_sound.py.suckit 2004-06-22 01:28:14.000000000 -0400
++++ usr/lib/transgaming_point2play/tests/test_sound.py 2004-06-23 18:46:52.866931568 -0400
+@@ -30,14 +31,12 @@
+ except:
+ return ((_('Basic sound test'), _("Unable to open sound file,\nCan not test sound card"), 'red'),)
+ try:
+- audio_out = ossaudiodev.open('/dev/dsp', 'w')
++ audio_out = ossaudiodev.open('w')
+ except IOError, e:
+ return ((_('Basic sound test'), _('Unable to open /dev/dsp'), 'red'),)
+
+ try:
+- audio_out.setparameters(TestSound1.getframerate(), 16,
+- TestSound1.getnchannels(), ossaudiodev.AFMT_S16_LE, False)
+- #FIXME: use getsampwidth for 16 and AFMT_S16_LE
++ audio_out.setparameters(ossaudiodev.AFMT_S16_LE, TestSound1.getnchannels(), TestSound1.getframerate())
+ except:
+ audio_out.close()
+ return ((_('Basic sound test'), _('Unable to play sound, your\nSound card may not be configured correctly'), 'red'),)
diff --git a/app-emulation/point2play/point2play-1.3.ebuild b/app-emulation/point2play/point2play-1.3.ebuild
index 00b80235481b..583900b60566 100644
--- a/app-emulation/point2play/point2play-1.3.ebuild
+++ b/app-emulation/point2play/point2play-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.ebuild,v 1.1 2004/06/23 22:24:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.ebuild,v 1.2 2004/06/23 22:51:04 vapier Exp $
inherit eutils
@@ -29,6 +29,11 @@ pkg_nofetch() {
einfo "The archive should then be placed into ${DISTDIR}"
}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fix-sound-test.patch
+}
+
src_install() {
mv usr ${D}/
mv etc/X11/applnk ${D}/usr/share