summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-02-10 09:14:18 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-02-10 09:14:18 +0000
commit8f7506ef0119a61335d283165a2321582f52578f (patch)
tree15aaaea059bd6506654760b43882ff9ea1020cae /app-emulation/qemu-user
parentUpdate home page. (diff)
downloadgentoo-2-8f7506ef0119a61335d283165a2321582f52578f.tar.gz
gentoo-2-8f7506ef0119a61335d283165a2321582f52578f.tar.bz2
gentoo-2-8f7506ef0119a61335d283165a2321582f52578f.zip
New version
(Portage version: 2.1.2-r8)
Diffstat (limited to 'app-emulation/qemu-user')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/files/digest-qemu-user-0.9.03
-rw-r--r--app-emulation/qemu-user/qemu-user-0.9.0.ebuild93
3 files changed, 102 insertions, 1 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 7f38a45f71fc..8660380ed6fe 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.23 2007/02/06 14:48:39 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.24 2007/02/10 09:14:18 lu_zero Exp $
+
+*qemu-user-0.9.0 (10 Feb 2007)
+
+ 10 Feb 2007; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.9.0.ebuild:
+ New version
06 Feb 2007; Simon Stelling <blubb@gentoo.org> qemu-user-0.8.2.ebuild:
stable on amd64; bug 159522
diff --git a/app-emulation/qemu-user/files/digest-qemu-user-0.9.0 b/app-emulation/qemu-user/files/digest-qemu-user-0.9.0
new file mode 100644
index 000000000000..2079a38f6c73
--- /dev/null
+++ b/app-emulation/qemu-user/files/digest-qemu-user-0.9.0
@@ -0,0 +1,3 @@
+MD5 ab11a03ba30cf4a70641f0f170473d69 qemu-0.9.0.tar.gz 1901741
+RMD160 4296542b6da18a6ac93d20787330d3c1c2ac0a19 qemu-0.9.0.tar.gz 1901741
+SHA256 491facf9335654967ee53d8fb3540a274bfcbdcc225506bd38c4ee8e9ab405c1 qemu-0.9.0.tar.gz 1901741
diff --git a/app-emulation/qemu-user/qemu-user-0.9.0.ebuild b/app-emulation/qemu-user/qemu-user-0.9.0.ebuild
new file mode 100644
index 000000000000..abdd1a7b7be4
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.9.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.9.0.ebuild,v 1.1 2007/02/10 09:14:18 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/${P/-user/}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc -sparc ~x86"
+IUSE="" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip test"
+
+DEPEND="virtual/libc
+ app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${P/-user/}"
+
+QA_TEXTRELS="usr/bin/qemu-armeb
+ usr/bin/qemu-i386
+ usr/bin/qemu-mips
+ usr/bin/qemu-arm
+ usr/bin/qemu-ppc"
+
+#set_target_list() {
+# TARGET_LIST="i386-user ppc-user mips-user"
+# arm broken
+# TARGET_LIST="arm-user armeb-user i386-user ppc-user mips-user"
+# export TARGET_LIST
+#}
+
+#pkg_setup() {
+# if [ "$(gcc-major-version)" == "4" ]; then
+# die "Qemu must build with GCC 3"
+# fi
+#}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/qemu-0.7.0-ppc-linker.patch
+
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf="--disable-gcc-check"
+# set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ --enable-linux-user \
+ --disable-system \
+ ${myconf} \
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ rm -fR ${D}/usr/share/{man,qemu}
+ rm -fR ${D}/usr/bin/qemu-img
+}