summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-23 21:15:03 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-23 21:15:03 +0000
commitf15338f52c597839d7b302f54ed2785008f10410 (patch)
treea882ba5b2035e572c31add05f0049b796827e645 /app-emulation/qemu
parentMask USE=usbredir for qemu and qemu-kvm (unsatisfied dep on sys-apps/usbredir). (diff)
downloadgentoo-2-f15338f52c597839d7b302f54ed2785008f10410.tar.gz
gentoo-2-f15338f52c597839d7b302f54ed2785008f10410.tar.bz2
gentoo-2-f15338f52c597839d7b302f54ed2785008f10410.zip
Put back optional USE=opengl flag, added USE=usbredir and prefix support. Bumped up to EAPI=4 and cleaned doc installation (by WilliamH).
(Portage version: 2.2.0_alpha84_p18/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog9
-rw-r--r--app-emulation/qemu/metadata.xml3
-rw-r--r--app-emulation/qemu/qemu-1.0-r1.ebuild (renamed from app-emulation/qemu/qemu-1.0.ebuild)114
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild59
4 files changed, 86 insertions, 99 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index ff0b996fa501..d4018fd233c4 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.96 2012/01/23 19:04:48 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.97 2012/01/23 21:15:03 slyfox Exp $
+
+*qemu-1.0-r1 (23 Jan 2012)
+
+ 23 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org> +qemu-1.0-r1.ebuild,
+ -qemu-1.0.ebuild, metadata.xml, qemu-9999.ebuild:
+ Put back optional USE=opengl flag, added USE=usbredir and prefix support.
+ Bumped up to EAPI=4 and cleaned doc installation (by WilliamH).
23 Jan 2012; William Hubbs <williamh@gentoo.org> qemu-9999.ebuild:
clean up live ebuild and migrate to eapi 4 (approved by slyfox)
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
index 342a82d3e649..6173a565674c 100644
--- a/app-emulation/qemu/metadata.xml
+++ b/app-emulation/qemu/metadata.xml
@@ -21,6 +21,7 @@
<flag name='kvm'>Use the KVM (Kernel Virtual Machine) infrastructure on compatible hardware</flag>
<flag name='ncurses'>Enable the ncurses-based console</flag>
<flag name='nss'>Build support for Smartcard devices emulation using <pkg>dev-libs/nss</pkg></flag>
+ <flag name='nss'>Enable opengl/x11 output for lm32 target.</flag>
<flag name='pulseaudio'>Enable pulseaudio output for sound emulation</flag>
<flag name='qemu-ifup'>Provides the qemu-ifup script for use with
QEMU's built in bridging</flag>
@@ -30,6 +31,8 @@
emulation</flag>
<flag name='spice'>Enable Spice protocol support via <pkg>app-emulation/spice</pkg></flag>
<flag name='ssl'>Enable TLS support for the VNC console server</flag>
+ <flag name="usbredir">Use <pkg>sys-apps/usbredir</pkg> to redirect USB
+ devices to another machine over TCP</flag>
<flag name='vde'>Enable Virtual Distributed Ethernet (VDE) based networking</flag>
<flag name='vhost-net'>Enable accelerated networking using vhost-net, see http://www.linux-kvm.org/page/VhostNet</flag>
<flag name='xattr'>
diff --git a/app-emulation/qemu/qemu-1.0.ebuild b/app-emulation/qemu/qemu-1.0-r1.ebuild
index 448f4e945b77..053c3dc4f5b1 100644
--- a/app-emulation/qemu/qemu-1.0.ebuild
+++ b/app-emulation/qemu/qemu-1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.0.ebuild,v 1.3 2012/01/22 21:08:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-1.0-r1.ebuild,v 1.1 2012/01/23 21:15:03 slyfox Exp $
-EAPI="2"
+EAPI=4
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="git://git.qemu.org/qemu.git
@@ -12,10 +12,7 @@ fi
inherit eutils flag-o-matic ${GIT_ECLASS} linux-info toolchain-funcs
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
+if [[ ${PV} != *9999* ]]; then
SRC_URI="http://wiki.qemu.org/download/${P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
fi
@@ -25,8 +22,8 @@ HOMEPAGE="http://www.qemu.org"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+aio alsa bluetooth brltty curl esd fdt hardened jpeg ncurses nss \
-png pulseaudio qemu-ifup rbd sasl sdl spice ssl static threads vde \
+IUSE="+aio alsa bluetooth brltty curl esd fdt hardened jpeg ncurses nss
+opengl png pulseaudio qemu-ifup rbd sasl sdl spice ssl static threads usbredir vde
+vhost-net xattr xen"
COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
@@ -60,6 +57,10 @@ RDEPEND="
jpeg? ( virtual/jpeg )
ncurses? ( sys-libs/ncurses )
nss? ( dev-libs/nss )
+ opengl? (
+ virtual/opengl
+ x11-libs/libX11
+ )
png? ( media-libs/libpng )
pulseaudio? ( media-sound/pulseaudio )
qemu-ifup? ( sys-apps/iproute2 net-misc/bridge-utils )
@@ -69,14 +70,11 @@ RDEPEND="
spice? ( >=app-emulation/spice-0.9.0
>=app-emulation/spice-protocol-0.8.1 )
ssl? ( net-libs/gnutls )
+ usbredir? ( sys-apps/usbredir )
vde? ( net-misc/vde )
xattr? ( sys-apps/attr )
xen? ( app-emulation/xen-tools )
- qemu_softmmu_targets_lm32? (
- x11-libs/libX11
- virtual/opengl
- )
"
DEPEND="${RDEPEND}
@@ -124,8 +122,6 @@ pkg_setup() {
}
src_prepare() {
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
# Alter target makefiles to accept CFLAGS set via flag-o
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target || die
@@ -150,13 +146,13 @@ src_configure() {
user_targets="${user_targets} ${target}-linux-user"
done
- if [ -z "${softmmu_targets}" ]; then
+ if [[ -z ${softmmu_targets} ]]; then
conf_opts="${conf_opts} --disable-system"
else
einfo "Building the following softmmu targets: ${softmmu_targets}"
fi
- if [ ! -z "${user_targets}" ]; then
+ if [[ -n ${user_targets} ]]; then
einfo "Building the following user targets: ${user_targets}"
conf_opts="${conf_opts} --enable-linux-user"
else
@@ -169,32 +165,31 @@ src_configure() {
# Add support for static builds
use static && conf_opts="${conf_opts} --static"
- # Fix the $(prefix)/etc issue
- conf_opts="${conf_opts} --sysconfdir=/etc"
-
#config options
- conf_opts="${conf_opts} $(use_enable aio linux-aio)"
- conf_opts="${conf_opts} $(use_enable bluetooth bluez)"
- conf_opts="${conf_opts} $(use_enable brltty brlapi)"
- conf_opts="${conf_opts} $(use_enable curl)"
- conf_opts="${conf_opts} $(use_enable fdt)"
- conf_opts="${conf_opts} $(use_enable hardened pie)"
- conf_opts="${conf_opts} $(use_enable jpeg vnc-jpeg)"
- conf_opts="${conf_opts} $(use_enable ncurses curses)"
- conf_opts="${conf_opts} $(use_enable nss smartcard-nss)"
- conf_opts="${conf_opts} $(use_enable qemu_softmmu_targets_lm32 opengl)" # single opengl user
- conf_opts="${conf_opts} $(use_enable png vnc-png)"
- conf_opts="${conf_opts} $(use_enable rbd)"
- conf_opts="${conf_opts} $(use_enable sasl vnc-sasl)"
- conf_opts="${conf_opts} $(use_enable sdl)"
- conf_opts="${conf_opts} $(use_enable spice)"
- conf_opts="${conf_opts} $(use_enable ssl vnc-tls)"
- conf_opts="${conf_opts} $(use_enable threads vnc-thread)"
- conf_opts="${conf_opts} $(use_enable vde)"
- conf_opts="${conf_opts} $(use_enable vhost-net)"
- conf_opts="${conf_opts} $(use_enable xen)"
- conf_opts="${conf_opts} $(use_enable xattr attr)"
- conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
+ conf_opts="${conf_opts}
+ $(use_enable aio linux-aio)
+ $(use_enable bluetooth bluez)
+ $(use_enable brltty brlapi)
+ $(use_enable curl)
+ $(use_enable fdt)
+ $(use_enable hardened pie)
+ $(use_enable jpeg vnc-jpeg)
+ $(use_enable ncurses curses)
+ $(use_enable nss smartcard-nss)
+ $(use_enable opengl)
+ $(use_enable png vnc-png)
+ $(use_enable rbd)
+ $(use_enable sasl vnc-sasl)
+ $(use_enable sdl)
+ $(use_enable spice)
+ $(use_enable ssl vnc-tls)
+ $(use_enable threads vnc-thread)
+ $(use_enable vde)
+ $(use_enable vhost-net)
+ $(use_enable xen)
+ $(use_enable xattr attr)
+ --disable-darwin-user --disable-bsd-user
+ "
# audio options
audio_opts="oss"
@@ -203,13 +198,16 @@ src_configure() {
use pulseaudio && audio_opts="pa ${audio_opts}"
use sdl && audio_opts="sdl ${audio_opts}"
- set -- --prefix=/usr \
+ set -- --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
--disable-strip \
--disable-werror \
--disable-kvm \
+ --disable-libiscsi \
--enable-nptl \
--enable-uuid \
${conf_opts} \
+ --audio-card-list="ac97 es1370 sb16 cs4231a adlib gus hda" \
--audio-drv-list="${audio_opts}" \
--target-list="${softmmu_targets} ${user_targets}" \
--cc="$(tc-getCC)" \
@@ -217,32 +215,20 @@ src_configure() {
echo ./configure "$@" # show actual options
./configure "$@" || die "configure failed"
- # this is for qemu upstream's threaded support which is
- # in development and broken
- # the kvm project has its own support for threaded IO
- # which is always on and works
- # --enable-io-thread \
-}
-
-src_compile() {
- # Restricting parallel build until we get a patch to fix this
- emake || die
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if [ ! -z "${softmmu_targets}" ]; then
- exeinto /etc/qemu
- use qemu-ifup && { doexe \
- "${FILESDIR}/qemu-ifup" \
- "${FILESDIR}/qemu-ifdown" \
- || die "qemu interface scripts missing" ; }
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/"${PF}" \
+ install || die "make install failed"
+
+ if [[ -n ${softmmu_targets} ]]; then
+ if use qemu-ifup; then
+ exeinto /etc/qemu
+ doexe "${FILESDIR}"/qemu-if{up,down}
+ fi
fi
-
- dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
- newdoc pc-bios/README README.pc-bios || die
- dohtml qemu-doc.html qemu-tech.html || die
}
pkg_postinst() {
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 1b2bb9611901..9e7204f36800 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.10 2012/01/23 19:04:48 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.11 2012/01/23 21:15:03 slyfox Exp $
EAPI=4
@@ -23,7 +23,7 @@ HOMEPAGE="http://www.qemu.org"
LICENSE="GPL-2"
SLOT="0"
IUSE="+aio alsa bluetooth brltty curl esd fdt hardened jpeg ncurses nss
-png pulseaudio qemu-ifup rbd sasl sdl spice ssl static threads vde
+opengl png pulseaudio qemu-ifup rbd sasl sdl spice ssl static threads usbredir vde
+vhost-net xattr xen"
COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
@@ -57,6 +57,10 @@ RDEPEND="
jpeg? ( virtual/jpeg )
ncurses? ( sys-libs/ncurses )
nss? ( dev-libs/nss )
+ opengl? (
+ virtual/opengl
+ x11-libs/libX11
+ )
png? ( media-libs/libpng )
pulseaudio? ( media-sound/pulseaudio )
qemu-ifup? ( sys-apps/iproute2 net-misc/bridge-utils )
@@ -66,14 +70,11 @@ RDEPEND="
spice? ( >=app-emulation/spice-0.9.0
>=app-emulation/spice-protocol-0.8.1 )
ssl? ( net-libs/gnutls )
+ usbredir? ( sys-apps/usbredir )
vde? ( net-misc/vde )
xattr? ( sys-apps/attr )
xen? ( app-emulation/xen-tools )
- qemu_softmmu_targets_lm32? (
- x11-libs/libX11
- virtual/opengl
- )
"
DEPEND="${RDEPEND}
@@ -121,8 +122,6 @@ pkg_setup() {
}
src_prepare() {
- # prevent docs to get automatically installed
- sed -i '/$(DESTDIR)$(docdir)/d' Makefile || die
# Alter target makefiles to accept CFLAGS set via flag-o
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target || die
@@ -147,13 +146,13 @@ src_configure() {
user_targets="${user_targets} ${target}-linux-user"
done
- if [ -z "${softmmu_targets}" ]; then
+ if [[ -z ${softmmu_targets} ]]; then
conf_opts="${conf_opts} --disable-system"
else
einfo "Building the following softmmu targets: ${softmmu_targets}"
fi
- if [ ! -z "${user_targets}" ]; then
+ if [[ -n ${user_targets} ]]; then
einfo "Building the following user targets: ${user_targets}"
conf_opts="${conf_opts} --enable-linux-user"
else
@@ -166,9 +165,6 @@ src_configure() {
# Add support for static builds
use static && conf_opts="${conf_opts} --static"
- # Fix the $(prefix)/etc issue
- conf_opts="${conf_opts} --sysconfdir=/etc"
-
#config options
conf_opts="${conf_opts}
$(use_enable aio linux-aio)
@@ -180,8 +176,7 @@ src_configure() {
$(use_enable jpeg vnc-jpeg)
$(use_enable ncurses curses)
$(use_enable nss smartcard-nss)
- $(use_enable qemu_softmmu_targets_lm32 opengl)" # single opengl user
- conf_opts="${conf_opts}
+ $(use_enable opengl)
$(use_enable png vnc-png)
$(use_enable rbd)
$(use_enable sasl vnc-sasl)
@@ -193,7 +188,8 @@ src_configure() {
$(use_enable vhost-net)
$(use_enable xen)
$(use_enable xattr attr)
- --disable-darwin-user --disable-bsd-user"
+ --disable-darwin-user --disable-bsd-user
+ "
# audio options
audio_opts="oss"
@@ -202,10 +198,12 @@ src_configure() {
use pulseaudio && audio_opts="pa ${audio_opts}"
use sdl && audio_opts="sdl ${audio_opts}"
- set -- --prefix=/usr \
+ set -- --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
--disable-strip \
--disable-werror \
--disable-kvm \
+ --disable-libiscsi \
--enable-nptl \
--enable-uuid \
${conf_opts} \
@@ -217,27 +215,20 @@ src_configure() {
echo ./configure "$@" # show actual options
./configure "$@" || die "configure failed"
- # this is for qemu upstream's threaded support which is
- # in development and broken
- # the kvm project has its own support for threaded IO
- # which is always on and works
- # --enable-io-thread \
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- if [ ! -z "${softmmu_targets}" ]; then
- exeinto /etc/qemu
- use qemu-ifup && { doexe \
- "${FILESDIR}/qemu-ifup" \
- "${FILESDIR}/qemu-ifdown" \
- || die "qemu interface scripts missing" ; }
+ emake \
+ DESTDIR="${D}" \
+ docdir="${EPREFIX}"/usr/share/doc/"${PF}" \
+ install || die "make install failed"
+
+ if [[ -n ${softmmu_targets} ]]; then
+ if use qemu-ifup; then
+ exeinto /etc/qemu
+ doexe "${FILESDIR}"/qemu-if{up,down}
+ fi
fi
-
- dodoc Changelog MAINTAINERS TODO pci-ids.txt || die
- newdoc pc-bios/README README.pc-bios || die
- dohtml qemu-doc.html qemu-tech.html || die
}
pkg_postinst() {