summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-01-07 16:55:10 +0000
committerMichael Januszewski <spock@gentoo.org>2006-01-07 16:55:10 +0000
commit37d7df313ae36b9bf0f6f747ea0e8618b2a49df3 (patch)
tree05725bebcd7a567f2c04135af7095bb154ce1d24 /app-emulation/uade
parentRemove old version. (diff)
downloadgentoo-2-37d7df313ae36b9bf0f6f747ea0e8618b2a49df3.tar.gz
gentoo-2-37d7df313ae36b9bf0f6f747ea0e8618b2a49df3.tar.bz2
gentoo-2-37d7df313ae36b9bf0f6f747ea0e8618b2a49df3.zip
Version bump.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/ChangeLog10
-rw-r--r--app-emulation/uade/files/digest-uade-2.011
-rw-r--r--app-emulation/uade/files/uade-2.01-pkgprefix.patch23
-rw-r--r--app-emulation/uade/uade-2.01.ebuild44
4 files changed, 76 insertions, 2 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 65b655ce1123..e88705278c1b 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/uade
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.28 2005/08/09 18:28:12 spock Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.29 2006/01/07 16:55:10 spock Exp $
+
+*uade-2.01 (07 Jan 2006)
+
+ 07 Jan 2006; Michał Januszewski <spock@gentoo.org>
+ +files/uade-2.01-pkgprefix.patch, +uade-2.01.ebuild:
+ Version bump (bug #117370).
*uade-1.03 (09 Aug 2005)
diff --git a/app-emulation/uade/files/digest-uade-2.01 b/app-emulation/uade/files/digest-uade-2.01
new file mode 100644
index 000000000000..8861fb4639a3
--- /dev/null
+++ b/app-emulation/uade/files/digest-uade-2.01
@@ -0,0 +1 @@
+MD5 67e094d8f8f11d6263ce93936c869c9d uade-2.01.tar.bz2 2126001
diff --git a/app-emulation/uade/files/uade-2.01-pkgprefix.patch b/app-emulation/uade/files/uade-2.01-pkgprefix.patch
new file mode 100644
index 000000000000..21ba2599fce2
--- /dev/null
+++ b/app-emulation/uade/files/uade-2.01-pkgprefix.patch
@@ -0,0 +1,23 @@
+diff -Naurp uade-2.01-orig/Makefile.in uade-2.01/Makefile.in
+--- uade-2.01-orig/Makefile.in 2006-01-07 16:57:41.000000000 +0100
++++ uade-2.01/Makefile.in 2006-01-07 17:00:22.000000000 +0100
+@@ -8,6 +8,8 @@ FINALDOCDIR = {DOCDIR}
+ FINALMANDIR = {MANDIR}
+ FINALLIBDIR = {LIBDIR}
+
++PACKAGEPREFIX = {PACKAGEPREFIX}
++
+ BINDIR = {PACKAGEPREFIX}{BINDIR}
+ DATADIR = {PACKAGEPREFIX}{DATADIR}
+ DOCDIR = {PACKAGEPREFIX}{DOCDIR}
+@@ -50,8 +52,8 @@ xmmsplugin:
+ $(MAKE) -C src/frontends/xmms
+
+ xmmsplugininstall: $(XMMSPLUGIN)
+- mkdir -p "$(XMMSPLUGINDIR)" "$(BINDIR)"
+- install src/frontends/xmms/libuade2.so "$(XMMSPLUGINDIR)"
++ mkdir -p "$(PACKAGEPREFIX)$(XMMSPLUGINDIR)" "$(BINDIR)"
++ install src/frontends/xmms/libuade2.so "$(PACKAGEPREFIX)$(XMMSPLUGINDIR)"
+ install contrib/uadexmmsadd "$(BINDIR)"/
+
+ src/include/uadeconfig.h:
diff --git a/app-emulation/uade/uade-2.01.ebuild b/app-emulation/uade/uade-2.01.ebuild
new file mode 100644
index 000000000000..8e97e5b3c703
--- /dev/null
+++ b/app-emulation/uade/uade-2.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation and cloned m68k-assembler Eagleplayer API"
+HOMEPAGE="http://zakalwe.virtuaalipalvelin.net/uade"
+SRC_URI="http://zakalwe.virtuaalipalvelin.net/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="xmms"
+
+RDEPEND="virtual/libc
+ libao
+ xmms? ( >=media-sound/xmms-1.2.2 )"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-pkgprefix.patch
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with xmms) \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}
+
+pkg_postinst() {
+ einfo "The 2.x series of UADE currently doesn't support Beep Media Player."
+}