summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 14:18:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-15 14:18:34 +0000
commitd4f1567eb5543460199ba060177e42ab6d2aa29c (patch)
tree857976bd1e7032a3c3245956a70131c70f31ba69 /app-emulation/vice
parentMarked 1.1.1 stable on x86. Added 1.3.0 and changed the ebuild to use the gem. (diff)
downloadgentoo-2-d4f1567eb5543460199ba060177e42ab6d2aa29c.tar.gz
gentoo-2-d4f1567eb5543460199ba060177e42ab6d2aa29c.tar.bz2
gentoo-2-d4f1567eb5543460199ba060177e42ab6d2aa29c.zip
disabled gnome support since it doesn't work. see bug #101901
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog6
-rw-r--r--app-emulation/vice/vice-1.14-r1.ebuild11
-rw-r--r--app-emulation/vice/vice-1.16.ebuild9
3 files changed, 16 insertions, 10 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index c4be32006f28..8ada094de1b1 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.24 2005/05/04 16:11:40 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.25 2005/08/15 14:18:34 mr_bones_ Exp $
+
+ 15 Aug 2005; Michael Sterrett <mr_bones_@gentoo.org> vice-1.14-r1.ebuild,
+ vice-1.16.ebuild:
+ disabled gnome support since it doesn't work. see bug #101901 and discussion.
04 May 2005; Hanno Boeck <hanno@gentoo.org> +files/vice_gcc4_patch.gz,
vice-1.16.ebuild:
diff --git a/app-emulation/vice/vice-1.14-r1.ebuild b/app-emulation/vice/vice-1.14-r1.ebuild
index 7b4025080d4d..75ef6f6b0bfb 100644
--- a/app-emulation/vice/vice-1.14-r1.ebuild
+++ b/app-emulation/vice/vice-1.14-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.14-r1.ebuild,v 1.7 2005/06/21 04:41:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.14-r1.ebuild,v 1.8 2005/08/15 14:18:34 mr_bones_ Exp $
inherit eutils games
@@ -11,11 +11,10 @@ SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE="sdl nls gnome arts"
+IUSE="arts nls sdl"
DEPEND="virtual/x11
sdl? ( media-libs/libsdl )
- gnome? ( gnome-base/gnome-libs )
arts? ( kde-base/arts )"
src_unpack() {
@@ -28,13 +27,15 @@ src_unpack() {
}
src_compile() {
+ # disabled gnome support since it doesn't work.
+ # see bug #101901 and discussion.
egamesconf \
--enable-fullscreen \
--disable-dependency-tracking \
- $(use_with sdl) \
- $(use_enable gnome gnomeui) \
+ --disable-gnomeui \
$(use_with arts) \
$(use_enable nls) \
+ $(use_with sdl) \
|| die
emake || die "emake failed"
}
diff --git a/app-emulation/vice/vice-1.16.ebuild b/app-emulation/vice/vice-1.16.ebuild
index 06f52c757a60..c8d9b1e3bc27 100644
--- a/app-emulation/vice/vice-1.16.ebuild
+++ b/app-emulation/vice/vice-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.16.ebuild,v 1.5 2005/06/21 05:11:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.16.ebuild,v 1.6 2005/08/15 14:18:34 mr_bones_ Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="arts gnome nls sdl X Xaw3d readline"
+IUSE="arts nls sdl X Xaw3d readline"
# FIXME: esound is required until configure.in is patched.
DEPEND="virtual/libc
@@ -19,7 +19,6 @@ DEPEND="virtual/libc
media-libs/libpng
sys-libs/zlib
arts? ( kde-base/arts )
- gnome? ( gnome-base/gnome-libs )
readline? ( sys-libs/readline )
sdl? ( media-libs/libsdl )
X? ( virtual/x11 )
@@ -33,6 +32,8 @@ src_unpack() {
src_compile() {
# disabled ffmpeg support since ffmpeg isn't slotted and later
# versions aren't compatible with the vice code (bug #81795)
+ # disabled gnome support since it doesn't work.
+ # see bug #101901 and discussion.
egamesconf \
--disable-dependency-tracking \
--enable-fullscreen \
@@ -42,7 +43,7 @@ src_compile() {
--with-resid \
--without-midas \
--disable-ffmpeg \
- $(use_enable gnome gnomeui) \
+ --disable-gnomeui \
$(use_enable nls) \
$(use_with X x) \
$(use_with Xaw3d xaw3d) \