summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-28 08:39:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-28 08:39:41 +0000
commita2196cd27ad3827dc9abeeebe15260450312a00d (patch)
tree040399825ee1c03762f755def217b83f4ae52dcb /app-emulation/virtinst
parentVersion bump wrt #358363 by Tim Harder. The package is veryvery low maintenan... (diff)
downloadgentoo-2-a2196cd27ad3827dc9abeeebe15260450312a00d.tar.gz
gentoo-2-a2196cd27ad3827dc9abeeebe15260450312a00d.tar.bz2
gentoo-2-a2196cd27ad3827dc9abeeebe15260450312a00d.zip
Version bump; fix live ebuild (bug #360077).
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/virtinst')
-rw-r--r--app-emulation/virtinst/ChangeLog8
-rw-r--r--app-emulation/virtinst/virtinst-0.500.5.ebuild18
-rw-r--r--app-emulation/virtinst/virtinst-0.500.6.ebuild37
-rw-r--r--app-emulation/virtinst/virtinst-9999.ebuild9
4 files changed, 53 insertions, 19 deletions
diff --git a/app-emulation/virtinst/ChangeLog b/app-emulation/virtinst/ChangeLog
index c355b2fb36de..fa1de1a4ba79 100644
--- a/app-emulation/virtinst/ChangeLog
+++ b/app-emulation/virtinst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virtinst
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.25 2011/02/22 08:28:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/ChangeLog,v 1.26 2011/03/28 08:39:41 flameeyes Exp $
+
+*virtinst-0.500.6 (28 Mar 2011)
+
+ 28 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ virtinst-0.500.5.ebuild, +virtinst-0.500.6.ebuild, virtinst-9999.ebuild:
+ Version bump; fix live ebuild (bug #360077).
22 Feb 2011; Markos Chandras <hwoarang@gentoo.org> virtinst-0.500.4.ebuild:
Stable on amd64 wrt bug #353559
diff --git a/app-emulation/virtinst/virtinst-0.500.5.ebuild b/app-emulation/virtinst/virtinst-0.500.5.ebuild
index 8f0a70d3abc8..4ae926c30ea8 100644
--- a/app-emulation/virtinst/virtinst-0.500.5.ebuild
+++ b/app-emulation/virtinst/virtinst-0.500.5.ebuild
@@ -1,30 +1,20 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.5.ebuild,v 1.1 2011/02/02 21:58:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.5.ebuild,v 1.2 2011/03/28 08:39:41 flameeyes Exp $
#BACKPORTS=1
EAPI=3
-if [[ ${PV} = *9999* ]]; then
- EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
- HG_ECLASS="mercurial autotools"
-fi
-
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.*"
SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils ${HG_ECLASS}
-if [[ ${PV} = *9999* ]]; then
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
- ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+KEYWORDS="~amd64 ~x86"
DESCRIPTION="Python modules for starting virtualized guest installations"
HOMEPAGE="http://virt-manager.et.redhat.com/"
diff --git a/app-emulation/virtinst/virtinst-0.500.6.ebuild b/app-emulation/virtinst/virtinst-0.500.6.ebuild
new file mode 100644
index 000000000000..e9ae04ca3405
--- /dev/null
+++ b/app-emulation/virtinst/virtinst-0.500.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-0.500.6.ebuild,v 1.1 2011/03/28 08:39:41 flameeyes Exp $
+
+#BACKPORTS=1
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils ${HG_ECLASS}
+
+SRC_URI="http://virt-manager.et.redhat.com/download/sources/${PN}/${P}.tar.gz
+ ${BACKPORTS:+mirror://gentoo/${P}-backports-${BACKPORTS}.tar.bz2}"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Python modules for starting virtualized guest installations"
+HOMEPAGE="http://virt-manager.et.redhat.com/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+RDEPEND=">=app-emulation/libvirt-0.7.0[python]
+ dev-python/urlgrabber
+ dev-libs/libxml2[python]"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="virtconv virtinst"
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ distutils_src_prepare
+}
diff --git a/app-emulation/virtinst/virtinst-9999.ebuild b/app-emulation/virtinst/virtinst-9999.ebuild
index 88acfd3b906b..29621a0b38bb 100644
--- a/app-emulation/virtinst/virtinst-9999.ebuild
+++ b/app-emulation/virtinst/virtinst-9999.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-9999.ebuild,v 1.4 2011/02/02 21:58:31 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtinst/virtinst-9999.ebuild,v 1.5 2011/03/28 08:39:41 flameeyes Exp $
#BACKPORTS=1
EAPI=3
+
if [[ ${PV} = *9999* ]]; then
- EHG_REPO_URI="http://hg.fedorahosted.org/hg/python-virtinst"
- HG_ECLASS="mercurial autotools"
+ EGIT_REPO_URI="http://git.fedorahosted.org/git/python-virtinst.git"
+ GIT_ECLASS="git"
fi
PYTHON_DEPEND="2"
RESTRICT_PYTHON_ABIS="3.*"
SUPPORT_PYTHON_ABIS="1"
-inherit distutils eutils ${HG_ECLASS}
+inherit distutils eutils ${GIT_ECLASS}
if [[ ${PV} = *9999* ]]; then
SRC_URI=""