summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-12 02:38:44 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-12 02:38:44 +0000
commit9f5d960bdafe5878059211f4c59866a7d61d89f8 (patch)
treeda18577e3fa74f599b4186897b6ea4a7021ce224 /app-emulation/wine
parentDon't add the current working directory to syspath, fixes arbitrary code exec... (diff)
downloadgentoo-2-9f5d960bdafe5878059211f4c59866a7d61d89f8.tar.gz
gentoo-2-9f5d960bdafe5878059211f4c59866a7d61d89f8.tar.bz2
gentoo-2-9f5d960bdafe5878059211f4c59866a7d61d89f8.zip
Update osmesa patch (bug #483984, thanks to Maksym).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/ChangeLog6
-rw-r--r--app-emulation/wine/files/wine-1.7.2-osmesa-check.patch38
-rw-r--r--app-emulation/wine/wine-9999.ebuild4
3 files changed, 45 insertions, 3 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index f8db2d7a9506..08eb9acaa0d0 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.477 2013/09/02 08:03:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.478 2013/09/12 02:38:44 tetromino Exp $
+
+ 12 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org> wine-9999.ebuild,
+ +files/wine-1.7.2-osmesa-check.patch:
+ Update osmesa patch (bug #483984, thanks to Maksym).
02 Sep 2013; Agostino Sarubbo <ago@gentoo.org> wine-1.6.ebuild:
Stable for amd64, wrt bug #483280
diff --git a/app-emulation/wine/files/wine-1.7.2-osmesa-check.patch b/app-emulation/wine/files/wine-1.7.2-osmesa-check.patch
new file mode 100644
index 000000000000..e20ea2c28dcd
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.7.2-osmesa-check.patch
@@ -0,0 +1,38 @@
+From b7eb1ff48dd1210aa3e1002afc503d5df75d50b9 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 7 Aug 2012 01:29:01 -0400
+Subject: [PATCH] Do not check for libGL symbols when checking libOSMesa
+
+If mesa had been built with shared glapi, glAccum is not available in
+libOSMesa without explicitly linking to libGL. In addition, in
+mesa-8.0.x and earlier, libOSMesa needs to be explicitly linked to
+libglapi if mesa was built with shared glapi, see
+https://bugs.gentoo.org/show_bug.cgi?id=399813
+And in mesa-8.1.x, libOSMesa in addition needs libdl, libpthread, and
+libstdc++, see https://bugs.gentoo.org/show_bug.cgi?id=431832
+---
+ configure.ac | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 66b4dd6..0303d87 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1213,7 +1213,13 @@ This probably prevents linking to OpenGL. Try deleting the file and restarting c
+
+ if test "x$with_osmesa" != "xno"
+ then
+- WINE_CHECK_SONAME(OSMesa,glAccum,,,[$X_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[$X_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ if test "x$ac_cv_lib_soname_OSMesa" = "x"; then
++ osmesa_save_CC=$CC
++ CC=$CXX
++ WINE_CHECK_SONAME(OSMesa,OSMesaCreateContext,,,[-lglapi -lpthread -ldl $X_LIBS $XLIB -lm $X_EXTRA_LIBS])
++ CC=$osmesa_save_CC
++ fi
+ WINE_NOTICE_WITH(osmesa,[test "x$ac_cv_lib_soname_OSMesa" = "x"],
+ [libOSMesa ${notice_platform}development files not found (or too old), OpenGL rendering in bitmaps won't be supported.])
+ fi
+--
+1.8.3.2
+
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 0adf7cad59ce..0ed8d91f343c 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.151 2013/09/01 15:31:53 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.152 2013/09/12 02:38:44 tetromino Exp $
EAPI="5"
@@ -176,7 +176,7 @@ src_prepare() {
local PATCHES=(
"${FILESDIR}"/${PN}-1.5.26-winegcc.patch #260726
"${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
- "${FILESDIR}"/${PN}-1.5.17-osmesa-check.patch #429386
+ "${FILESDIR}"/${PN}-1.7.2-osmesa-check.patch #429386
"${FILESDIR}"/${PN}-1.6-memset-O3.patch #480508
)
[[ ${PV} == "9999" ]] || PATCHES+=(