summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-01-21 20:24:05 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-01-21 20:24:05 +0000
commita8ce4dd1b32e56e752b9db8821d6ac02c219c5bf (patch)
treeb7efd720605abf65d24615c72b315173b931cbaf /app-emulation/x48
parentVersion bump. Add patch to fix build with modern glib, ship a .desktop file d... (diff)
downloadgentoo-2-a8ce4dd1b32e56e752b9db8821d6ac02c219c5bf.tar.gz
gentoo-2-a8ce4dd1b32e56e752b9db8821d6ac02c219c5bf.tar.bz2
gentoo-2-a8ce4dd1b32e56e752b9db8821d6ac02c219c5bf.zip
Drop old version
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/ChangeLog6
-rw-r--r--app-emulation/x48/files/x48-0.6.3-no-readline.patch11
-rw-r--r--app-emulation/x48/files/x48-0.6.3-off-by-one.patch25
-rw-r--r--app-emulation/x48/x48-0.6.3.ebuild61
4 files changed, 5 insertions, 98 deletions
diff --git a/app-emulation/x48/ChangeLog b/app-emulation/x48/ChangeLog
index e3d143669be5..6954130a7027 100644
--- a/app-emulation/x48/ChangeLog
+++ b/app-emulation/x48/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/x48
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.31 2013/01/21 20:17:10 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.32 2013/01/21 20:24:04 nimiux Exp $
+
+ 21 Jan 2013; Chema Alonso <nimiux@gentoo.org> -x48-0.6.3.ebuild,
+ -files/x48-0.6.3-no-readline.patch, -files/x48-0.6.3-off-by-one.patch:
+ Drop old version
21 Jan 2013; Chema Alonso <nimiux@gentoo.org> metadata.xml:
Add long description and use flag description.
diff --git a/app-emulation/x48/files/x48-0.6.3-no-readline.patch b/app-emulation/x48/files/x48-0.6.3-no-readline.patch
deleted file mode 100644
index 90c7d7854b39..000000000000
--- a/app-emulation/x48/files/x48-0.6.3-no-readline.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- x48-0.6.3.orig/configure.ac 2011-01-30 12:35:56.960715403 -0500
-+++ x48-0.6.3/configure.ac 2011-01-30 12:35:41.746142323 -0500
-@@ -82,7 +82,7 @@
-
- # Checks for header files.
- AC_HEADER_STDC
--AC_CHECK_HEADERS([fcntl.h memory.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h])
-+AC_CHECK_HEADERS([fcntl.h memory.h stdlib.h string.h sys/ioctl.h sys/time.h termios.h unistd.h stdint.h])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_C_CONST
diff --git a/app-emulation/x48/files/x48-0.6.3-off-by-one.patch b/app-emulation/x48/files/x48-0.6.3-off-by-one.patch
deleted file mode 100644
index b71f23abe663..000000000000
--- a/app-emulation/x48/files/x48-0.6.3-off-by-one.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- x48-0.6.3.orig/src/debugger.c 2011-01-29 12:58:24.432244663 -0500
-+++ x48-0.6.3/src/debugger.c 2011-01-29 13:06:46.750769284 -0500
-@@ -1919,10 +1919,7 @@
- free (cl);
- cl = (char *) 0;
- }
-- if (old_line)
-- cl = strcpy ((char *) malloc (strlen (old_line)), old_line);
-- else
-- cl = strcpy ((char *) malloc (strlen ("(null)")), "(null)");
-+ cl = strdup (old_line == NULL ? "(null)" : old_line);
- }
- else
- {
-@@ -1936,8 +1933,8 @@
- free (old_line);
- old_line = (char *) 0;
- }
-- cl = strcpy ((char *) malloc (strlen (rl)), rl);
-- old_line = strcpy ((char *) malloc (strlen (rl)), rl);
-+ cl = strdup (rl);
-+ old_line = strdup (rl);
- #ifdef HAVE_READLINE
- add_history (rl);
- #endif
diff --git a/app-emulation/x48/x48-0.6.3.ebuild b/app-emulation/x48/x48-0.6.3.ebuild
deleted file mode 100644
index 672529276820..000000000000
--- a/app-emulation/x48/x48-0.6.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.6.3.ebuild,v 1.2 2012/05/03 18:49:06 jdhore Exp $
-
-EAPI=3
-
-inherit eutils autotools
-
-DESCRIPTION="HP48 Calculator Emulator"
-HOMEPAGE="http://x48.berlios.de/"
-SRC_URI="mirror://berlios/x48/${P}.tar.gz"
-LICENSE="GPL-3"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="readline"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- readline? ( sys-libs/readline )"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-off-by-one.patch"
- epatch "${FILESDIR}/${P}-no-readline.patch"
- eautoreconf
-}
-
-src_configure() {
- econf $(use_enable readline)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed."
- dodoc AUTHORS README ChangeLog
-}
-
-pkg_postinst() {
- elog "The X48 emulator requires an HP48 ROM image to run."
- elog
- elog "If you own an HP-48 calculator, you can use the ROMDump utility"
- elog "included with this package to obtain this from your calculator."
- elog
- elog "Alternatively, HP has provided the ROM images for non-commercial"
- elog "use only."
- elog
- elog "Due to confusion over the legal status of these ROMs you must"
- elog "manually download one from http://www.hpcalc.org/hp48/pc/emulators/"
- elog
- elog "If you do not know which one to use, try 'HP 48GX Revision R ROM.'"
- elog
- elog "Once you have a ROM, you will need to install it by running:"
- elog
- elog "x48 -rom gxrom-r"
- elog
- elog "You will only have to do this the first time you run X48. The"
- elog "ROM will be stored in ~/.hp48/rom for future runs."
-}