summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-06 22:05:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-06 22:05:28 +0000
commit4e9494ca3d0301a4da9e16cdaf7aeb4435566f0a (patch)
tree5145595f0554f2f0b5bb30ac6dc17f04b3a51a0b /app-emulation/xen
parentRemoved orphaned qwt libs from tree (diff)
downloadgentoo-2-4e9494ca3d0301a4da9e16cdaf7aeb4435566f0a.tar.gz
gentoo-2-4e9494ca3d0301a4da9e16cdaf7aeb4435566f0a.tar.bz2
gentoo-2-4e9494ca3d0301a4da9e16cdaf7aeb4435566f0a.zip
Crashfix for xen console thanks to Andrew Lyon
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog10
-rw-r--r--app-emulation/xen/files/xen-3.4.2-dump_registers-watchdog-fix.patch19
-rw-r--r--app-emulation/xen/xen-3.4.2-r1.ebuild108
3 files changed, 135 insertions, 2 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index d75cd282bf7e..f842c13df863 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.65 2009/12/01 13:38:55 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.66 2010/01/06 22:05:27 patrick Exp $
+
+*xen-3.4.2-r1 (06 Jan 2010)
+
+ 06 Jan 2010; Patrick Lauer <patrick@gentoo.org> +xen-3.4.2-r1.ebuild,
+ +files/xen-3.4.2-dump_registers-watchdog-fix.patch:
+ Crashfix for xen console thanks to Andrew Lyon
*xen-3.4.2 (01 Dec 2009)
diff --git a/app-emulation/xen/files/xen-3.4.2-dump_registers-watchdog-fix.patch b/app-emulation/xen/files/xen-3.4.2-dump_registers-watchdog-fix.patch
new file mode 100644
index 000000000000..7c8ff5b8a95d
--- /dev/null
+++ b/app-emulation/xen/files/xen-3.4.2-dump_registers-watchdog-fix.patch
@@ -0,0 +1,19 @@
+diff -r 784caad93325 xen/common/keyhandler.c
+--- a/xen/common/keyhandler.c Tue Nov 10 15:03:52 2009 +0000
++++ b/xen/common/keyhandler.c Tue Jan 05 10:47:49 2010 +0000
+@@ -106,6 +106,7 @@
+ unsigned int cpu;
+
+ /* We want to get everything out that we possibly can. */
++ watchdog_disable();
+ console_start_sync();
+
+ printk("'%c' pressed -> dumping registers\n", key);
+@@ -125,6 +126,7 @@
+ printk("\n");
+
+ console_end_sync();
++ watchdog_enable();
+ }
+
+ static void dump_dom0_registers(unsigned char key)
diff --git a/app-emulation/xen/xen-3.4.2-r1.ebuild b/app-emulation/xen/xen-3.4.2-r1.ebuild
new file mode 100644
index 000000000000..4fc352980f23
--- /dev/null
+++ b/app-emulation/xen/xen-3.4.2-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.4.2-r1.ebuild,v 1.1 2010/01/06 22:05:27 patrick Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://xen.org/"
+SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug custom-cflags pae acm flask xsm"
+
+RDEPEND="|| ( sys-boot/grub
+ sys-boot/grub-static )
+ >=sys-kernel/xen-sources-2.6.18"
+PDEPEND="~app-emulation/xen-tools-${PV}"
+
+RESTRICT="test"
+
+# Approved by QA team in bug #144032
+QA_WX_LOAD="boot/xen-syms-${PV}"
+
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+
+ if use xsm ; then
+ export "XSM_ENABLE=y"
+ use acm && export "ACM_SECURITY=y"
+ if use flask ; then
+ ! use acm && export "FLASK_ENABLE=y"
+ use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
+ fi
+ elif use acm || use flask ; then
+ ewarn "acm and flask require USE=xsm to be set, dropping use flags"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix unexport $target in xen-setup
+ epatch "${FILESDIR}/"${PN}-3.3.0-unexported-target-fix.patch
+
+ # Fix crash in xen console
+ epatch "${FILESDIR}/"${P}-dump_registers-watchdog-fix.patch
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ replace-flags -O3 -O2
+ else
+ unset CFLAGS
+ fi
+
+ # Send raw LDFLAGS so that --as-needed works
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+}
+
+src_install() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://en.gentoo-wiki.com/wiki/Xen/"
+
+ if use pae; then
+ echo
+ ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
+ fi
+}