summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ross <aross@gentoo.org>2006-10-06 23:20:25 +0000
committerAndrew Ross <aross@gentoo.org>2006-10-06 23:20:25 +0000
commitaca9c724d9537362489c3d563373842f026fc704 (patch)
tree1dbff429306a3c859f6f3426bf822a46341fc142 /app-emulation/xen
parentMake nss respect CFLAGS thanks to Ed Catmur bug#143619 (diff)
downloadgentoo-2-aca9c724d9537362489c3d563373842f026fc704.tar.gz
gentoo-2-aca9c724d9537362489c3d563373842f026fc704.tar.bz2
gentoo-2-aca9c724d9537362489c3d563373842f026fc704.zip
Allow compilation under AMD64 with a 64 bit kernel but 32 bit userland (#143999).
(Portage version: 2.1.1)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog7
-rw-r--r--app-emulation/xen/xen-3.0.2.ebuild15
2 files changed, 20 insertions, 2 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index f93f83c7be54..8fdcb64c5cd6 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.41 2006/08/15 11:33:46 aross Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.42 2006/10/06 23:20:25 aross Exp $
+
+ 06 Oct 2006; <aross@gentoo.org> xen-3.0.2.ebuild:
+ Allow compilation under AMD64 with a 64 bit kernel but 32 bit userland.
+ Thanks to tonich <tonich@artparade.ru> and Sven Wegener
+ <swegener@gentoo.org> in bug #143999
16 Aug 2006; Andrew Ross <aross@gentoo.org> metadata.xml:
Convert from individual maintainers to xen herd.
diff --git a/app-emulation/xen/xen-3.0.2.ebuild b/app-emulation/xen/xen-3.0.2.ebuild
index b18e181c7802..d0fb237586da 100644
--- a/app-emulation/xen/xen-3.0.2.ebuild
+++ b/app-emulation/xen/xen-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.2.ebuild,v 1.6 2006/08/04 15:09:42 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.0.2.ebuild,v 1.7 2006/10/06 23:20:25 aross Exp $
inherit mount-boot flag-o-matic
@@ -25,6 +25,19 @@ RDEPEND=""
RESTRICT="test"
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+}
+
+
src_unpack() {
unpack ${A}
# if the user *really* wants to use their own custom-cflags, let them