summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-09-01 00:30:53 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-09-01 00:30:53 +0000
commitb5b844602f7536200c4d5f17fc5071df093e5f87 (patch)
tree539f64359d7e3b4608cde0e1b25759956ca7f63d /app-emulation/xen
parentBump wrt bug 226373 (diff)
downloadgentoo-2-b5b844602f7536200c4d5f17fc5071df093e5f87.tar.gz
gentoo-2-b5b844602f7536200c4d5f17fc5071df093e5f87.tar.bz2
gentoo-2-b5b844602f7536200c4d5f17fc5071df093e5f87.zip
Version bump to Xen 3.3 (bug #201792).
Bugs fixed: * Fix invalid sed that broke gcc-4.3 (bug #217151) (Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc4-git1 x86_64)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog10
-rw-r--r--app-emulation/xen/files/xen-sed-gcc.patch22
-rw-r--r--app-emulation/xen/metadata.xml3
-rw-r--r--app-emulation/xen/xen-3.2.1.ebuild10
-rw-r--r--app-emulation/xen/xen-3.3.0.ebuild (renamed from app-emulation/xen/xen-3.2.0.ebuild)27
5 files changed, 62 insertions, 10 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index fbc746bd5459..cd79b6c56797 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.55 2008/07/28 20:50:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.56 2008/09/01 00:30:53 rbu Exp $
+
+*xen-3.3.0 (01 Sep 2008)
+
+ 01 Sep 2008; Robert Buchholz <rbu@gentoo.org> +files/xen-sed-gcc.patch,
+ metadata.xml, -xen-3.2.0.ebuild, xen-3.2.1.ebuild, +xen-3.3.0.ebuild:
+ Version bump to Xen 3.3 (bug #201792).
+ Bugs fixed:
+ * Fix invalid sed that broke gcc-4.3 (bug #217151)
28 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-emulation/xen/files/xen-sed-gcc.patch b/app-emulation/xen/files/xen-sed-gcc.patch
new file mode 100644
index 000000000000..87f6e165551a
--- /dev/null
+++ b/app-emulation/xen/files/xen-sed-gcc.patch
@@ -0,0 +1,22 @@
+# HG changeset patch
+# User Keir Fraser <keir.fraser@citrix.com>
+# Date 1219920196 -3600
+# Node ID 83fb5b3e55e12e2b94d34eb168c3c5c30e75d089
+# Parent 05e59668aa77d9566b22796768f7fe6a6d89b915
+Use 'gcc -v 2>&1 | tail -1' to extract gcc version.
+
+Signed-off-by: Keir Fraser <keir.fraser@citrix.com>
+xen-unstable changeset: 18380:6c6bda7f09cde36fa875941d7202e77620fdc687
+xen-unstable date: Wed Aug 27 11:47:02 2008 +0100
+
+--- a/xen/Makefile Thu Aug 28 11:41:56 2008 +0100
++++ b/xen/Makefile Thu Aug 28 11:43:16 2008 +0100
+@@ -87,7 +87,7 @@ include/xen/compile.h: include/xen/compi
+ -e 's/@@whoami@@/$(XEN_WHOAMI)/g' \
+ -e 's/@@domain@@/$(XEN_DOMAIN)/g' \
+ -e 's/@@hostname@@/$(shell hostname)/g' \
+- -e 's!@@compiler@@!$(shell $(CC) $(CFLAGS) -v 2>&1 | grep -i "gcc.*version")!g' \
++ -e 's!@@compiler@@!$(shell $(CC) $(CFLAGS) -v 2>&1 | tail -1)!g' \
+ -e 's/@@version@@/$(XEN_VERSION)/g' \
+ -e 's/@@subversion@@/$(XEN_SUBVERSION)/g' \
+ -e 's/@@extraversion@@/$(XEN_EXTRAVERSION)/g' \
diff --git a/app-emulation/xen/metadata.xml b/app-emulation/xen/metadata.xml
index 7eec5581c315..8f9af958a8d8 100644
--- a/app-emulation/xen/metadata.xml
+++ b/app-emulation/xen/metadata.xml
@@ -7,5 +7,8 @@
default Xen CFLAGS (not supported)</flag>
<flag name='pae'>Enable support for PAE kernels (usually x86-32 with >4GB
memory)</flag>
+ <flag name='xsm'>Enable the Xen Security Modules (XSM)</flag>
+ <flag name='acm'>Enable the ACM/sHype XSM module from IBM</flag>
+ <flag name='flask'>Enable the Flask XSM module from NSA</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/xen/xen-3.2.1.ebuild b/app-emulation/xen/xen-3.2.1.ebuild
index 07095ba3a0e0..5abf32951a6f 100644
--- a/app-emulation/xen/xen-3.2.1.ebuild
+++ b/app-emulation/xen/xen-3.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.2.1.ebuild,v 1.1 2008/05/04 18:59:13 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.2.1.ebuild,v 1.2 2008/09/01 00:30:53 rbu Exp $
-inherit mount-boot flag-o-matic
+inherit mount-boot flag-o-matic toolchain-funcs
DESCRIPTION="The Xen virtual machine monitor"
HOMEPAGE="http://xen.org/"
@@ -39,6 +39,10 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-sed-gcc.patch
+
# if the user *really* wants to use their own custom-cflags, let them
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
@@ -66,7 +70,7 @@ src_compile() {
fi
# Send raw LDFLAGS so that --as-needed works
- emake LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
}
src_install() {
diff --git a/app-emulation/xen/xen-3.2.0.ebuild b/app-emulation/xen/xen-3.3.0.ebuild
index 42f450a13998..6b76ff98aa1b 100644
--- a/app-emulation/xen/xen-3.2.0.ebuild
+++ b/app-emulation/xen/xen-3.3.0.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.2.0.ebuild,v 1.1 2008/02/08 22:19:23 marineam Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.3.0.ebuild,v 1.1 2008/09/01 00:30:53 rbu Exp $
-inherit mount-boot flag-o-matic
+inherit mount-boot flag-o-matic toolchain-funcs
DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://www.xensource.com/xen/xen/"
-SRC_URI="mirror://gentoo/xen-${PV}.tar.bz2"
+HOMEPAGE="http://xen.org/"
+SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug custom-cflags pae"
+IUSE="debug custom-cflags pae acm flask xsm"
RDEPEND="|| ( sys-boot/grub
sys-boot/grub-static )
@@ -35,10 +35,25 @@ pkg_setup() {
die "Unsupported architecture!"
fi
fi
+
+ if use xsm ; then
+ export "XSM_ENABLE=y"
+ use acm && export "ACM_SECURITY=y"
+ if use flask ; then
+ ! use acm && export "FLASK_ENABLE=y"
+ use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
+ fi
+ elif use acm || use flask ; then
+ ewarn "acm and flask require USE=xsm to be set, dropping use flags"
+ fi
}
src_unpack() {
unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-sed-gcc.patch
+
# if the user *really* wants to use their own custom-cflags, let them
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"
@@ -66,7 +81,7 @@ src_compile() {
fi
# Send raw LDFLAGS so that --as-needed works
- emake LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
}
src_install() {