summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-05 08:38:15 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-05 08:38:15 +0000
commit00c340e2341ac1caed30c49293733e4e16e86dc3 (patch)
tree46752077713623388252bcf74e2a698ad7d46ff0 /app-emulation
parentdrop py2.6 add py3.4 support (diff)
downloadgentoo-2-00c340e2341ac1caed30c49293733e4e16e86dc3.tar.gz
gentoo-2-00c340e2341ac1caed30c49293733e4e16e86dc3.tar.bz2
gentoo-2-00c340e2341ac1caed30c49293733e4e16e86dc3.zip
Add USE=infiniband to control librdma automagic dep.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/qemu-2.0.0-r1.ebuild6
-rw-r--r--app-emulation/qemu/qemu-2.1.0.ebuild6
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild6
4 files changed, 17 insertions, 7 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index fa15d91ba1e1..e3a3f68ee447 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.278 2014/08/05 08:24:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.279 2014/08/05 08:38:15 vapier Exp $
+
+ 05 Aug 2014; Mike Frysinger <vapier@gentoo.org> qemu-2.0.0-r1.ebuild,
+ qemu-2.1.0.ebuild, qemu-9999.ebuild:
+ Add USE=infiniband to control librdma automagic dep.
05 Aug 2014; Mike Frysinger <vapier@gentoo.org> metadata.xml,
qemu-2.1.0.ebuild, qemu-9999.ebuild:
diff --git a/app-emulation/qemu/qemu-2.0.0-r1.ebuild b/app-emulation/qemu/qemu-2.0.0-r1.ebuild
index 14e1e2452114..18393a280668 100644
--- a/app-emulation/qemu/qemu-2.0.0-r1.ebuild
+++ b/app-emulation/qemu/qemu-2.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.0.0-r1.ebuild,v 1.12 2014/08/05 08:21:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.0.0-r1.ebuild,v 1.13 2014/08/05 08:38:15 vapier Exp $
EAPI=5
@@ -30,7 +30,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
-gtk iscsi +jpeg \
+gtk infiniband iscsi +jpeg \
kernel_linux kernel_FreeBSD lzo ncurses nfs nls opengl +png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
@@ -70,6 +70,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
curl? ( >=net-misc/curl-7.15.4[static-libs(+)] )
fdt? ( >=sys-apps/dtc-1.4.0[static-libs(+)] )
glusterfs? ( >=sys-cluster/glusterfs-3.4.0[static-libs(+)] )
+ infiniband? ( sys-infiniband/librdmacm[static-libs(+)] )
jpeg? ( virtual/jpeg[static-libs(+)] )
lzo? ( dev-libs/lzo:2[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
@@ -335,6 +336,7 @@ qemu_src_configure() {
$(use_enable curl)
$(use_enable fdt)
$(use_enable glusterfs)
+ $(use_enable infiniband rdma)
$(use_enable iscsi libiscsi)
$(use_enable jpeg vnc-jpeg)
$(use_enable kernel_linux kvm)
diff --git a/app-emulation/qemu/qemu-2.1.0.ebuild b/app-emulation/qemu/qemu-2.1.0.ebuild
index c98829ae0919..250c96089988 100644
--- a/app-emulation/qemu/qemu-2.1.0.ebuild
+++ b/app-emulation/qemu/qemu-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.5 2014/08/05 08:24:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.6 2014/08/05 08:38:15 vapier Exp $
EAPI=5
@@ -30,7 +30,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
-gtk iscsi +jpeg \
+gtk infiniband iscsi +jpeg \
kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
@@ -70,6 +70,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
curl? ( >=net-misc/curl-7.15.4[static-libs(+)] )
fdt? ( >=sys-apps/dtc-1.4.0[static-libs(+)] )
glusterfs? ( >=sys-cluster/glusterfs-3.4.0[static-libs(+)] )
+ infiniband? ( sys-infiniband/librdmacm[static-libs(+)] )
jpeg? ( virtual/jpeg[static-libs(+)] )
lzo? ( dev-libs/lzo:2[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
@@ -330,6 +331,7 @@ qemu_src_configure() {
$(use_enable curl)
$(use_enable fdt)
$(use_enable glusterfs)
+ $(use_enable infiniband rdma)
$(use_enable iscsi libiscsi)
$(use_enable jpeg vnc-jpeg)
$(use_enable kernel_linux kvm)
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 3429cb8c27d5..d8bcf3755dbc 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.83 2014/08/05 08:24:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.84 2014/08/05 08:38:15 vapier Exp $
EAPI=5
@@ -30,7 +30,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
-gtk iscsi +jpeg \
+gtk infiniband iscsi +jpeg \
kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
@@ -70,6 +70,7 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
curl? ( >=net-misc/curl-7.15.4[static-libs(+)] )
fdt? ( >=sys-apps/dtc-1.4.0[static-libs(+)] )
glusterfs? ( >=sys-cluster/glusterfs-3.4.0[static-libs(+)] )
+ infiniband? ( sys-infiniband/librdmacm[static-libs(+)] )
jpeg? ( virtual/jpeg[static-libs(+)] )
lzo? ( dev-libs/lzo:2[static-libs(+)] )
ncurses? ( sys-libs/ncurses[static-libs(+)] )
@@ -330,6 +331,7 @@ qemu_src_configure() {
$(use_enable curl)
$(use_enable fdt)
$(use_enable glusterfs)
+ $(use_enable infiniband rdma)
$(use_enable iscsi libiscsi)
$(use_enable jpeg vnc-jpeg)
$(use_enable kernel_linux kvm)