summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-03-11 08:31:40 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-03-11 08:31:40 +0000
commit00e0377d73d37f07ec7832875dad874f90abf10e (patch)
treee16e832e89c6117d308dd0642c96dda549eebda2 /app-emulation
parentRevision bump: add support for optional building of CARE binary, wrt bug #502... (diff)
downloadgentoo-2-00e0377d73d37f07ec7832875dad874f90abf10e.tar.gz
gentoo-2-00e0377d73d37f07ec7832875dad874f90abf10e.tar.bz2
gentoo-2-00e0377d73d37f07ec7832875dad874f90abf10e.zip
first 0.7.4 build, no init yet
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cloud-init/ChangeLog10
-rw-r--r--app-emulation/cloud-init/cloud-init-0.7.4.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/app-emulation/cloud-init/ChangeLog b/app-emulation/cloud-init/ChangeLog
index 8aaa6eef1011..7dc85c5e3dc4 100644
--- a/app-emulation/cloud-init/ChangeLog
+++ b/app-emulation/cloud-init/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/cloud-init
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.2 2013/10/29 04:42:05 prometheanfire Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/ChangeLog,v 1.3 2014/03/11 08:31:40 prometheanfire Exp $
+
+*cloud-init-0.7.4 (11 Mar 2014)
+
+ 11 Mar 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +cloud-init-0.7.4.ebuild:
+ first 0.7.4 build, no init yet
29 Oct 2013; Matthew Thode <prometheanfire@gentoo.org>
cloud-init-0.7.2.ebuild:
diff --git a/app-emulation/cloud-init/cloud-init-0.7.4.ebuild b/app-emulation/cloud-init/cloud-init-0.7.4.ebuild
new file mode 100644
index 000000000000..0b8e0d70973f
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-0.7.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cloud-init/cloud-init-0.7.4.ebuild,v 1.1 2014/03/11 08:31:40 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib
+
+DESCRIPTION="Package provides configuration and customization of cloud instance."
+HOMEPAGE="https://launchpad.net/cloud-init"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+
+RDEPEND="dev-python/cheetah[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/oauth[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i "s/'tests'//g" "${S}/setup.py"
+ rm -R "${S}/tests"
+}