summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-22 17:25:19 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-22 17:25:19 +0000
commit2c5c3b44f090a6936b63eefa4114e056a0c40fe9 (patch)
treeeb471bf873cc264203c8954edc8cfd89fa68c0d0 /app-emulation
parentAdd ~alpha/~sh/~sparc wrt #397769 (diff)
downloadgentoo-2-2c5c3b44f090a6936b63eefa4114e056a0c40fe9.tar.gz
gentoo-2-2c5c3b44f090a6936b63eefa4114e056a0c40fe9.tar.bz2
gentoo-2-2c5c3b44f090a6936b63eefa4114e056a0c40fe9.zip
Version bump, remove old (#398443 by b1254633).
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vboxgtk/ChangeLog9
-rw-r--r--app-emulation/vboxgtk/vboxgtk-0.5.0-r1.ebuild46
-rw-r--r--app-emulation/vboxgtk/vboxgtk-0.8.0.ebuild53
3 files changed, 60 insertions, 48 deletions
diff --git a/app-emulation/vboxgtk/ChangeLog b/app-emulation/vboxgtk/ChangeLog
index 898b847dc0da..7fce374ffd92 100644
--- a/app-emulation/vboxgtk/ChangeLog
+++ b/app-emulation/vboxgtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/vboxgtk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vboxgtk/ChangeLog,v 1.5 2012/06/16 07:39:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vboxgtk/ChangeLog,v 1.6 2012/07/22 17:25:18 pacho Exp $
+
+*vboxgtk-0.8.0 (22 Jul 2012)
+
+ 22 Jul 2012; Pacho Ramos <pacho@gentoo.org> +vboxgtk-0.8.0.ebuild,
+ -vboxgtk-0.5.0-r1.ebuild:
+ Version bump, remove old (#398443 by b1254633).
16 Jun 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer as he is not able to maintain this anymore.
@@ -25,4 +31,3 @@
30 May 2009; Mounir Lamouri <volkmar@gentoo.org> +metadata.xml,
+vboxgtk-0.4.1.ebuild:
Initial commit, see bug 254718
-
diff --git a/app-emulation/vboxgtk/vboxgtk-0.5.0-r1.ebuild b/app-emulation/vboxgtk/vboxgtk-0.5.0-r1.ebuild
deleted file mode 100644
index 64e34b48cb62..000000000000
--- a/app-emulation/vboxgtk/vboxgtk-0.5.0-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vboxgtk/vboxgtk-0.5.0-r1.ebuild,v 1.3 2011/04/06 18:14:26 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit gnome2-utils distutils
-
-DESCRIPTION="GTK frontend for VirtualBox"
-HOMEPAGE="http://vboxgtk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="linguas_es"
-
-DEPEND=""
-RDEPEND="
- || ( app-emulation/virtualbox[-headless,sdk]
- >=app-emulation/virtualbox-bin-2.2.2 )
- >=dev-python/pygtk-2.14.0"
-
-src_prepare() {
- if ! use linguas_es; then
- rm po/es.po || die "rm failed"
- fi
- python_convert_shebangs -r 2 .
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- distutils_pkg_postrm
- gnome2_icon_cache_update
-}
diff --git a/app-emulation/vboxgtk/vboxgtk-0.8.0.ebuild b/app-emulation/vboxgtk/vboxgtk-0.8.0.ebuild
new file mode 100644
index 000000000000..eba0deaa8c06
--- /dev/null
+++ b/app-emulation/vboxgtk/vboxgtk-0.8.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vboxgtk/vboxgtk-0.8.0.ebuild,v 1.1 2012/07/22 17:25:18 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit gnome2-utils distutils
+
+DESCRIPTION="GTK frontend for VirtualBox"
+HOMEPAGE="http://code.google.com/p/vboxgtk/"
+SRC_URI="http://vboxgtk.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ || ( app-emulation/virtualbox[-headless,python,sdk]
+ >=app-emulation/virtualbox-bin-2.2.2[python] )
+ >=dev-python/pygobject-2.28.0:2"
+
+PKG_LINGUAS="cs gl"
+for PKG_LINGUA in ${PKG_LINGUAS}; do
+ IUSE="${IUSE} linguas_${PKG_LINGUA/-/_}"
+done
+
+src_prepare() {
+ for LINGUA in ${PKG_LINGUAS}; do
+ if ! use linguas_${LINGUA/-/_}; then
+ rm -r po/"${LINGUA}".po || die "LINGUAS removal failed"
+ fi
+ done
+ python_convert_shebangs -r 2 .
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_icon_cache_update
+}