summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2014-08-10 13:06:49 +0000
committerTiziano Müller <dev-zero@gentoo.org>2014-08-10 13:06:49 +0000
commit42cbb77eba47492c82d05c16e29839386b84ff76 (patch)
treeb2bfa8aa5a0ad7c0b69d3fd11020d38e3a825522 /app-emulation
parentx86 stable, see bug 498184 (diff)
downloadgentoo-2-42cbb77eba47492c82d05c16e29839386b84ff76.tar.gz
gentoo-2-42cbb77eba47492c82d05c16e29839386b84ff76.tar.bz2
gentoo-2-42cbb77eba47492c82d05c16e29839386b84ff76.zip
Rev.bump to pull in media-libs/opus to avoid automagic dep (bug #518546). Pull more patches from upstream.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x1A5D023975B0583D!)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/spice/ChangeLog11
-rw-r--r--app-emulation/spice/files/spice-0.12.5-fix-crash-when-clearing-surface-memory.patch31
-rw-r--r--app-emulation/spice/files/spice-0.12.5-server-dont-assert-on-invalid-client-message.patch30
-rw-r--r--app-emulation/spice/spice-0.12.5-r1.ebuild (renamed from app-emulation/spice/spice-0.12.5.ebuild)7
4 files changed, 76 insertions, 3 deletions
diff --git a/app-emulation/spice/ChangeLog b/app-emulation/spice/ChangeLog
index c223912b4de2..b2f17635760e 100644
--- a/app-emulation/spice/ChangeLog
+++ b/app-emulation/spice/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emulation/spice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.60 2014/08/06 06:44:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/ChangeLog,v 1.61 2014/08/10 13:06:49 dev-zero Exp $
+
+*spice-0.12.5-r1 (10 Aug 2014)
+
+ 10 Aug 2014; Tiziano Müller <dev-zero@gentoo.org>
+ +files/spice-0.12.5-fix-crash-when-clearing-surface-memory.patch,
+ +files/spice-0.12.5-server-dont-assert-on-invalid-client-message.patch,
+ +spice-0.12.5-r1.ebuild, -spice-0.12.5.ebuild:
+ Rev.bump to pull in media-libs/opus to avoid automagic dep (bug #518546). Pull
+ more patches from upstream.
06 Aug 2014; Patrick Lauer <patrick@gentoo.org> spice-0.12.2.ebuild,
spice-0.12.3-r1.ebuild, spice-0.12.4-r1.ebuild, spice-0.12.5.ebuild:
diff --git a/app-emulation/spice/files/spice-0.12.5-fix-crash-when-clearing-surface-memory.patch b/app-emulation/spice/files/spice-0.12.5-fix-crash-when-clearing-surface-memory.patch
new file mode 100644
index 000000000000..b14a56b1d245
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.12.5-fix-crash-when-clearing-surface-memory.patch
@@ -0,0 +1,31 @@
+From 1898f3949cf75422aa1fedba40c429b28d8d6b67 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@gmail.com>
+Date: Wed, 6 Aug 2014 18:34:56 +0200
+Subject: Fix crash when clearing surface memory
+
+The beginning of the surface data needs to be computed correctly if the
+stride is negative, otherwise, it should point already to the beginning
+of the surface data. This bug seems to exists since 4a208b (0.5.2)
+
+https://bugzilla.redhat.com/show_bug.cgi?id=1029646
+
+diff --git a/server/red_worker.c b/server/red_worker.c
+index 6bdad93..35a1a04 100644
+--- a/server/red_worker.c
++++ b/server/red_worker.c
+@@ -9470,7 +9470,11 @@ static inline void red_create_surface(RedWorker *worker, uint32_t surface_id, ui
+ surface->context.stride = stride;
+ surface->context.line_0 = line_0;
+ if (!data_is_valid) {
+- memset((char *)line_0 + (int32_t)(stride * (height - 1)), 0, height*abs(stride));
++ char *data = line_0;
++ if (stride < 0) {
++ data -= abs(stride) * (height - 1);
++ }
++ memset(data, 0, height*abs(stride));
+ }
+ surface->create.info = NULL;
+ surface->destroy.info = NULL;
+--
+cgit v0.10.2
+
diff --git a/app-emulation/spice/files/spice-0.12.5-server-dont-assert-on-invalid-client-message.patch b/app-emulation/spice/files/spice-0.12.5-server-dont-assert-on-invalid-client-message.patch
new file mode 100644
index 000000000000..d9b49a4abb27
--- /dev/null
+++ b/app-emulation/spice/files/spice-0.12.5-server-dont-assert-on-invalid-client-message.patch
@@ -0,0 +1,30 @@
+From 3c25192ee90f843a2f84ff99d119b1cb45979bac Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@gmail.com>
+Date: Wed, 25 Jun 2014 14:36:03 +0200
+Subject: server: don't assert on invalid client message
+
+Some users have been reaching this error:
+snd_receive: ASSERT n failed
+
+A misbehaving client could easily hit that condition by sending too big
+messages. Instead of assert(), replace with a warning. When a message
+too big to fit is received, it will simply disconnect the channel.
+
+https://bugzilla.redhat.com/show_bug.cgi?id=962187
+
+diff --git a/server/snd_worker.c b/server/snd_worker.c
+index 7d52ded..70148b7 100644
+--- a/server/snd_worker.c
++++ b/server/snd_worker.c
+@@ -421,7 +421,7 @@ static void snd_receive(void* data)
+ for (;;) {
+ ssize_t n;
+ n = channel->receive_data.end - channel->receive_data.now;
+- spice_assert(n);
++ spice_warn_if(n <= 0);
+ n = reds_stream_read(channel->stream, channel->receive_data.now, n);
+ if (n <= 0) {
+ if (n == 0) {
+--
+cgit v0.10.2
+
diff --git a/app-emulation/spice/spice-0.12.5.ebuild b/app-emulation/spice/spice-0.12.5-r1.ebuild
index e5bda727d8cf..011b4d8142c6 100644
--- a/app-emulation/spice/spice-0.12.5.ebuild
+++ b/app-emulation/spice/spice-0.12.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.5.ebuild,v 1.2 2014/08/06 06:44:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/spice/spice-0.12.5-r1.ebuild,v 1.1 2014/08/10 13:06:49 dev-zero Exp $
EAPI=5
@@ -22,6 +22,7 @@ IUSE="client sasl smartcard static-libs" # static
RDEPEND=">=x11-libs/pixman-0.17.7[static-libs(+)?]
>=dev-libs/glib-2.22:2[static-libs(+)?]
>=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
+ media-libs/opus[static-libs(+)?]
dev-libs/openssl[static-libs(+)?]
virtual/jpeg[static-libs(+)?]
sys-libs/zlib[static-libs(+)?]
@@ -57,7 +58,9 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}/0.11.0-gold.patch" \
- "${FILESDIR}/${P}-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch"
+ "${FILESDIR}/${P}-fix-assert-in-mjpeg_encoder_adjust_params_to_bit_rate.patch" \
+ "${FILESDIR}/${P}-server-dont-assert-on-invalid-client-message.patch" \
+ "${FILESDIR}/${P}-fix-crash-when-clearing-surface-memory.patch"
epatch_user
}