summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-04-14 16:23:58 +0000
committerDan Armak <danarmak@gentoo.org>2002-04-14 16:23:58 +0000
commit53331f70419f5214ed8d978347b254904c3d93cf (patch)
tree3621c1bbfd2207ab2880c171e302418b3b8cdd5b /app-emulation
parentdisable fast-malloc optimization if `arch`=pcc since it doesn't work there (diff)
downloadgentoo-2-53331f70419f5214ed8d978347b254904c3d93cf.tar.gz
gentoo-2-53331f70419f5214ed8d978347b254904c3d93cf.tar.bz2
gentoo-2-53331f70419f5214ed8d978347b254904c3d93cf.zip
new version
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog7
-rw-r--r--app-emulation/wine/files/digest-wine-200204111
-rw-r--r--app-emulation/wine/wine-20020411.ebuild93
3 files changed, 100 insertions, 1 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index bc1938130ab0..0d715a4b6d79 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.6 2002/03/29 16:29:47 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.7 2002/04/14 16:23:55 danarmak Exp $
+
+*wine-20020411 (14 Apr 2002)
+
+ 14 Apr 2002; Dan Armak <danarmak@gentoo.org>: new upstream release
+
*wine-20020310-r1 (29 Mar 2002)
diff --git a/app-emulation/wine/files/digest-wine-20020411 b/app-emulation/wine/files/digest-wine-20020411
new file mode 100644
index 000000000000..9db176c3004e
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-20020411
@@ -0,0 +1 @@
+MD5 a86f56f1cee754f46eae63474515fef7 Wine-20020411.tar.gz 7270988
diff --git a/app-emulation/wine/wine-20020411.ebuild b/app-emulation/wine/wine-20020411.ebuild
new file mode 100644
index 000000000000..c52836f201ee
--- /dev/null
+++ b/app-emulation/wine/wine-20020411.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20020411.ebuild,v 1.1 2002/04/14 16:23:58 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Wine is a free implementation of Windows on Unix."
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/ALPHA/wine/development/Wine-${PV}.tar.gz"
+HOMEPAGE="http://www.winehq.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/wine \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all manpages || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ cd ${S}
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ cd ${S}/programs
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/bin
+ chmod a-x *.so
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ cd ${S}/documentation
+ doman man3w/*
+ doman *.man
+ dohtml *.sgml
+
+ insinto /etc/wine
+ doins samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.wine
+ dosym /etc/wine/config /etc/skel/.wine/config
+
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing wine for the first time,
+copy /etc/wine/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, wine will
+not run.
+Also, run \"regapi setValue < /etc/wine/winedefault.reg\" to setup
+per-user registry for using wine. More info in /usr/share/doc/wine-${PV}."
+
+}