summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-02-18 16:15:56 +0000
committerTilman Klar <phoenix@gentoo.org>2003-02-18 16:15:56 +0000
commit6cb08bbc8109ceffe2922c9cea7854769454ff45 (patch)
tree5fbf8ede2826a58c9604816e44a217546a077767 /app-emulation
parentMasking app-emulation/winex-transgaming because i'm unable to test it (i'm no... (diff)
downloadgentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.tar.gz
gentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.tar.bz2
gentoo-2-6cb08bbc8109ceffe2922c9cea7854769454ff45.zip
Adding new package to the tree: winex-transgaming. See bug #11023 for further details.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winex-transgaming/ChangeLog15
-rw-r--r--app-emulation/winex-transgaming/files/digest-winex-transgaming-2.2.11
-rw-r--r--app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild69
3 files changed, 85 insertions, 0 deletions
diff --git a/app-emulation/winex-transgaming/ChangeLog b/app-emulation/winex-transgaming/ChangeLog
new file mode 100644
index 000000000000..f95f89483b06
--- /dev/null
+++ b/app-emulation/winex-transgaming/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for app-emulation/winex-transgaming
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/ChangeLog,v 1.1 2003/02/18 16:15:56 phoenix Exp $
+
+*winex-transgaming-2.2.1 (18 Feb 2002)
+
+ 18 Feb 2002; phoen][x <phoenix@gentoo.org> ChangeLog, winex-transgaming-2.2.1.ebuild,
+ digest-winex-transgaming-2.2.1 :
+ Initial import. Ebuild submitted by Max Kalika <alkern23@yahoo.com> (bug #11023).
+ This ebuild gives users the possibility, to install transgamings winex distribution.
+ In order to install it, you have to fetch the winex tarball from the transgaming download-
+ section (http://www.transgaming.com/download.php) - you must be an official transgaming
+ subscriber to enter the download area, though. This package currently blocks
+ app-emulation/winex (they share the same locations, and cannot be installed at the same time).
+ Do not mail Max or me - we will not give you the tarball.
diff --git a/app-emulation/winex-transgaming/files/digest-winex-transgaming-2.2.1 b/app-emulation/winex-transgaming/files/digest-winex-transgaming-2.2.1
new file mode 100644
index 000000000000..f31d765bb36b
--- /dev/null
+++ b/app-emulation/winex-transgaming/files/digest-winex-transgaming-2.2.1
@@ -0,0 +1 @@
+MD5 e824168613fbc0712425822c010527d3 winex-2.2.1.tgz 5166125
diff --git a/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
new file mode 100644
index 000000000000..703a74497ea9
--- /dev/null
+++ b/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex-transgaming/winex-transgaming-2.2.1.ebuild,v 1.1 2003/02/18 16:15:56 phoenix Exp $
+
+IUSE="cups opengl"
+
+P="winex-${PV}"
+SRC_URI="${P}.tgz"
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="Transgaming"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ !app-emulation/winex"
+
+src_unpack () {
+
+ if [ ! -e "${DISTDIR}/${P}.tgz" ] ; then
+ eerror ""
+ eerror "Please download the appropriate WineX archive (${P}.tgz)"
+ eerror "from: ${HOMEPAGE} (requires a Transgaming subscription)."
+ eerror ""
+ eerror "The archive should be placed into ${DISTDIR}."
+ die "package archive (${P}.tgz) not found"
+ fi
+
+ mkdir ${S}
+ tar -C ${S} -xzf ${DISTDIR}/${P}.tgz
+
+}
+
+src_install () {
+
+ mv ${S}/usr ${D}
+
+}
+
+pkg_postinst() {
+
+ einfo ""
+ einfo "Run /usr/bin/winex to start winex as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the winex wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/winex:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to /etc/modules.autoload."
+ einfo ""
+
+}