summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-09-27 21:14:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-09-27 21:14:09 +0000
commit8577c48745837098713d17e8de3fb1cc85885a6c (patch)
treef23e82d5432c91135d28f032fe478bb8a8c97de3 /app-emulation
parentVersion bump. (diff)
downloadgentoo-2-8577c48745837098713d17e8de3fb1cc85885a6c.tar.gz
gentoo-2-8577c48745837098713d17e8de3fb1cc85885a6c.tar.bz2
gentoo-2-8577c48745837098713d17e8de3fb1cc85885a6c.zip
Proxy commit for Ian "idella4" Delaney. LDFLAGS respect closes bug #384351. Removal of static libraries closes bug #384355. Use toolchain function instead of calling LD directly, closes bug #384359.
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog10
-rw-r--r--app-emulation/xen-tools/files/xen-tools-3.4.2-ldflags-respect.patch31
-rw-r--r--app-emulation/xen-tools/xen-tools-3.4.2-r5.ebuild (renamed from app-emulation/xen-tools/xen-tools-3.4.2-r4.ebuild)10
3 files changed, 48 insertions, 3 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 63ca11d31fa0..8bbcbed067f0 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.94 2011/09/25 19:45:22 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.95 2011/09/27 21:14:09 chainsaw Exp $
+
+*xen-tools-3.4.2-r5 (27 Sep 2011)
+
+ 27 Sep 2011; Tony Vroon <chainsaw@gentoo.org> -xen-tools-3.4.2-r4.ebuild,
+ +xen-tools-3.4.2-r5.ebuild, +files/xen-tools-3.4.2-ldflags-respect.patch:
+ Proxy commit for Ian "idella4" Delaney. LDFLAGS respect closes bug #384351.
+ Removal of static libraries closes bug #384355. Use toolchain function
+ instead of calling LD directly, closes bug #384359.
*xen-tools-3.4.2-r4 (25 Sep 2011)
diff --git a/app-emulation/xen-tools/files/xen-tools-3.4.2-ldflags-respect.patch b/app-emulation/xen-tools/files/xen-tools-3.4.2-ldflags-respect.patch
new file mode 100644
index 000000000000..fd777126d498
--- /dev/null
+++ b/app-emulation/xen-tools/files/xen-tools-3.4.2-ldflags-respect.patch
@@ -0,0 +1,31 @@
+--- ./tools/fs-back/Makefile 2011-09-26 23:14:30.454759297 +0800
++++ ./tools/fs-back/Makefile 2011-09-27 16:37:57.445748680 +0800
+@@ -23,7 +23,7 @@
+ all: $(IBIN)
+
+ fs-backend: $(OBJS) fs-backend.c
+- $(CC) $(CFLAGS) -o fs-backend $(OBJS) $(LIBS) fs-backend.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fs-backend $(OBJS) $(LIBS) fs-backend.c
+
+ install: all
+ $(INSTALL_PROG) $(IBIN) $(DESTDIR)$(SBINDIR)
+--- ./tools/libfsimage/common/Makefile 2009-11-10 23:12:56.000000000 +0800
++++ ./tools/libfsimage/common/Makefile 2011-09-27 16:41:16.516748626 +0800
+@@ -6,7 +6,7 @@
+
+ LDFLAGS-$(CONFIG_SunOS) = -Wl,-M -Wl,mapfile-SunOS
+ LDFLAGS-$(CONFIG_Linux) = -Wl,mapfile-GNU
+-LDFLAGS = $(LDFLAGS-y)
++#LDFLAGS = $(LDFLAGS-y)
+
+ LIB_SRCS-y = fsimage.c fsimage_plugin.c fsimage_grub.c
+
+--- ./tools/misc/lomount/Makefile 2011-09-27 14:23:26.596752233 +0800
++++ ./tools/misc/lomount/Makefile 2011-09-27 16:37:57.445748680 +0800
+@@ -23,5 +23,5 @@
+ $(RM) *.a *.so *.o *.rpm $(BIN)
+
+ %: %.c $(HDRS) Makefile
+- $(CC) $(CFLAGS) -o $@ $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
+
diff --git a/app-emulation/xen-tools/xen-tools-3.4.2-r4.ebuild b/app-emulation/xen-tools/xen-tools-3.4.2-r5.ebuild
index f7f92c77235d..393c6c849eaa 100644
--- a/app-emulation/xen-tools/xen-tools-3.4.2-r4.ebuild
+++ b/app-emulation/xen-tools/xen-tools-3.4.2-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.4.2-r4.ebuild,v 1.1 2011/09/25 19:45:22 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.4.2-r5.ebuild,v 1.1 2011/09/27 21:14:09 chainsaw Exp $
EAPI="3"
@@ -62,6 +62,7 @@ PATCHES=(
"${FILESDIR}/${P}-fix-definitions.patch"
"${FILESDIR}/${P}-fix-include.patch"
"${FILESDIR}/${P}-werror-idiocy-v2.patch"
+ "${FILESDIR}/${P}-ldflags-respect.patch"
)
# hvmloader is used to bootstrap a fully virtualized kernel
@@ -131,7 +132,7 @@ src_compile() {
append-flags -fno-strict-overflow
fi
- emake CC=$(tc-getCC) -C tools ${myopt} || die "compile failed"
+ emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools ${myopt} || die "compile failed"
if use doc; then
sh ./docs/check_pkgs || die "package check failed"
@@ -149,6 +150,11 @@ src_install() {
# Remove RedHat-specific stuff
rm -rf "${D}"/etc/sysconfig
+ # Remove unneeded static-libs
+ rm "${D}"/usr/lib64/libxenctrl.a "${D}"/usr/lib64/libxenguest.a \
+ "${D}"/usr/lib64/libflask.a "${D}"/usr/lib64/libxenstore.a \
+ "${D}"/usr/lib64/libblktap.a "${D}"/usr/lib64/libxenapi.a
+
dodoc README docs/README.xen-bugtool docs/ChangeLog
if use doc; then
emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs \