summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-02-10 21:47:50 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-02-10 21:47:50 +0000
commitbcefe63da50c2bf5ab467675f5202b740862212a (patch)
tree2477c0160318a94d22e935130bedf0913e4cebc1 /app-emulation
parentRemove deprecated key from desktop file (diff)
downloadgentoo-2-bcefe63da50c2bf5ab467675f5202b740862212a.tar.gz
gentoo-2-bcefe63da50c2bf5ab467675f5202b740862212a.tar.bz2
gentoo-2-bcefe63da50c2bf5ab467675f5202b740862212a.zip
Fix python build depends. bug #448264, thanks to David Weber <davidwerbung@gmx.de>
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-guest-agent/ChangeLog9
-rw-r--r--app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild13
2 files changed, 16 insertions, 6 deletions
diff --git a/app-emulation/qemu-guest-agent/ChangeLog b/app-emulation/qemu-guest-agent/ChangeLog
index fa55fca9ecae..b396b63c57ce 100644
--- a/app-emulation/qemu-guest-agent/ChangeLog
+++ b/app-emulation/qemu-guest-agent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-guest-agent
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-guest-agent/ChangeLog,v 1.6 2012/12/13 20:06:02 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-guest-agent/ChangeLog,v 1.7 2013/02/10 21:47:50 cardoe Exp $
+
+ 10 Feb 2013; Doug Goldstein <cardoe@gentoo.org>
+ qemu-guest-agent-1.2.0.ebuild:
+ Fix python build depends. bug #448264, thanks to David Weber
+ <davidwerbung@gmx.de>
13 Dec 2012; Samuli Suominen <ssuominen@gentoo.org>
qemu-guest-agent-1.1.1.ebuild, qemu-guest-agent-1.2.0.ebuild:
diff --git a/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild b/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild
index d4c1b3446496..96ae218d16ff 100644
--- a/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild
+++ b/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild,v 1.2 2012/12/13 20:06:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-guest-agent/qemu-guest-agent-1.2.0.ebuild,v 1.3 2013/02/10 21:47:50 cardoe Exp $
EAPI=4
-inherit systemd udev
+inherit systemd udev python
MY_PN="qemu"
MY_P="${MY_PN}-${PV}"
@@ -29,11 +29,16 @@ IUSE=""
DEPEND=">=dev-libs/glib-2.22"
RDEPEND="${DEPEND}
!<app-emulation/qemu-1.1.1-r1"
+PYTHON_DEPEND="2:2.4"
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_configure() {
- ./configure
+ ./configure --python=python2
}
src_compile() {