summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-10-24 21:57:11 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-10-24 21:57:11 +0000
commitfaee8e3497f1959a706cbbf12ab5ac117730c0f9 (patch)
treea73ba800bb5bbd8678b66c8b65edcd578afd6421 /app-emulation
parentRespect CFLAGS. (diff)
downloadgentoo-2-faee8e3497f1959a706cbbf12ab5ac117730c0f9.tar.gz
gentoo-2-faee8e3497f1959a706cbbf12ab5ac117730c0f9.tar.bz2
gentoo-2-faee8e3497f1959a706cbbf12ab5ac117730c0f9.zip
Fixed bug #350237, #366305, #376531 and #382061
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox/ChangeLog9
-rw-r--r--app-emulation/virtualbox/virtualbox-4.0.12.ebuild29
-rw-r--r--app-emulation/virtualbox/virtualbox-4.1.2.ebuild29
-rw-r--r--app-emulation/virtualbox/virtualbox-4.1.4.ebuild29
4 files changed, 71 insertions, 25 deletions
diff --git a/app-emulation/virtualbox/ChangeLog b/app-emulation/virtualbox/ChangeLog
index d5e6f45653d7..b2c19adfc1e2 100644
--- a/app-emulation/virtualbox/ChangeLog
+++ b/app-emulation/virtualbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/virtualbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.87 2011/10/23 13:14:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/ChangeLog,v 1.88 2011/10/24 21:57:11 polynomial-c Exp $
+
+ 24 Oct 2011; Lars Wendler <polynomial-c@gentoo.org> virtualbox-4.0.12.ebuild,
+ virtualbox-4.1.2.ebuild, virtualbox-4.1.4.ebuild:
+ Forced python-2 on installation (bug #350237). Made the package's decription
+ the same as virtualbox-bin (bug #366305). Made pam support optional with
+ changes provided by René 'Necoro' Neumann (bug #376531). Added
+ vboxwebsrv<->java dependency to REQUIRED_USE (bug #382061).
23 Oct 2011; Patrick Lauer <patrick@gentoo.org> virtualbox-9999.ebuild:
Fixing deps of the 9999 ebuild so that it might maybe build
diff --git a/app-emulation/virtualbox/virtualbox-4.0.12.ebuild b/app-emulation/virtualbox/virtualbox-4.0.12.ebuild
index 61eae1a32f52..9d505ea7b781 100644
--- a/app-emulation/virtualbox/virtualbox-4.0.12.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.0.12.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.0.12.ebuild,v 1.5 2011/08/20 21:05:44 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.0.12.ebuild,v 1.6 2011/10/24 21:57:11 polynomial-c Exp $
EAPI=4
-inherit eutils fdo-mime flag-o-matic linux-info pax-utils qt4-r2 toolchain-funcs java-pkg-opt-2
+inherit eutils fdo-mime flag-o-matic linux-info pax-utils python qt4-r2 toolchain-funcs java-pkg-opt-2
if [[ ${PV} == "9999" ]] ; then
# XXX: should finish merging the -9999 ebuild into this one ...
@@ -16,13 +16,13 @@ else
S="${WORKDIR}/${MY_P}_OSE"
fi
-DESCRIPTION="Software family of powerful x86 virtualization"
+DESCRIPTION="Family of powerful x86 virtualization products for enterprise as well as home use"
HOMEPAGE="http://www.virtualbox.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+additions alsa doc extensions headless java pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
+IUSE="+additions alsa doc extensions headless java pam pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
RDEPEND="!app-emulation/virtualbox-bin
~app-emulation/virtualbox-modules-${PV}
@@ -56,7 +56,7 @@ DEPEND="${RDEPEND}
sys-devel/dev86
sys-power/iasl
media-libs/libpng
- sys-libs/pam
+ pam? ( sys-libs/pam )
sys-libs/libcap
doc? (
dev-texlive/texlive-basic
@@ -71,7 +71,6 @@ DEPEND="${RDEPEND}
alsa? ( >=media-libs/alsa-lib-1.0.13 )
!headless? ( x11-libs/libXinerama )
pulseaudio? ( media-sound/pulseaudio )
- python? ( >=dev-lang/python-2.3[threads] )
vboxwebsrv? ( >=net-libs/gsoap-2.7.13 )"
PDEPEND="additions? ( ~app-emulation/virtualbox-additions-${PV} )
extensions? ( ~app-emulation/virtualbox-extpack-oracle-${PV} )"
@@ -110,7 +109,11 @@ QA_TEXTRELS_x86="usr/lib/virtualbox-ose/VBoxGuestPropSvc.so
usr/lib/virtualbox/VBoxOGLhostcrutil.so
usr/lib/virtualbox/VBoxNetDHCP.so"
-REQUIRED_USE="java? ( sdk ) python? ( sdk )"
+REQUIRED_USE="
+ java? ( sdk )
+ python? ( sdk )
+ vboxwebsrv? ( java )
+"
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c | grep -qv -E "hardenednopie|vanilla"; then
@@ -135,6 +138,8 @@ pkg_setup() {
einfo "the OpenGL feature."
fi
java-pkg-opt-2_pkg_setup
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -160,6 +165,14 @@ src_prepare() {
# We still want to use ${HOME}/.VirtualBox/Machines as machines dir.
epatch "${FILESDIR}/${PN}-4.0.2-restore_old_machines_dir.patch"
+ # Use PAM only when pam USE flag is enbaled (bug #376531)
+ if ! use pam ; then
+ elog "Disabling PAM removes the possibility to use the VRDP features."
+ sed -i 's/^.*VBOX_WITH_PAM/#VBOX_WITH_PAM/' Config.kmk || die
+ sed -i 's;\(.*/auth/Makefile.kmk.*\);#\1;' \
+ src/VBox/HostServices/Makefile.kmk || die
+ fi
+
# add correct java path
if use java ; then
sed "s:/usr/lib/jvm/java-6-sun:$(java-config -O):" \
@@ -201,7 +214,7 @@ src_compile() {
# strip-flags
MAKE="kmk" emake \
- VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo \
+ VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo_ \
TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
diff --git a/app-emulation/virtualbox/virtualbox-4.1.2.ebuild b/app-emulation/virtualbox/virtualbox-4.1.2.ebuild
index 2445da5c3d33..87ae990c4cb2 100644
--- a/app-emulation/virtualbox/virtualbox-4.1.2.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.1.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.2.ebuild,v 1.1 2011/08/17 23:37:47 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.2.ebuild,v 1.2 2011/10/24 21:57:11 polynomial-c Exp $
EAPI=4
-inherit eutils fdo-mime flag-o-matic linux-info pax-utils qt4-r2 toolchain-funcs java-pkg-opt-2
+inherit eutils fdo-mime flag-o-matic linux-info pax-utils python qt4-r2 toolchain-funcs java-pkg-opt-2
if [[ ${PV} == "9999" ]] ; then
# XXX: should finish merging the -9999 ebuild into this one ...
@@ -16,13 +16,13 @@ else
S="${WORKDIR}/${MY_P}_OSE"
fi
-DESCRIPTION="Software family of powerful x86 virtualization"
+DESCRIPTION="Family of powerful x86 virtualization products for enterprise as well as home use"
HOMEPAGE="http://www.virtualbox.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+additions alsa doc extensions headless java pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
+IUSE="+additions alsa doc extensions headless java pam pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
RDEPEND="!app-emulation/virtualbox-bin
~app-emulation/virtualbox-modules-${PV}
@@ -56,7 +56,7 @@ DEPEND="${RDEPEND}
sys-devel/dev86
sys-power/iasl
media-libs/libpng
- sys-libs/pam
+ pam? ( sys-libs/pam )
sys-libs/libcap
doc? (
dev-texlive/texlive-basic
@@ -71,7 +71,6 @@ DEPEND="${RDEPEND}
alsa? ( >=media-libs/alsa-lib-1.0.13 )
!headless? ( x11-libs/libXinerama )
pulseaudio? ( media-sound/pulseaudio )
- python? ( >=dev-lang/python-2.3[threads] )
vboxwebsrv? ( >=net-libs/gsoap-2.7.13 )"
PDEPEND="additions? ( ~app-emulation/virtualbox-additions-${PV} )
extensions? ( ~app-emulation/virtualbox-extpack-oracle-${PV} )"
@@ -110,7 +109,11 @@ QA_TEXTRELS_x86="usr/lib/virtualbox-ose/VBoxGuestPropSvc.so
usr/lib/virtualbox/VBoxOGLhostcrutil.so
usr/lib/virtualbox/VBoxNetDHCP.so"
-REQUIRED_USE="java? ( sdk ) python? ( sdk )"
+REQUIRED_USE="
+ java? ( sdk )
+ python? ( sdk )
+ vboxwebsrv? ( java )
+"
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c | grep -qv -E "hardenednopie|vanilla"; then
@@ -135,6 +138,8 @@ pkg_setup() {
einfo "the OpenGL feature."
fi
java-pkg-opt-2_pkg_setup
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -163,6 +168,14 @@ src_prepare() {
# Don't build vboxpci.ko module (D'oh!)
epatch "${FILESDIR}"/${P}-vboxpci-build.patch
+ # Use PAM only when pam USE flag is enbaled (bug #376531)
+ if ! use pam ; then
+ elog "Disabling PAM removes the possibility to use the VRDP features."
+ sed -i 's/^.*VBOX_WITH_PAM/#VBOX_WITH_PAM/' Config.kmk || die
+ sed -i 's;\(.*/auth/Makefile.kmk.*\);#\1;' \
+ src/VBox/HostServices/Makefile.kmk || die
+ fi
+
# add correct java path
if use java ; then
sed "s:/usr/lib/jvm/java-6-sun:$(java-config -O):" \
@@ -204,7 +217,7 @@ src_compile() {
# strip-flags
MAKE="kmk" emake \
- VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo \
+ VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo_ \
TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \
diff --git a/app-emulation/virtualbox/virtualbox-4.1.4.ebuild b/app-emulation/virtualbox/virtualbox-4.1.4.ebuild
index e0767184908a..edf56d07d98e 100644
--- a/app-emulation/virtualbox/virtualbox-4.1.4.ebuild
+++ b/app-emulation/virtualbox/virtualbox-4.1.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.4.ebuild,v 1.1 2011/10/04 18:00:30 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox/virtualbox-4.1.4.ebuild,v 1.2 2011/10/24 21:57:11 polynomial-c Exp $
EAPI=4
-inherit eutils fdo-mime flag-o-matic linux-info pax-utils qt4-r2 toolchain-funcs java-pkg-opt-2
+inherit eutils fdo-mime flag-o-matic linux-info pax-utils python qt4-r2 toolchain-funcs java-pkg-opt-2
if [[ ${PV} == "9999" ]] ; then
# XXX: should finish merging the -9999 ebuild into this one ...
@@ -16,13 +16,13 @@ else
S="${WORKDIR}/${MY_P}_OSE"
fi
-DESCRIPTION="Software family of powerful x86 virtualization"
+DESCRIPTION="Family of powerful x86 virtualization products for enterprise as well as home use"
HOMEPAGE="http://www.virtualbox.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+additions alsa doc extensions headless java pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
+IUSE="+additions alsa doc extensions headless java pam pulseaudio +opengl python +qt4 +sdk vboxwebsrv vnc"
RDEPEND="!app-emulation/virtualbox-bin
~app-emulation/virtualbox-modules-${PV}
@@ -56,7 +56,7 @@ DEPEND="${RDEPEND}
sys-devel/dev86
sys-power/iasl
media-libs/libpng
- sys-libs/pam
+ pam? ( sys-libs/pam )
sys-libs/libcap
doc? (
dev-texlive/texlive-basic
@@ -71,7 +71,6 @@ DEPEND="${RDEPEND}
alsa? ( >=media-libs/alsa-lib-1.0.13 )
!headless? ( x11-libs/libXinerama )
pulseaudio? ( media-sound/pulseaudio )
- python? ( >=dev-lang/python-2.3[threads] )
vboxwebsrv? ( >=net-libs/gsoap-2.7.13 )"
PDEPEND="additions? ( ~app-emulation/virtualbox-additions-${PV} )
extensions? ( ~app-emulation/virtualbox-extpack-oracle-${PV} )"
@@ -110,7 +109,11 @@ QA_TEXTRELS_x86="usr/lib/virtualbox-ose/VBoxGuestPropSvc.so
usr/lib/virtualbox/VBoxOGLhostcrutil.so
usr/lib/virtualbox/VBoxNetDHCP.so"
-REQUIRED_USE="java? ( sdk ) python? ( sdk )"
+REQUIRED_USE="
+ java? ( sdk )
+ python? ( sdk )
+ vboxwebsrv? ( java )
+"
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c | grep -qv -E "hardenednopie|vanilla"; then
@@ -135,6 +138,8 @@ pkg_setup() {
einfo "the OpenGL feature."
fi
java-pkg-opt-2_pkg_setup
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
@@ -163,6 +168,14 @@ src_prepare() {
# Don't build vboxpci.ko module (D'oh!)
epatch "${FILESDIR}"/${PN}-4.1.2-vboxpci-build.patch
+ # Use PAM only when pam USE flag is enbaled (bug #376531)
+ if ! use pam ; then
+ elog "Disabling PAM removes the possibility to use the VRDP features."
+ sed -i 's/^.*VBOX_WITH_PAM/#VBOX_WITH_PAM/' Config.kmk || die
+ sed -i 's;\(.*/auth/Makefile.kmk.*\);#\1;' \
+ src/VBox/HostServices/Makefile.kmk || die
+ fi
+
# add correct java path
if use java ; then
sed "s:/usr/lib/jvm/java-6-sun:$(java-config -O):" \
@@ -204,7 +217,7 @@ src_compile() {
# strip-flags
MAKE="kmk" emake \
- VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo \
+ VBOX_VERSION_STRING='$(VBOX_VERSION_MAJOR).$(VBOX_VERSION_MINOR).$(VBOX_VERSION_BUILD)'-Gentoo_ \
TOOL_GCC3_CC="$(tc-getCC)" TOOL_GCC3_CXX="$(tc-getCXX)" \
TOOL_GCC3_AS="$(tc-getCC)" TOOL_GCC3_AR="$(tc-getAR)" \
TOOL_GCC3_LD="$(tc-getCXX)" TOOL_GCC3_LD_SYSMOD="$(tc-getLD)" \