summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-27 09:22:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-27 09:22:35 +0000
commit26e937b0bea5ca01b8f2a5d651ec696f07dc5995 (patch)
tree227770dffd816cceb63a15f9811fcd33c40cfd73 /app-forensics
parenttokyocabinet is not optional. Bug #432840 (diff)
downloadgentoo-2-26e937b0bea5ca01b8f2a5d651ec696f07dc5995.tar.gz
gentoo-2-26e937b0bea5ca01b8f2a5d651ec696f07dc5995.tar.bz2
gentoo-2-26e937b0bea5ca01b8f2a5d651ec696f07dc5995.zip
Bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog9
-rw-r--r--app-forensics/libewf/libewf-20120813.ebuild44
-rw-r--r--app-forensics/libewf/metadata.xml1
3 files changed, 52 insertions, 2 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index b06434d2597a..b4154c712bdb 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.22 2012/03/01 23:30:28 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.23 2012/08/27 09:22:35 patrick Exp $
+
+*libewf-20120813 (27 Aug 2012)
+
+ 27 Aug 2012; Patrick Lauer <patrick@gentoo.org> +libewf-20120813.ebuild,
+ metadata.xml:
+ Bump
01 Mar 2012; Brent Baude <ranger@gentoo.org> libewf-20100226-r1.ebuild:
Marking libewf-20100226-r1 ppc stable for bug 374321
@@ -80,4 +86,3 @@
01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+libewf-20090209.ebuild:
Initial import. Ebuild by RB <aoz.syn@gmail.com>. Fixes #224121
-
diff --git a/app-forensics/libewf/libewf-20120813.ebuild b/app-forensics/libewf/libewf-20120813.ebuild
new file mode 100644
index 000000000000..06dfe8fd789c
--- /dev/null
+++ b/app-forensics/libewf/libewf-20120813.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20120813.ebuild,v 1.1 2012/08/27 09:22:35 patrick Exp $
+
+EAPI="4"
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug ewf rawio static-libs unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable rawio low-level-functions)
+ $(use_enable unicode wide-character-type)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}
diff --git a/app-forensics/libewf/metadata.xml b/app-forensics/libewf/metadata.xml
index 903ff28895c6..53eaf11fe341 100644
--- a/app-forensics/libewf/metadata.xml
+++ b/app-forensics/libewf/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="rawio">Enables raw IO handling</flag>
<flag name="ewf2">Enables the v2 API</flag>
+ <flag name="ewf">Enables the v1 API</flag>
</use>
</pkgmetadata>