summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-24 14:33:48 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-24 14:33:48 +0000
commit517600c13ee7e78bd04dcdfbfaa559d5a81d1ea6 (patch)
tree3bd3ce67c31a8d5f07c50c0203510ad03eb0f9e8 /app-forensics
parentinitial commit. The library was shipped with ghc up to 6.10.2 but now it's a ... (diff)
downloadgentoo-2-517600c13ee7e78bd04dcdfbfaa559d5a81d1ea6.tar.gz
gentoo-2-517600c13ee7e78bd04dcdfbfaa559d5a81d1ea6.tar.bz2
gentoo-2-517600c13ee7e78bd04dcdfbfaa559d5a81d1ea6.zip
Version Bump, 280332
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/chkrootkit/ChangeLog7
-rw-r--r--app-forensics/chkrootkit/chkrootkit-0.49.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/app-forensics/chkrootkit/ChangeLog b/app-forensics/chkrootkit/ChangeLog
index 2efc0fb83ac2..481254084480 100644
--- a/app-forensics/chkrootkit/ChangeLog
+++ b/app-forensics/chkrootkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/chkrootkit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.57 2010/01/21 16:56:16 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/ChangeLog,v 1.58 2010/07/24 14:33:48 jlec Exp $
+
+*chkrootkit-0.49 (24 Jul 2010)
+
+ 24 Jul 2010; Justin Lecher <jlec@gentoo.org> +chkrootkit-0.49.ebuild:
+ Version Bump, 280332
21 Jan 2010; Peter Volkov <pva@gentoo.org> chkrootkit-0.48-r1.ebuild:
Fix LICENSE: should be BSD-2, bug #301121, thank Ulrich Müller for this
diff --git a/app-forensics/chkrootkit/chkrootkit-0.49.ebuild b/app-forensics/chkrootkit/chkrootkit-0.49.ebuild
new file mode 100644
index 000000000000..08e703ac1b3c
--- /dev/null
+++ b/app-forensics/chkrootkit/chkrootkit-0.49.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/chkrootkit/chkrootkit-0.49.ebuild,v 1.1 2010/07/24 14:33:48 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Tool to locally check for signs of a rootkit"
+HOMEPAGE="http://www.chkrootkit.org/"
+SRC_URI="
+ ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${WORKDIR}/${P}-gentoo.diff"
+ sed -i 's:/var/adm/:/var/log/:g' chklastlog.c || die "sed chklastlog.c failed"
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) STRIP=true sense || die "emake sense failed"
+}
+
+src_install() {
+ dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc \
+ strings-static || die
+ dodoc ACKNOWLEDGMENTS README* || die
+
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}"/${PN}.cron ${PN} || die
+}
+
+pkg_postinst() {
+ echo
+ elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
+ elog
+ elog "Some applications, such as portsentry, will cause chkrootkit"
+ elog "to produce false positives. Read the chkrootkit FAQ at"
+ elog "http://www.chkrootkit.org/ for more information."
+ echo
+}