summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2015-01-30 01:58:41 +0000
committerHanno Böck <hanno@gentoo.org>2015-01-30 01:58:41 +0000
commit88857c0d363c9ec1095204e087dc0350e7da6716 (patch)
treefef7c44b7b0e7112d60cf4a561b772de01b76ac5 /app-forensics
parentAutomated update. (diff)
downloadgentoo-2-88857c0d363c9ec1095204e087dc0350e7da6716.tar.gz
gentoo-2-88857c0d363c9ec1095204e087dc0350e7da6716.tar.bz2
gentoo-2-88857c0d363c9ec1095204e087dc0350e7da6716.zip
afl bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BBB51E42)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afl/ChangeLog9
-rw-r--r--app-forensics/afl/afl-1.35b.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/app-forensics/afl/ChangeLog b/app-forensics/afl/ChangeLog
index 96156906bc85..ad20543945f6 100644
--- a/app-forensics/afl/ChangeLog
+++ b/app-forensics/afl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/afl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.5 2014/12/25 12:58:15 hanno Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/ChangeLog,v 1.6 2015/01/30 01:58:41 hanno Exp $
+
+*afl-1.35b (30 Jan 2015)
+
+ 30 Jan 2015; <hanno@gentoo.org> +afl-1.35b.ebuild:
+ Bump.
*afl-1.03b (25 Dec 2014)
diff --git a/app-forensics/afl/afl-1.35b.ebuild b/app-forensics/afl/afl-1.35b.ebuild
new file mode 100644
index 000000000000..e9c692f82e4e
--- /dev/null
+++ b/app-forensics/afl/afl-1.35b.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afl/afl-1.35b.ebuild,v 1.1 2015/01/30 01:58:41 hanno Exp $
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+DESCRIPTION="american fuzzy lop - compile-time instrumentation fuzzer"
+HOMEPAGE="http://lcamtuf.coredump.cx/afl/"
+SRC_URI="http://lcamtuf.coredump.cx/afl/releases//${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND="sys-devel/gcc"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ HELPER_PATH="/usr/$(get_libdir)/afl" \
+ DOC_PATH="/usr/share/doc/${PF}" \
+ install
+}