summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-03-24 22:11:34 +0000
committerMike Auty <ikelos@gentoo.org>2008-03-24 22:11:34 +0000
commited0756f8a3eecf4b3064f6377b15ee94895ece2b (patch)
tree14c4110333841f3b91cdca5c59669d36217f7049 /app-forensics
parentRemoving orphaned javamake licence. (diff)
downloadgentoo-2-ed0756f8a3eecf4b3064f6377b15ee94895ece2b.tar.gz
gentoo-2-ed0756f8a3eecf4b3064f6377b15ee94895ece2b.tar.bz2
gentoo-2-ed0756f8a3eecf4b3064f6377b15ee94895ece2b.zip
Version bump, and re-apply patch. Fixes bug 214471.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/foremost/ChangeLog8
-rw-r--r--app-forensics/foremost/foremost-1.4.ebuild7
-rw-r--r--app-forensics/foremost/foremost-1.5.3.ebuild35
-rw-r--r--app-forensics/foremost/foremost-1.5.ebuild6
4 files changed, 49 insertions, 7 deletions
diff --git a/app-forensics/foremost/ChangeLog b/app-forensics/foremost/ChangeLog
index cbb221f5ac0e..0f80efabaa66 100644
--- a/app-forensics/foremost/ChangeLog
+++ b/app-forensics/foremost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/foremost
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.11 2008/01/31 14:31:49 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/ChangeLog,v 1.12 2008/03/24 22:11:34 ikelos Exp $
+
+*foremost-1.5.3 (24 Mar 2008)
+
+ 24 Mar 2008; Mike Auty <ikelos@gentoo.org> foremost-1.4.ebuild,
+ foremost-1.5.ebuild, +foremost-1.5.3.ebuild:
+ Version bump, and re-apply patch. Fixes bug 214471.
31 Jan 2008; Mike Auty <ikelos@gentoo.org> ChangeLog:
Re-sign digestless manifest.
diff --git a/app-forensics/foremost/foremost-1.4.ebuild b/app-forensics/foremost/foremost-1.4.ebuild
index 61b7c00ca858..4cdc34716e9f 100644
--- a/app-forensics/foremost/foremost-1.4.ebuild
+++ b/app-forensics/foremost/foremost-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.4.ebuild,v 1.2 2007/02/21 20:03:13 ikelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.4.ebuild,v 1.3 2008/03/24 22:11:34 ikelos Exp $
inherit eutils toolchain-funcs
@@ -17,8 +17,7 @@ RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
-
- epatch ${FILESDIR}/${P}-config-location.patch
+ epatch "${FILESDIR}/${P}-config-location.patch"
}
src_compile() {
diff --git a/app-forensics/foremost/foremost-1.5.3.ebuild b/app-forensics/foremost/foremost-1.5.3.ebuild
new file mode 100644
index 000000000000..e13655a01909
--- /dev/null
+++ b/app-forensics/foremost/foremost-1.5.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.3.ebuild,v 1.1 2008/03/24 22:11:34 ikelos Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A console program to recover files based on their headers and footers"
+HOMEPAGE="http://foremost.sourceforge.net/"
+SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
+
+KEYWORDS="~ppc ~x86 ~amd64"
+IUSE=""
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
+}
+
+src_compile() {
+ emake RAW_FLAGS="${CFLAGS} -Wall" RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ CONF=/etc || die "emake failed"
+}
+
+src_install() {
+ dobin foremost
+ doman foremost.1
+ insinto /etc
+ doins foremost.conf
+ dodoc README CHANGES
+}
diff --git a/app-forensics/foremost/foremost-1.5.ebuild b/app-forensics/foremost/foremost-1.5.ebuild
index a0cdd95f939a..770fb5ba7f2d 100644
--- a/app-forensics/foremost/foremost-1.5.ebuild
+++ b/app-forensics/foremost/foremost-1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.ebuild,v 1.1 2007/05/17 16:57:23 hyakuhei Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/foremost/foremost-1.5.ebuild,v 1.2 2008/03/24 22:11:34 ikelos Exp $
inherit eutils toolchain-funcs
@@ -17,6 +17,8 @@ RDEPEND="virtual/libc"
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4-config-location.patch"
}
src_compile() {