summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-04-24 17:07:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-04-24 17:07:15 +0000
commit8a349b6bb0ce6babf340f5b8cd5788e5cdc06d96 (patch)
tree51061091d3b73120c49c654676bfb4fe2fb6d471 /app-i18n/kimera/kimera-1.40.ebuild
parentfixed broken encoding in ChangeLog (diff)
downloadgentoo-2-8a349b6bb0ce6babf340f5b8cd5788e5cdc06d96.tar.gz
gentoo-2-8a349b6bb0ce6babf340f5b8cd5788e5cdc06d96.tar.bz2
gentoo-2-8a349b6bb0ce6babf340f5b8cd5788e5cdc06d96.zip
Version bumped.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-i18n/kimera/kimera-1.40.ebuild')
-rw-r--r--app-i18n/kimera/kimera-1.40.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-i18n/kimera/kimera-1.40.ebuild b/app-i18n/kimera/kimera-1.40.ebuild
new file mode 100644
index 000000000000..2d56fc3c4409
--- /dev/null
+++ b/app-i18n/kimera/kimera-1.40.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/kimera/kimera-1.40.ebuild,v 1.1 2007/04/24 17:07:15 matsuu Exp $
+
+inherit kde-functions qt3
+
+IUSE="anthy"
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+SRC_URI="mirror://sourceforge.jp/kimera/24905/${P}.tar.gz"
+HOMEPAGE="http://kimera.sourceforge.jp/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="$(qt_min_version 3)
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+need-qt 3
+
+src_compile(){
+ local myconf
+ if ! use anthy ; then
+ myconf="no_anthy=1"
+ fi
+
+ ${QTDIR}/bin/qmake ${myconf} kimera.pro || die
+
+ # Avoid pre-stripping
+ sed -i -e '/strip/d' Makefile
+
+ emake || die
+}
+
+src_install(){
+ emake INSTALL_ROOT="${D}" install || die
+
+ dodoc AUTHORS INSTALL README*
+}