summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-10 10:56:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-10 10:56:28 +0000
commit2a51072bd69ea1b3d0dd280f8542ea071f809922 (patch)
treeb6784981a0efa1034b8497bc37539bf06ab3151b /app-i18n/opencc
parentapp-misc/ktoblzcheck: Version bump. (diff)
downloadgentoo-2-2a51072bd69ea1b3d0dd280f8542ea071f809922.tar.gz
gentoo-2-2a51072bd69ea1b3d0dd280f8542ea071f809922.tar.bz2
gentoo-2-2a51072bd69ea1b3d0dd280f8542ea071f809922.zip
Use eapi4 and define mycmakeargs as local.
(Portage version: 2.2.0_alpha103/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/ChangeLog6
-rw-r--r--app-i18n/opencc/opencc-0.1.2.ebuild27
-rw-r--r--app-i18n/opencc/opencc-0.2.0.ebuild7
3 files changed, 9 insertions, 31 deletions
diff --git a/app-i18n/opencc/ChangeLog b/app-i18n/opencc/ChangeLog
index 2adac3f54cc2..54c55180ecba 100644
--- a/app-i18n/opencc/ChangeLog
+++ b/app-i18n/opencc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/opencc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.4 2012/04/18 18:38:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/ChangeLog,v 1.5 2012/05/10 10:56:28 scarabeus Exp $
+
+ 10 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> -opencc-0.1.2.ebuild,
+ opencc-0.2.0.ebuild:
+ Use eapi4 and define mycmakeargs as local.
18 Apr 2012; Markus Meier <maekke@gentoo.org> opencc-0.2.0.ebuild:
x86 stable, bug #409403
diff --git a/app-i18n/opencc/opencc-0.1.2.ebuild b/app-i18n/opencc/opencc-0.1.2.ebuild
deleted file mode 100644
index ddd1ff9b2c95..000000000000
--- a/app-i18n/opencc/opencc-0.1.2.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.1.2.ebuild,v 1.1 2010/09/20 02:46:56 matsuu Exp $
-
-EAPI=3
-
-DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
-HOMEPAGE="http://code.google.com/p/open-chinese-convert/"
-SRC_URI="http://open-chinese-convert.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="nls"
-
-DEPEND="nls? ( sys-devel/gettext )"
-RDEPEND="nls? ( virtual/libintl )"
-
-src_configure() {
- econf $(use_enable nls) || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README || die
-}
diff --git a/app-i18n/opencc/opencc-0.2.0.ebuild b/app-i18n/opencc/opencc-0.2.0.ebuild
index bd30d69992d0..6b4c8a3aed71 100644
--- a/app-i18n/opencc/opencc-0.2.0.ebuild
+++ b/app-i18n/opencc/opencc-0.2.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.2.0.ebuild,v 1.3 2012/04/18 18:38:36 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/opencc/opencc-0.2.0.ebuild,v 1.4 2012/05/10 10:56:28 scarabeus Exp $
+
+EAPI=4
-EAPI=3
inherit cmake-utils multilib
DESCRIPTION="Libraries for Simplified-Traditional Chinese Conversion"
@@ -26,7 +27,7 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
"$(cmake-utils_use_enable nls GETTEXT)"
)