summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-29 14:29:02 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-29 14:29:02 +0000
commit73900a1cf9ef846426b1ba38b8b3a7154283f8fd (patch)
tree57923dcc01de741a6023cce7e7e25bc1538316be /app-i18n/scim-anthy
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-73900a1cf9ef846426b1ba38b8b3a7154283f8fd.tar.gz
gentoo-2-73900a1cf9ef846426b1ba38b8b3a7154283f8fd.tar.bz2
gentoo-2-73900a1cf9ef846426b1ba38b8b3a7154283f8fd.zip
Version bumped.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/scim-anthy')
-rw-r--r--app-i18n/scim-anthy/ChangeLog9
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index c4f1e1174d20..9ba6f2fcf207 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-anthy
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.58 2008/12/20 18:43:24 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.59 2009/01/29 14:29:02 matsuu Exp $
+
+*scim-anthy-1.2.7 (29 Jan 2009)
+
+ 29 Jan 2009; MATSUU Takuto <matsuu@gentoo.org> +scim-anthy-1.2.7.ebuild:
+ Version bumped.
20 Dec 2008; nixnut <nixnut@gentoo.org> scim-anthy-1.2.6.ebuild:
Stable on ppc wrt bug 245175
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
new file mode 100644
index 000000000000..1f793eca6727
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.1 2009/01/29 14:29:02 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kde nls"
+
+DEPEND=">=app-i18n/scim-1.2
+ >=app-i18n/anthy-5900
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2.4 )"
+RDEPEND="${DEPEND}
+ gtk? ( app-dicts/kasumi )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}