summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-03-04 07:43:45 +0000
committerNaohiro Aota <naota@gentoo.org>2013-03-04 07:43:45 +0000
commit080b8cae2ff497e4497bec947bbc0177e1d2d34d (patch)
treef2ebf195ddec6a4289e9228225a7a0c54025d145 /app-i18n/scim-hangul
parentVersion bump and block sys-infiniband/dapl for bug #429810. (diff)
downloadgentoo-2-080b8cae2ff497e4497bec947bbc0177e1d2d34d.tar.gz
gentoo-2-080b8cae2ff497e4497bec947bbc0177e1d2d34d.tar.bz2
gentoo-2-080b8cae2ff497e4497bec947bbc0177e1d2d34d.zip
version bump
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/scim-hangul')
-rw-r--r--app-i18n/scim-hangul/ChangeLog10
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild52
2 files changed, 59 insertions, 3 deletions
diff --git a/app-i18n/scim-hangul/ChangeLog b/app-i18n/scim-hangul/ChangeLog
index cc2421a0a4be..1c3718e9b5e5 100644
--- a/app-i18n/scim-hangul/ChangeLog
+++ b/app-i18n/scim-hangul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-hangul
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.32 2012/06/30 13:53:34 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/ChangeLog,v 1.33 2013/03/04 07:43:45 naota Exp $
+
+*scim-hangul-0.4.0 (04 Mar 2013)
+
+ 04 Mar 2013; Naohiro Aota <naota@gentoo.org> +scim-hangul-0.4.0.ebuild:
+ version bump
30 Jun 2012; Naohiro Aota <naota@gentoo.org>
+files/scim-hangul-0.3.2+gcc-4.7.patch, scim-hangul-0.3.2.ebuild:
@@ -135,4 +140,3 @@
03 Aug 2004; Mamoru KOMACHI <usata@gentoo.org> +metadata.xml,
+scim-hangul-0.0.2.ebuild:
Initial import.
-
diff --git a/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild b/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild
new file mode 100644
index 000000000000..2289d2705308
--- /dev/null
+++ b/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-hangul/scim-hangul-0.4.0.ebuild,v 1.1 2013/03/04 07:43:45 naota Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Hangul IMEngine for SCIM ported from imhangul"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ >=app-i18n/libhangul-0.0.4
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.2+gcc-4.3.patch"
+ "${FILESDIR}/${PN}-0.3.2+gcc-4.7.patch" )
+
+DOCS=(AUTHORS NEWS)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-skim-support
+ $(use_enable nls)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ dodoc ChangeLog* README*
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}