summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2014-05-07 20:01:21 +0000
committerDenis Dupeyron <calchan@gentoo.org>2014-05-07 20:01:21 +0000
commitf22c9ae6c5fb85f595a48f124f0a021c5fab6059 (patch)
treedad3aa8539be87734af8151b84ff37daa34d2465 /app-i18n
parentStable for ppc, wrt bug #504210 (diff)
downloadgentoo-2-f22c9ae6c5fb85f595a48f124f0a021c5fab6059.tar.gz
gentoo-2-f22c9ae6c5fb85f595a48f124f0a021c5fab6059.tar.bz2
gentoo-2-f22c9ae6c5fb85f595a48f124f0a021c5fab6059.zip
Add LINGUAS support.
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/tagainijisho/ChangeLog5
-rw-r--r--app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild29
2 files changed, 32 insertions, 2 deletions
diff --git a/app-i18n/tagainijisho/ChangeLog b/app-i18n/tagainijisho/ChangeLog
index e75767dcd54f..4ac4606e291d 100644
--- a/app-i18n/tagainijisho/ChangeLog
+++ b/app-i18n/tagainijisho/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-i18n/tagainijisho
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tagainijisho/ChangeLog,v 1.2 2014/05/07 14:24:23 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tagainijisho/ChangeLog,v 1.3 2014/05/07 20:01:21 calchan Exp $
+
+ 07 May 2014; Denis Dupeyron <calchan@gentoo.org> tagainijisho-1.0.2.ebuild:
+ Add LINGUAS support.
07 May 2014; Denis Dupeyron <calchan@gentoo.org> tagainijisho-1.0.2.ebuild:
Tagaini Jinsho depends on sqlite3 but I can't seem to be able to completely
diff --git a/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild b/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
index 1dc93b3cedf8..15e177736c92 100644
--- a/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
+++ b/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild,v 1.2 2014/05/07 14:24:23 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/tagainijisho/tagainijisho-1.0.2.ebuild,v 1.3 2014/05/07 20:01:21 calchan Exp $
EAPI=5
@@ -19,6 +19,33 @@ DEPEND="dev-qt/qtcore:4
dev-db/sqlite:3"
RDEPEND="${DEPEND}"
+pkg_linguas=( ar cs de es fi_FI fr it nb nl pt ru sv th tr vi )
+IUSE+=" ${pkg_linguas[@]/#/linguas_}"
+
+src_configure() {
+ # GUI linguas
+ # en is not optional, and build fails if none other then en is set, so adding ja as non-optional too
+ # linguas undeclared in IUSE will trigger an error, which is a handy check
+ for lingua in $(ls -1 i18n/*.ts | sed -e 's/.*tagainijisho_\(.*\)\.ts/\1/' | grep -v en | grep -v ja); do
+ if ! use linguas_${lingua}; then
+ rm i18n/tagainijisho_${lingua}.ts || die
+ fi
+ done
+
+ # Dictionary linguas
+ # en is not optional here either, but nothing special needs to be done
+ # here too, linguas undeclared in IUSE will trigger an error
+ local cmake_linguas
+ for lingua in $(sed -e 's/;/ /g' -ne '/set(DICT_LANG ".*")/s/.*"\(.*\)".*/\1/p' CMakeLists.txt); do
+ if use linguas_${lingua}; then
+ cmake_linguas+="${lingua};"
+ fi
+ done
+ mycmakeargs=( -DDICT_LANG=${cmake_linguas} )
+
+ cmake-utils_src_configure
+}
+
pkg_preinst() {
gnome2_icon_savelist
}