summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-05-21 23:02:52 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-05-21 23:02:52 +0000
commitfe64fc270b2ff53759db7fde257f75f534b94b87 (patch)
treec5f79560365987e3bb8f073c37b790dc23811272 /app-i18n
parentAdded menu. Bug #159745 (diff)
downloadgentoo-2-fe64fc270b2ff53759db7fde257f75f534b94b87.tar.gz
gentoo-2-fe64fc270b2ff53759db7fde257f75f534b94b87.tar.bz2
gentoo-2-fe64fc270b2ff53759db7fde257f75f534b94b87.zip
Version bumped.
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/skk-jisyo/ChangeLog9
-rw-r--r--app-i18n/skk-jisyo/files/digest-skk-jisyo-2007053
-rw-r--r--app-i18n/skk-jisyo/files/unannotation.awk75
-rw-r--r--app-i18n/skk-jisyo/skk-jisyo-200705.ebuild56
4 files changed, 142 insertions, 1 deletions
diff --git a/app-i18n/skk-jisyo/ChangeLog b/app-i18n/skk-jisyo/ChangeLog
index bd434eca6b95..29a3de506fef 100644
--- a/app-i18n/skk-jisyo/ChangeLog
+++ b/app-i18n/skk-jisyo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/skk-jisyo
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/skk-jisyo/ChangeLog,v 1.40 2007/02/03 18:18:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skk-jisyo/ChangeLog,v 1.41 2007/05/21 23:02:52 matsuu Exp $
+
+*skk-jisyo-200705 (21 May 2007)
+
+ 21 May 2007; MATSUU Takuto <matsuu@gentoo.org> +files/unannotation.awk,
+ +skk-jisyo-200705.ebuild:
+ Version bumped.
+ Aggregated app-i18n/skk-jisyo*.
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-i18n/skk-jisyo/files/digest-skk-jisyo-200705 b/app-i18n/skk-jisyo/files/digest-skk-jisyo-200705
new file mode 100644
index 000000000000..b428654f16e0
--- /dev/null
+++ b/app-i18n/skk-jisyo/files/digest-skk-jisyo-200705
@@ -0,0 +1,3 @@
+MD5 1a452d442ea3c1258064dffb0f2f8344 skk-jisyo-200705.tar.gz 8639170
+RMD160 8b4832af24e686339053b2ddc35faf8027d0b466 skk-jisyo-200705.tar.gz 8639170
+SHA256 b8df8b7ad1beadc9b9d5112e679751f17492eb94955f9ece28c0420dfe93e587 skk-jisyo-200705.tar.gz 8639170
diff --git a/app-i18n/skk-jisyo/files/unannotation.awk b/app-i18n/skk-jisyo/files/unannotation.awk
new file mode 100644
index 000000000000..88d9eb254344
--- /dev/null
+++ b/app-i18n/skk-jisyo/files/unannotation.awk
@@ -0,0 +1,75 @@
+# unannotation.awk: filter to remove annotations in dictionaries.
+#
+# Copyright (C) 2001, 2002 SKK Development Team <skk@ring.gr.jp>
+#
+# Maintainer: SKK Development Team <skk@ring.gr.jp>
+# Version: $Id: unannotation.awk,v 1.3 2006/01/04 10:35:06 skk-cvs Exp $
+# Last Modified: $Date: 2006/01/04 10:35:06 $
+#
+# This file is part of Daredevil SKK.
+#
+# Daredevil SKK is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or
+# (at your option) any later version.
+#
+# Daredevil SKK is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Daredevil SKK, see the file COPYING. If not, write to
+# the Free Software Foundation Inc., 51 Franklin St, Fifth Floor,
+# Boston, MA 02110-1301, USA.
+
+BEGIN{
+ print ";; -*- text -*-";
+ ctime = myctime(0);
+ this = ARGV[1];
+ if (match(this, /\.annotated$/) != 0){
+ this = substr(this, 1, RSTART - 1);
+ } else
+ this = this ".unannotated";
+ printf(";; %s was generated automatically by unannotation.awk at %s\n",
+ this, ctime);
+ #getline modeindicator
+ #if (match(modeindicator, /;; -*- text -*-/) != 0){
+ # print modeindicator;
+ #}
+}
+#$0 !~ /"^;; -\*- text -\*-\n"/{
+{
+ if (match($0, /^;/) == 0) {
+ gsub(";[^/]*/", "/");
+ if (DEQUOTE && $0 ~ /\\073/) {
+ $0 = dequote($0);
+ }
+ }
+ print;
+}
+function myctime(ts, format) {
+ format = "%a %b %e %H:%M:%S %Y";
+ if (ts == 0)
+ ts = systime(); # use current time as default
+ return strftime(format, ts);
+}
+# convert '\073' to ';' and strip '(concat "...")'.
+# example: 'smile /(concat "^_^\073\073")/:-)/' to 'smile /^_^;;/:-)/'
+# @param s string to convert
+# @return converted string
+function dequote(s) {
+ ret = "";
+ n = split(s, a, "/");
+ for (i = 1; i < n; i++) {
+ if (a[i] ~ /^\(concat ".*\\073.*"\)$/) { # \073 = ';'
+ gsub(/\\073/, ";", a[i]);
+ if (a[i] !~ /\\/) { # no other quote
+ a[i] = gensub(/^\(concat "(.*)"\)$/, "\\1", "g", a[i]);
+ }
+ }
+ ret = ret a[i] "/";
+ }
+ return ret;
+}
+# end of unannotation.awk.
diff --git a/app-i18n/skk-jisyo/skk-jisyo-200705.ebuild b/app-i18n/skk-jisyo/skk-jisyo-200705.ebuild
new file mode 100644
index 000000000000..198449a1c81e
--- /dev/null
+++ b/app-i18n/skk-jisyo/skk-jisyo-200705.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skk-jisyo/skk-jisyo-200705.ebuild,v 1.1 2007/05/21 23:02:52 matsuu Exp $
+
+DESCRIPTION="Jisyo (dictionary) files for the SKK Japanese-input software"
+HOMEPAGE="http://openlab.ring.gr.jp/skk/dic.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE="cdb"
+
+DEPEND="sys-apps/gawk
+ cdb? ( || (
+ dev-db/cdb
+ dev-db/tinycdb
+ dev-db/freecdb
+ ) )
+ !app-i18n/skk-jisyo-extra
+ !app-i18n/skk-jisyo-cdb"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm SKK-JISYO.wrong.annotated SKK-JISYO.china_taiwan.header
+ rm SKK-JISYO.noregist SKK-JISYO.not_wrong SKK-JISYO.hukugougo
+ rm SKK-JISYO.notes SKK-JISYO.requested SKK-JISYO.pubdic+
+}
+
+src_compile() {
+ for f in SKK-JISYO.* zipcode/SKK-JISYO.* ; do
+ mv ${f} ${f}.annotated
+ awk -f "${FILESDIR}"/unannotation.awk ${f}.annotated > $(basename ${f}) || die
+ if use cdb ; then
+ awk '
+ /^[^;]/ {
+ s = substr($0, index($0, " ") + 1)
+ print "+" length($1) "," length(s) ":" $1 "->" s
+ }
+ END {
+ print ""
+ }
+ ' $(basename ${f}) | cdbmake $(basename ${f}).cdb "${T}"/$(basename ${f}) || die
+ fi
+ rm ${f}.annotated
+ done
+}
+
+src_install() {
+ # install dictionaries
+ insinto /usr/share/skk
+ doins SKK-JISYO.* || die
+
+ dodoc ChangeLog* READMEs/committers.txt edict_doc.txt
+}