summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-24 19:48:10 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-24 19:48:10 +0000
commit6a892bf2ec418e19b61307919f89ec3c50397b99 (patch)
tree6564a379c9578f9d699629d072ecfeaabcd73934 /app-laptop/acerhk/acerhk-0.5.31.ebuild
parentAdded modular X dependencies and closing bug #120077. (diff)
downloadgentoo-2-6a892bf2ec418e19b61307919f89ec3c50397b99.tar.gz
gentoo-2-6a892bf2ec418e19b61307919f89ec3c50397b99.tar.bz2
gentoo-2-6a892bf2ec418e19b61307919f89ec3c50397b99.zip
version bump thanks to Daniel Webert <rockoo@gmail.com> and Johannes Ebke <johannes.ebke@web.de> in bug 111796
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-laptop/acerhk/acerhk-0.5.31.ebuild')
-rw-r--r--app-laptop/acerhk/acerhk-0.5.31.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-laptop/acerhk/acerhk-0.5.31.ebuild b/app-laptop/acerhk/acerhk-0.5.31.ebuild
new file mode 100644
index 000000000000..8854f651213f
--- /dev/null
+++ b/app-laptop/acerhk/acerhk-0.5.31.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/acerhk/acerhk-0.5.31.ebuild,v 1.1 2006/01/24 19:48:10 genstef Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Hotkey driver for some Acer and Acer-like laptops"
+HOMEPAGE="http://www.informatik.hu-berlin.de/~tauber/acerhk/"
+SRC_URI="http://www.informatik.hu-berlin.de/~tauber/acerhk/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+IUSE=""
+
+MODULE_NAMES="acerhk(extra:)"
+BUILD_TARGETS="all"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELSRC=${KV_DIR} KERNELVERSION=${KV_FULL}"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc README COPYING NEWS doc/*
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo "You can load the module:"
+ einfo "% modprobe acerhk poll=1"
+ einfo "If you need poll=1 you can set it permanently in /etc/modules.d/acerhk"
+ echo
+ einfo "If you need more info about this driver you can read the README file"
+ einfo "% zmore /usr/share/doc/${PF}/README.gz"
+}