summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-07-07 23:40:18 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-07-07 23:40:18 +0000
commit4edb425ae2663d801c3e58050392ad9259ac3657 (patch)
tree44fe285f21eb0477009d349ffda5274a77a2d63e /app-laptop/pbbuttonsd
parentVersion bump, removed old version. (diff)
downloadgentoo-2-4edb425ae2663d801c3e58050392ad9259ac3657.tar.gz
gentoo-2-4edb425ae2663d801c3e58050392ad9259ac3657.tar.bz2
gentoo-2-4edb425ae2663d801c3e58050392ad9259ac3657.zip
New release.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'app-laptop/pbbuttonsd')
-rw-r--r--app-laptop/pbbuttonsd/ChangeLog7
-rw-r--r--app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.13
-rw-r--r--app-laptop/pbbuttonsd/pbbuttonsd-0.8.1.ebuild99
3 files changed, 108 insertions, 1 deletions
diff --git a/app-laptop/pbbuttonsd/ChangeLog b/app-laptop/pbbuttonsd/ChangeLog
index 721713866c6c..0ff311a1675e 100644
--- a/app-laptop/pbbuttonsd/ChangeLog
+++ b/app-laptop/pbbuttonsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/pbbuttonsd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.67 2007/06/20 20:52:58 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/ChangeLog,v 1.68 2007/07/07 23:40:18 josejx Exp $
+
+*pbbuttonsd-0.8.1 (07 Jul 2007)
+
+ 07 Jul 2007; Joseph Jezak <josejx@gentoo.org> +pbbuttonsd-0.8.1.ebuild:
+ New release.
20 Jun 2007; Markus Rothe <corsair@gentoo.org> pbbuttonsd-0.7.4.ebuild,
pbbuttonsd-0.7.8.ebuild, pbbuttonsd-0.7.9.ebuild, pbbuttonsd-0.8.0.ebuild:
diff --git a/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1 b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1
new file mode 100644
index 000000000000..68208022e6dc
--- /dev/null
+++ b/app-laptop/pbbuttonsd/files/digest-pbbuttonsd-0.8.1
@@ -0,0 +1,3 @@
+MD5 5addde05fe291bee974443b531a3a3e5 pbbuttonsd-0.8.1.tar.gz 589630
+RMD160 2f1dc0bc8b67cbb310f06df932a5dfcf26d35551 pbbuttonsd-0.8.1.tar.gz 589630
+SHA256 b391fd98ed263f355d7e7addc6566959e986627c87dcfdaa1da15310ad70bffa pbbuttonsd-0.8.1.tar.gz 589630
diff --git a/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1.ebuild b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1.ebuild
new file mode 100644
index 000000000000..eca29b64dbf0
--- /dev/null
+++ b/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pbbuttonsd/pbbuttonsd-0.8.1.ebuild,v 1.1 2007/07/07 23:40:18 josejx Exp $
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Handles power management and special keys on laptops."
+HOMEPAGE="http://pbbuttons.berlios.de"
+SRC_URI="mirror://sourceforge/pbbuttons/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="acpi alsa debug doc ibam macbook oss"
+
+DEPEND="macbook? ( sys-libs/libsmbios )
+ >=dev-libs/glib-2.6
+ doc? ( app-doc/doxygen )"
+RDEPEND="alsa? ( >=media-libs/alsa-lib-1.0 )
+ >=dev-libs/glib-2.6"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ eautoconf
+}
+
+src_compile() {
+ # Fix crash bug on some systems
+ replace-flags -O? -O1
+
+ if use macbook; then
+ laptop=macbook
+ elif use x86 || use amd64; then
+ if use acpi; then
+ laptop=acpi
+ else
+ laptop=i386
+ fi
+ # Default to PowerBook
+ else
+ laptop=powerbook
+ fi
+
+ econf laptop=$laptop \
+ $(use_enable debug) \
+ $(use_with doc doxygen_docs) \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with ibam) \
+ || die "Sorry, failed to configure pbbuttonsd"
+
+ # Thanks to Stefan Bruda for this workaround
+ # Using -j1 fixes a parallel build issue with the docs
+ if use doc; then
+ emake -j1 || die "Sorry, failed to compile pbbuttonsd"
+ else
+ emake || die "Sorry, failed to compile pbbuttonsd"
+ fi
+}
+
+src_install() {
+ dodir /etc/power
+ use ibam && dodir /var/lib/ibam
+ make DESTDIR=${D} install || die "failed to install"
+ newinitd ${FILESDIR}/pbbuttonsd.rc6 pbbuttonsd
+ dodoc README
+ use doc && dohtml -r doc/*
+}
+
+pkg_postinst() {
+ if [ -e /etc/pbbuttonsd.conf ]; then
+ ewarn "The pbbuttonsd.cnf file replaces /etc/pbuttonsd.conf with a new"
+ ewarn "file (/etc/pbbuttonsd.conf) and a new format. Please check the"
+ ewarn "manual page with 'man pbbuttonsd.cnf' for details."
+ ewarn
+ fi
+
+ if use macbook; then
+ ewarn "Macbook and Macbook Pro users should make sure to have applesmc"
+ ewarn "loaded before starting pbbuttonsdm otherwise auto-adjustments"
+ ewarn "will not work and pbbuttonsd may segfault."
+ fi
+
+ ewarn "Ensure that the evdev kernel module is loaded otherwise"
+ ewarn "pbbuttonsd won't work. SysV IPC is also required."
+ ewarn
+ ewarn "If you need extra security, you can tell pbbuttonsd to only accept"
+ ewarn "input from one user. You can set the userallowed option in"
+ ewarn "/etc/pbbuttonsd.cnf to limit access."
+ ewarn
+
+ if use ibam; then
+ elog "To properly initialize the IBaM battery database, you will"
+ elog "need to perform a full discharge/charge cycle. For more"
+ elog "details, please see the pbbuttonsd man page."
+ elog
+ fi
+}