summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-11-16 18:27:11 +0000
committerPeter Weller <welp@gentoo.org>2007-11-16 18:27:11 +0000
commitff817515d90fc2f28bab7392b92523d4ffd015b1 (patch)
tree6058d148a550edf1455da20cefcf2a064c073c14 /app-laptop/tp_smapi
parentVersion bump <http://my.opera.com/desktopteam/blog/2007/11/16/even-more-work>. (diff)
downloadgentoo-2-ff817515d90fc2f28bab7392b92523d4ffd015b1.tar.gz
gentoo-2-ff817515d90fc2f28bab7392b92523d4ffd015b1.tar.bz2
gentoo-2-ff817515d90fc2f28bab7392b92523d4ffd015b1.zip
Update metadata.xml, bump wrt bug 187316
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-laptop/tp_smapi')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.323
-rw-r--r--app-laptop/tp_smapi/metadata.xml4
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.32.ebuild55
4 files changed, 66 insertions, 3 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 7d68651b9749..9be376a84d9d 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.21 2007/10/10 17:30:30 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.22 2007/11/16 18:27:10 welp Exp $
+
+*tp_smapi-0.32 (16 Nov 2007)
+
+ 16 Nov 2007; <welp@gentoo.org> metadata.xml, +tp_smapi-0.32.ebuild:
+ Update metadata.xml, bump ebuild wrt bug 187316
10 Oct 2007; Dawid Węgliński <cla@gentoo.org> tp_smapi-0.31.ebuild:
Stable on x86 for bug 195379
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.32 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.32
new file mode 100644
index 000000000000..f6f458fefd04
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.32
@@ -0,0 +1,3 @@
+MD5 4f721dc1c1d16494ddda7ac6c6e9a92f tp_smapi-0.32.tgz 35042
+RMD160 c9a0725361ce8e7ac2c7f84219cc821f5ff1aec3 tp_smapi-0.32.tgz 35042
+SHA256 1fe05da5c1e77137b85a2f4d358c022be3eaf8bada9c5a27b8bd33e08b23c853 tp_smapi-0.32.tgz 35042
diff --git a/app-laptop/tp_smapi/metadata.xml b/app-laptop/tp_smapi/metadata.xml
index e7cdaebb845e..d391ed09aa03 100644
--- a/app-laptop/tp_smapi/metadata.xml
+++ b/app-laptop/tp_smapi/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>mobile</herd>
<maintainer>
- <email>chainsaw@gentoo.org</email>
- <name>Tony Vroon</name>
+ <email>welp@gentoo.org</email>
+ <name>Peter Weller</name>
</maintainer>
</pkgmetadata>
diff --git a/app-laptop/tp_smapi/tp_smapi-0.32.ebuild b/app-laptop/tp_smapi/tp_smapi-0.32.ebuild
new file mode 100644
index 000000000000..3ea6037133d8
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.32.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.32.ebuild,v 1.1 2007/11/16 18:27:10 welp Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 19; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.19 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove usage of `sudo` in Makefile.
+ sed -i 's,sudo ,,' Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}