summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-12-20 09:30:11 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-12-20 09:30:11 +0000
commit160c5021c76b6e162b268a52723991c650121a07 (patch)
treea841ede1ba97b245c63c5dd87da17edf1b4c72c3 /app-laptop
parentadd changelog (diff)
downloadgentoo-2-160c5021c76b6e162b268a52723991c650121a07.tar.gz
gentoo-2-160c5021c76b6e162b268a52723991c650121a07.tar.bz2
gentoo-2-160c5021c76b6e162b268a52723991c650121a07.zip
Revision bump, with patch to fix compilation against kernels >=2.6.19. See bug #158529
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/omnibook/ChangeLog8
-rw-r--r--app-laptop/omnibook/files/digest-omnibook-20060817-r13
-rw-r--r--app-laptop/omnibook/files/omnibook-2.6.19.patch24
-rw-r--r--app-laptop/omnibook/omnibook-20060817-r1.ebuild51
4 files changed, 85 insertions, 1 deletions
diff --git a/app-laptop/omnibook/ChangeLog b/app-laptop/omnibook/ChangeLog
index 9dc3ea254176..636359b467f3 100644
--- a/app-laptop/omnibook/ChangeLog
+++ b/app-laptop/omnibook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/omnibook
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook/ChangeLog,v 1.15 2006/11/27 15:37:50 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook/ChangeLog,v 1.16 2006/12/20 09:30:10 s4t4n Exp $
+
+*omnibook-20060817-r1 (20 Dec 2006)
+
+ 20 Dec 2006; Michele Noberasco <s4t4n@gentoo.org> +omnibook-20060817-r1.ebuild:
+ Revision bump, with patch to fix compilation against kernels >=2.6.19.
+ See bug #158529.
27 Nov 2006; Michele Noberasco <s4t4n@gentoo.org> omnibook-20060817.ebuild:
Stable for x86. Closes bug #156396.
diff --git a/app-laptop/omnibook/files/digest-omnibook-20060817-r1 b/app-laptop/omnibook/files/digest-omnibook-20060817-r1
new file mode 100644
index 000000000000..d4d22a24fcff
--- /dev/null
+++ b/app-laptop/omnibook/files/digest-omnibook-20060817-r1
@@ -0,0 +1,3 @@
+MD5 62ca391fe9c99942603991b719156f53 omnibook-2.20060817.tar.gz 56007
+RMD160 b5d7ded487155e0bc9dcecdb913c6d0622a0c74a omnibook-2.20060817.tar.gz 56007
+SHA256 a22aac0cc653954df65442cff7195de08c96d3f33e96d670baba1e3605391c28 omnibook-2.20060817.tar.gz 56007
diff --git a/app-laptop/omnibook/files/omnibook-2.6.19.patch b/app-laptop/omnibook/files/omnibook-2.6.19.patch
new file mode 100644
index 000000000000..2e58b66b6c21
--- /dev/null
+++ b/app-laptop/omnibook/files/omnibook-2.6.19.patch
@@ -0,0 +1,24 @@
+diff -Nrau omnibook-2.20060817.a/ec.c omnibook-2.20060817.b/ec.c
+--- omnibook-2.20060817.orig/ec.c 2006-08-17 18:16:44.000000000 +0200
++++ omnibook-2.20060817/ec.c 2006-12-19 13:51:16.000000000 +0200
+@@ -19,7 +19,7 @@
+ #include <linux/types.h>
+ #include <linux/delay.h>
+ #include <linux/sched.h>
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include <linux/spinlock.h>
+ #include <linux/acpi.h>
+ #include <linux/version.h>
+diff -Nrau omnibook-2.20060817.a/omnibook.h omnibook-2.20060817.b/omnibook.h
+--- omnibook-2.20060817.orig/omnibook.h 2006-08-17 19:12:11.000000000 +0200
++++ omnibook-2.20060817/omnibook.h 2006-12-19 13:51:04.000000000 +0200
+@@ -18,7 +18,7 @@
+
+ #include <linux/module.h>
+ #include <linux/moduleparam.h>
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include <linux/version.h>
+
+ /*
diff --git a/app-laptop/omnibook/omnibook-20060817-r1.ebuild b/app-laptop/omnibook/omnibook-20060817-r1.ebuild
new file mode 100644
index 000000000000..5926a14de723
--- /dev/null
+++ b/app-laptop/omnibook/omnibook-20060817-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook/omnibook-20060817-r1.ebuild,v 1.1 2006/12/20 09:30:10 s4t4n Exp $
+
+inherit linux-mod eutils
+
+
+MY_PV="2.${PV}"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="Linux kernel module for (but not limited to) HP Omnibook support"
+HOMEPAGE="http://www.sourceforge.net/projects/omnibook"
+SRC_URI="mirror://sourceforge/omnibook/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+IUSE=""
+S=${WORKDIR}/${MY_P}
+
+MODULE_NAMES="omnibook(char:)"
+BUILD_TARGETS=" "
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL=${KV_MAJOR}.${KV_MINOR} KSRC=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Patch to fix compilation against kernels >=2.6.19, see bug #158529
+ [ ${KV_MAJOR} -eq 2 -a ${KV_MINOR} -eq 6 -a ${KV_PATCH} -gt 18 ] && \
+ epatch ${FILESDIR}/omnibook-2.6.19.patch
+}
+
+src_compile() {
+ cd misc/obtest
+ emake || die "make obtest failed"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ dosbin misc/obtest/obtest
+ dodoc doc/*
+ docinto misc
+ dodoc misc/*.patch misc/*.txt
+ docinto hotkeys
+ dodoc misc/hotkeys/*
+
+ linux-mod_src_install
+}