summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Weller <welp@gentoo.org>2007-12-31 18:30:44 +0000
committerPeter Weller <welp@gentoo.org>2007-12-31 18:30:44 +0000
commit60dc9ee3c5c53960928f0ffd58ce51a3939058f3 (patch)
treec50eeb940aced666e942069e1d23c72c9fc1fcdb /app-laptop
parentVersion bump. (diff)
downloadgentoo-2-60dc9ee3c5c53960928f0ffd58ce51a3939058f3.tar.gz
gentoo-2-60dc9ee3c5c53960928f0ffd58ce51a3939058f3.tar.bz2
gentoo-2-60dc9ee3c5c53960928f0ffd58ce51a3939058f3.zip
Bump, bug 203892
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog7
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.333
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.33.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 9be376a84d9d..7c7b3c903a04 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.22 2007/11/16 18:27:10 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.23 2007/12/31 18:30:43 welp Exp $
+
+*tp_smapi-0.33 (31 Dec 2007)
+
+ 31 Dec 2007; <welp@gentoo.org> +tp_smapi-0.33.ebuild:
+ Bump, bug 203892
*tp_smapi-0.32 (16 Nov 2007)
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.33 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.33
new file mode 100644
index 000000000000..bc30a9ff9088
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.33
@@ -0,0 +1,3 @@
+MD5 8c8375eb752ed90de2bdec36e29f98e6 tp_smapi-0.33.tgz 36407
+RMD160 20be782d2b8e684867177c3f8617c5971277225c tp_smapi-0.33.tgz 36407
+SHA256 715d8e234f60814a98756062a02cdf922445d806093fbb1ca6af8be402169d81 tp_smapi-0.33.tgz 36407
diff --git a/app-laptop/tp_smapi/tp_smapi-0.33.ebuild b/app-laptop/tp_smapi/tp_smapi-0.33.ebuild
new file mode 100644
index 000000000000..3334eb021a27
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.33.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.33.ebuild,v 1.1 2007/12/31 18:30:43 welp Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 19; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.19 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove usage of `sudo` in Makefile.
+ sed -i 's,sudo ,,' Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}