summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 17:51:51 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-04-10 17:51:51 +0000
commitc63208ad6e9d92a2d722de62e91be36d75f5e3b8 (patch)
treea4459d0163b42a8c855a1562a9336f4de3150451 /app-leechcraft/lc-core
parentBump LeechCraft to 0.5.65, thanks to 0xd34df00d. (diff)
downloadgentoo-2-c63208ad6e9d92a2d722de62e91be36d75f5e3b8.tar.gz
gentoo-2-c63208ad6e9d92a2d722de62e91be36d75f5e3b8.tar.bz2
gentoo-2-c63208ad6e9d92a2d722de62e91be36d75f5e3b8.zip
Bump LeechCraft to 0.5.65, thanks to 0xd34df00d.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'app-leechcraft/lc-core')
-rw-r--r--app-leechcraft/lc-core/ChangeLog7
-rw-r--r--app-leechcraft/lc-core/lc-core-0.6.65.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/app-leechcraft/lc-core/ChangeLog b/app-leechcraft/lc-core/ChangeLog
index dc3376fbaa12..fba74207ea17 100644
--- a/app-leechcraft/lc-core/ChangeLog
+++ b/app-leechcraft/lc-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.16 2014/04/03 07:57:31 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/ChangeLog,v 1.17 2014/04/10 17:51:51 maksbotan Exp $
+
+*lc-core-0.6.65 (10 Apr 2014)
+
+ 10 Apr 2014; Maxim Koltsov <maksbotan@gentoo.org> +lc-core-0.6.65.ebuild:
+ Bump LeechCraft to 0.5.65, thanks to 0xd34df00d.
03 Apr 2014; Mikle Kolyada <zlogene@gentoo.org> lc-core-0.6.60.ebuild:
x86 stable wrt bug #500914
diff --git a/app-leechcraft/lc-core/lc-core-0.6.65.ebuild b/app-leechcraft/lc-core/lc-core-0.6.65.ebuild
new file mode 100644
index 000000000000..d8c2c89dd1e6
--- /dev/null
+++ b/app-leechcraft/lc-core/lc-core-0.6.65.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-core/lc-core-0.6.65.ebuild,v 1.1 2014/04/10 17:51:51 maksbotan Exp $
+
+EAPI="5"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit eutils confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug doc +sqlite postgres +qwt"
+
+COMMON_DEPEND=">=dev-libs/boost-1.46
+ dev-qt/qtcore:4
+ dev-qt/qtdeclarative:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4[postgres?,sqlite?]
+ dev-qt/qtwebkit:4
+ qwt? ( x11-libs/qwt:6 )"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${COMMON_DEPEND}
+ dev-qt/qtsvg:4
+ || (
+ kde-base/oxygen-icons
+ x11-themes/kfaenza
+ )"
+
+REQUIRED_USE="|| ( postgres sqlite )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_PLUGINS=False
+ $(cmake-utils_use_with doc DOCS)
+ $(cmake-utils_use_with qwt QWT)
+ )
+ if [[ ${PV} != 9999 ]]; then
+ mycmakeargs+=( -DLEECHCRAFT_VERSION=${PV} )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dohtml -r "${CMAKE_BUILD_DIR}/${PN#lc-}"/out/html/*
+}