summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:37:55 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-05-02 15:37:55 +0000
commit63bf9b2b8e3a1213e36770de3fac27ee61700a09 (patch)
treec384fafda408a3ec1edc9786dbfd13c35281cdc4 /app-leechcraft/lc-vrooby
parentBump LeechCraft to 0.5.95, thanks to 0xd34df00d (diff)
downloadgentoo-2-63bf9b2b8e3a1213e36770de3fac27ee61700a09.tar.gz
gentoo-2-63bf9b2b8e3a1213e36770de3fac27ee61700a09.tar.bz2
gentoo-2-63bf9b2b8e3a1213e36770de3fac27ee61700a09.zip
Bump LeechCraft to 0.5.95, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-leechcraft/lc-vrooby')
-rw-r--r--app-leechcraft/lc-vrooby/ChangeLog7
-rw-r--r--app-leechcraft/lc-vrooby/lc-vrooby-0.5.95.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-leechcraft/lc-vrooby/ChangeLog b/app-leechcraft/lc-vrooby/ChangeLog
index 1ece6e5e8c1d..15231ee69c84 100644
--- a/app-leechcraft/lc-vrooby/ChangeLog
+++ b/app-leechcraft/lc-vrooby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-leechcraft/lc-vrooby
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/ChangeLog,v 1.2 2013/04/12 08:44:34 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/ChangeLog,v 1.3 2013/05/02 15:37:54 pinkbyte Exp $
+
+*lc-vrooby-0.5.95 (02 May 2013)
+
+ 02 May 2013; Sergey Popov <pinkbyte@gentoo.org> +lc-vrooby-0.5.95.ebuild:
+ Bump app-leechcraft/lc-vrooby to 0.5.95, thanks to 0xd34df00d
12 Apr 2013; Sergey Popov <pinkbyte@gentoo.org> lc-vrooby-9999.ebuild:
Bump EAPI to 5. Now both udisks backends can be compiled and used, thanks to
diff --git a/app-leechcraft/lc-vrooby/lc-vrooby-0.5.95.ebuild b/app-leechcraft/lc-vrooby/lc-vrooby-0.5.95.ebuild
new file mode 100644
index 000000000000..e6dfc548447f
--- /dev/null
+++ b/app-leechcraft/lc-vrooby/lc-vrooby-0.5.95.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-vrooby/lc-vrooby-0.5.95.ebuild,v 1.1 2013/05/02 15:37:55 pinkbyte Exp $
+
+EAPI="5"
+
+inherit leechcraft
+
+DESCRIPTION="Vrooby, removable device manager for LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug udisks udisks2"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtdbus:4"
+RDEPEND="${DEPEND}
+ udisks? ( sys-fs/udisks:0 )
+ udisks2? ( sys-fs/udisks:2 )
+ "
+
+REQUIRED_USE="|| ( udisks udisks2 )"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable udisks VROOBY_UDISKS)
+ $(cmake-utils_use_enable udisks2 VROOBY_UDISKS2)
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if use udisks2; then
+ elog "You have enabled the experimental UDisks2 backend. "
+ elog "Please try the old udisks:0-based one before "
+ elog "reporting issues."
+ fi
+}