summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-26 01:29:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-26 01:29:40 +0000
commit434e2919fb7b4ffd5a904e02a5cb76051b2f2763 (patch)
treee93832cbec75db45b270cda0e11152f5e8df5638 /app-misc/booh
parentVersion bump. (diff)
downloadgentoo-2-434e2919fb7b4ffd5a904e02a5cb76051b2f2763.tar.gz
gentoo-2-434e2919fb7b4ffd5a904e02a5cb76051b2f2763.tar.bz2
gentoo-2-434e2919fb7b4ffd5a904e02a5cb76051b2f2763.zip
Version bump. Add ruby19 support. Cleanup old.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-misc/booh')
-rw-r--r--app-misc/booh/ChangeLog9
-rw-r--r--app-misc/booh/booh-0.9.4.ebuild (renamed from app-misc/booh/booh-0.9.3.ebuild)40
-rw-r--r--app-misc/booh/files/booh-0.9.1-require_gems.patch70
3 files changed, 27 insertions, 92 deletions
diff --git a/app-misc/booh/ChangeLog b/app-misc/booh/ChangeLog
index 4cec04820d09..75be087b1ef3 100644
--- a/app-misc/booh/ChangeLog
+++ b/app-misc/booh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/booh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/ChangeLog,v 1.31 2013/08/11 07:00:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/ChangeLog,v 1.32 2013/11/26 01:29:40 mrueg Exp $
+
+*booh-0.9.4 (26 Nov 2013)
+
+ 26 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +booh-0.9.4.ebuild,
+ -booh-0.9.3.ebuild, -files/booh-0.9.1-require_gems.patch:
+ Version bump. Add ruby19 support. Cleanup old.
11 Aug 2013; Hans de Graaff <graaff@gentoo.org> metadata.xml:
Drop package from ruby herd as per 2013-07-21 announcement.
@@ -133,4 +139,3 @@
01 Apr 2005; <dams@gentoo.org> +metadata.xml, +booh-0.1.0.ebuild:
first ebuild
-
diff --git a/app-misc/booh/booh-0.9.3.ebuild b/app-misc/booh/booh-0.9.4.ebuild
index 82f6709baf46..db341e001a44 100644
--- a/app-misc/booh/booh-0.9.3.ebuild
+++ b/app-misc/booh/booh-0.9.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/booh-0.9.3.ebuild,v 1.2 2011/03/01 18:40:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/booh/booh-0.9.4.ebuild,v 1.1 2013/11/26 01:29:40 mrueg Exp $
-EAPI="2"
-USE_RUBY="ruby18"
+EAPI=5
+USE_RUBY="ruby18 ruby19"
-inherit eutils bash-completion ruby-ng
+inherit eutils bash-completion-r1 ruby-ng
DESCRIPTION="Static HTML photo album generator"
HOMEPAGE="http://booh.org/index.html"
@@ -28,7 +28,7 @@ RDEPEND="${RDEPEND} ${CDEPEND}
ruby_add_rdepend "
>=dev-ruby/ruby-gettext-0.8.0
dev-ruby/ruby-glib2
- gtk? ( >=dev-ruby/ruby-gtk2-0.12 )"
+ gtk? ( >=dev-ruby/ruby-gtk2-0.12 )"
all_ruby_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.2.2-stdc.patch
@@ -36,8 +36,10 @@ all_ruby_prepare() {
# Remove scripts requiring gtk if gtk is not used
if ! use gtk; then
rm bin/booh bin/booh-classifier bin/booh-fix-whitebalance \
- bin/booh-gamma-correction
+ bin/booh-gamma-correction || die
fi
+ sed -i -e 's/-48x48.png//' desktop/booh-classifier.desktop || die
+ sed -i -e 's/-48x48.png//' desktop/booh.desktop || die
}
each_ruby_configure() {
@@ -45,30 +47,28 @@ each_ruby_configure() {
${RUBY} setup.rb setup || die "ruby setup.rb setup failed"
cd ext
${RUBY} extconf.rb || die "ruby extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined ::' Makefile || die "--no-undefined removal failed"
- sed -i -e 's:-Wl,-R$(libdir)::' -e 's:-Wl,-R -Wl,$(libdir)::' Makefile || die "Fix insecure RUNPATH failed"
+ sed -i -e 's:-Wl,--no-undefined ::' -e 's:-Wl,-R$(libdir)::'\
+ -e 's:-Wl,-R -Wl,$(libdir)::' Makefile || die
}
each_ruby_compile() {
- emake -Cext || die
+ emake -Cext V=1
}
each_ruby_install() {
${RUBY} setup.rb install \
--prefix="${D}" || die "ruby setup.rb install failed"
cd ext
- emake install \
- DESTDIR=${D} \
- libdir=${D}/`ruby -rrbconfig -e "puts Config::CONFIG['sitelibdir']"` \
- archdir=${D}/`ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']"` \
- || die "emake install failed"
+ emake install V=1 \
+ DESTDIR="${D}" \
+ libdir="${D}"/$(${RUBY} -rrbconfig -e "puts Config::CONFIG['sitelibdir']") \
+ archdir="${D}"/$({$RUBY} -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
cd ..
}
all_ruby_install() {
- domenu desktop/booh-classifier.desktop desktop/booh.desktop || die "domenu failed"
- doicon desktop/booh-48x48.png || die "doicon failed"
- dobashcompletion booh.bash-completion || die "dobashcompletion failed"
- dodoc AUTHORS ChangeLog INTERNALS README VERSION THEMES \
- || die "dodoc failed"
+ domenu desktop/booh-classifier.desktop desktop/booh.desktop
+ newicon -s 48 desktop/booh-48x48.png booh.png
+ dobashcomp booh.bash-completion
+ dodoc AUTHORS ChangeLog INTERNALS README VERSION THEMES
}
diff --git a/app-misc/booh/files/booh-0.9.1-require_gems.patch b/app-misc/booh/files/booh-0.9.1-require_gems.patch
deleted file mode 100644
index 304d9c4a4df3..000000000000
--- a/app-misc/booh/files/booh-0.9.1-require_gems.patch
+++ /dev/null
@@ -1,70 +0,0 @@
---- bin/album2booh.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/album2booh 2008-07-06 13:30:21.000000000 +0100
-@@ -33,6 +33,7 @@
- # $ recode ISO-8859-1..UTF-8 captions.txt
- #
-
-+require 'rubygems'
- require 'getoptlong'
- require 'gettext'
- include GetText
---- bin/booh.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/booh 2008-07-06 13:30:40.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'getoptlong'
- require 'tempfile'
- require 'thread'
---- bin/booh-backend.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/booh-backend 2008-07-06 13:30:51.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'getoptlong'
- require 'gettext'
- require 'gettext/locale'
---- bin/booh-classifier.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/booh-classifier 2008-07-06 13:31:02.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'getoptlong'
- require 'tempfile'
-
---- bin/booh-fix-whitebalance.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/booh-fix-whitebalance 2008-07-06 13:31:13.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'gtk2'
- require 'booh/libadds'
-
---- bin/booh-gamma-correction.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/booh-gamma-correction 2008-07-06 13:31:24.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'gtk2'
- require 'booh/libadds'
-
---- bin/webalbum2booh.old 2008-07-06 13:28:37.000000000 +0100
-+++ bin/webalbum2booh 2008-07-06 13:34:13.000000000 +0100
-@@ -19,6 +19,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
-
-+require 'rubygems'
- require 'getoptlong'
- require 'gettext'
- include GetText