summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-15 13:55:25 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-15 13:55:25 +0000
commit1c6000f9fdbf8bc53060e31bb92f83b62430fb68 (patch)
tree31ad441c5637f150039102294a6ad2f68bc6d551 /app-misc/byobu
parentdev-python/pytools: Add correct PYTHON_USEDEP (diff)
downloadgentoo-2-1c6000f9fdbf8bc53060e31bb92f83b62430fb68.tar.gz
gentoo-2-1c6000f9fdbf8bc53060e31bb92f83b62430fb68.tar.bz2
gentoo-2-1c6000f9fdbf8bc53060e31bb92f83b62430fb68.zip
app-misc/byobu: Version Bump, #452140; move to python-single-r1.eclass
(Portage version: 2.2.0_alpha152/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-misc/byobu')
-rw-r--r--app-misc/byobu/ChangeLog10
-rw-r--r--app-misc/byobu/byobu-5.27.ebuild40
-rw-r--r--app-misc/byobu/metadata.xml25
3 files changed, 65 insertions, 10 deletions
diff --git a/app-misc/byobu/ChangeLog b/app-misc/byobu/ChangeLog
index 8f83dd8e3291..1bd70f984186 100644
--- a/app-misc/byobu/ChangeLog
+++ b/app-misc/byobu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/byobu
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.40 2012/05/31 14:34:32 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/ChangeLog,v 1.41 2013/01/15 13:55:25 jlec Exp $
+
+*byobu-5.27 (15 Jan 2013)
+
+ 15 Jan 2013; Justin Lecher <jlec@gentoo.org> +byobu-5.27.ebuild,
+ metadata.xml:
+ Version Bump, #452140; move to python-single-r1.eclass
31 May 2012; Tim Harder <radhermit@gentoo.org> -byobu-5.15.ebuild:
Remove old.
diff --git a/app-misc/byobu/byobu-5.27.ebuild b/app-misc/byobu/byobu-5.27.ebuild
new file mode 100644
index 000000000000..b656642fa49f
--- /dev/null
+++ b/app-misc/byobu/byobu-5.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/byobu/byobu-5.27.ebuild,v 1.1 2013/01/15 13:55:25 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+
+inherit python-single-r1
+
+DESCRIPTION="A set of profiles for the GNU Screen console window manager (app-misc/screen)"
+HOMEPAGE="http://byobu.co"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P/-/_}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="screen"
+
+DEPEND="dev-libs/newt"
+RDEPEND="${DEPEND}
+ screen? ( app-misc/screen )
+ !screen? ( app-misc/tmux )"
+
+src_prepare() {
+ python_fix_shebang .
+
+ # Set default system backend to screen
+ if use screen ; then
+ sed -i -e 's/#\(BYOBU_BACKEND\).*/\1="screen"/' etc/byobu/backend || die
+ fi
+}
+
+src_install() {
+ default
+
+ # Create symlinks for backends
+ dosym ${PN} /usr/bin/${PN}-screen
+ dosym ${PN} /usr/bin/${PN}-tmux
+}
diff --git a/app-misc/byobu/metadata.xml b/app-misc/byobu/metadata.xml
index 68f91fde4b3a..b6bdd77b25c6 100644
--- a/app-misc/byobu/metadata.xml
+++ b/app-misc/byobu/metadata.xml
@@ -1,12 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>shell-tools</herd>
-<maintainer>
- <email>weaver@gentoo.org</email>
- <name>Andrey Kislyuk</name>
-</maintainer>
-<use>
- <flag name="screen">Use <pkg>app-misc/screen</pkg> as the default backend</flag>
-</use>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>weaver@gentoo.org</email>
+ <name>Andrey Kislyuk</name>
+ </maintainer>
+ <longdescription>
+Byobu is a GPLv3 open source text-based window manager and terminal multiplexer.
+It was originally designed to provide elegant enhancements to the otherwise
+functional, plain, practical GNU Screen, for the Ubuntu server distribution.
+Byobu now includes an enhanced profiles, convenient keybindings, configuration
+utilities, and toggle-able system status notifications for both the GNU Screen
+window manager and the more modern Tmux terminal multiplexer, and works on most
+Linux, BSD, and Mac distributions.
+</longdescription>
+ <use>
+ <flag name="screen">Use <pkg>app-misc/screen</pkg> as the default backend</flag>
+ </use>
</pkgmetadata>