summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-03-16 09:24:33 +0000
committerThilo Bangert <bangert@gentoo.org>2009-03-16 09:24:33 +0000
commitf6e29e87cfc5cf4212f7998944ab4d84bc80731d (patch)
tree6e1e8a19a6545eb3d03d1e6e4d0158a9e5579e3f /app-misc/cstream
parentAdd test dependencies. EAPI=2 (diff)
downloadgentoo-2-f6e29e87cfc5cf4212f7998944ab4d84bc80731d.tar.gz
gentoo-2-f6e29e87cfc5cf4212f7998944ab4d84bc80731d.tar.bz2
gentoo-2-f6e29e87cfc5cf4212f7998944ab4d84bc80731d.zip
cstream is a general-purpose stream-handling tool like UNIX dd - bug #215545 - based in part on work by Priit Laes - thanks
(Portage version: 2.2_rc24/cvs/Linux i686)
Diffstat (limited to 'app-misc/cstream')
-rw-r--r--app-misc/cstream/ChangeLog10
-rw-r--r--app-misc/cstream/cstream-2.7.6.ebuild25
-rw-r--r--app-misc/cstream/metadata.xml22
3 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/cstream/ChangeLog b/app-misc/cstream/ChangeLog
new file mode 100644
index 000000000000..86b5a2d7798a
--- /dev/null
+++ b/app-misc/cstream/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-misc/cstream
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cstream/ChangeLog,v 1.1 2009/03/16 09:24:33 bangert Exp $
+
+*cstream-2.7.6 (16 Mar 2009)
+
+ 16 Mar 2009; Thilo Bangert <bangert@gentoo.org> +metadata.xml,
+ +cstream-2.7.6.ebuild:
+ cstream is a general-purpose stream-handling tool like UNIX dd - bug #215545
+
diff --git a/app-misc/cstream/cstream-2.7.6.ebuild b/app-misc/cstream/cstream-2.7.6.ebuild
new file mode 100644
index 000000000000..a543747a52ea
--- /dev/null
+++ b/app-misc/cstream/cstream-2.7.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cstream/cstream-2.7.6.ebuild,v 1.1 2009/03/16 09:24:33 bangert Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="cstream is a general-purpose stream-handling tool like UNIX dd"
+HOMEPAGE="http://www.cons.org/cracauer/cstream.html"
+SRC_URI="http://www.cons.org/cracauer/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
diff --git a/app-misc/cstream/metadata.xml b/app-misc/cstream/metadata.xml
new file mode 100644
index 000000000000..13a6726c24ed
--- /dev/null
+++ b/app-misc/cstream/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+cstream is a general-purpose stream-handling tool like UNIX dd, usually used in commandline-constructed pipes.
+Features:
+ - Sane commandline switch syntax.
+ - Exact throughput limiting, on the incoming side. Timing variance in previous reads are counterbalanced in the following reads.
+ - Precise throughput reporting. Either at the end of the transmission or everytime SIGUSR1 is received. Quite useful to ask lengthy operations how much data has been transferred yet, i.e. when writing tapes. Reports are done in bytes/sec and if appropriate in KB/sec or MB/sec, where 1K = 1024.
+ - SIGHUP causes a clean shutdown before EOF on input, timing information is displayed.
+ - Build-in support to write its PID to a file, for painless sending of these signals.
+ - Build-in support for fifos. Example usage is a 'pseudo-device', something that sinks or delivers data at an appropriate rate, but looks like a file, i.e. if you test soundcard software. See the manpage for examples.
+ - Built-in data creation and sink, no more redirection of /dev/null and /dev/zero. These special devices speed varies greatly among operating systems, redirecting from it isn't appropriate benchmarking and a waste of resources anyway.
+ - Accepts 'k', 'm' and 'g' character after number for "kilo, mega, giga" bytes for overall data size limit.
+ - "gcc -Wall" clean source code, serious effort taken to avoid undefined behavior in ANSI C or POSIX, except long long is required. Limiting and reporting works on data amounts > 4 GB.
+</longdescription>
+</pkgmetadata>
+