summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 13:57:51 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-06 13:57:51 +0000
commit9c0aa9428eb2cdac912ebe9b6226aa0a201ba538 (patch)
tree81059b1a928b700074ddf33e970818757182f32f /app-misc/detox
parentadded log4j to classpath in catalina.sh, fixes #84206. thanks to Santiago Gal... (diff)
downloadgentoo-2-9c0aa9428eb2cdac912ebe9b6226aa0a201ba538.tar.gz
gentoo-2-9c0aa9428eb2cdac912ebe9b6226aa0a201ba538.tar.bz2
gentoo-2-9c0aa9428eb2cdac912ebe9b6226aa0a201ba538.zip
Switch to using patches rather than scary sed voodoo after discussion with upstream.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-misc/detox')
-rw-r--r--app-misc/detox/ChangeLog8
-rw-r--r--app-misc/detox/Manifest14
-rw-r--r--app-misc/detox/detox-1.1.0.ebuild13
-rw-r--r--app-misc/detox/files/detox-1.1.0-destdir.patch29
-rw-r--r--app-misc/detox/files/detox-1.1.0-parallel_build.patch18
5 files changed, 62 insertions, 20 deletions
diff --git a/app-misc/detox/ChangeLog b/app-misc/detox/ChangeLog
index 9fe2ef2223ad..fce7ff83417d 100644
--- a/app-misc/detox/ChangeLog
+++ b/app-misc/detox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/detox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.1 2005/03/05 21:55:55 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.2 2005/03/06 13:57:51 ciaranm Exp $
+
+ 06 Mar 2005; Ciaran McCreesh <ciaranm@gentoo.org>
+ +files/detox-1.1.0-destdir.patch, +files/detox-1.1.0-parallel_build.patch,
+ detox-1.1.0.ebuild:
+ Switch to using patches rather than scary sed voodoo after discussion with
+ upstream.
*detox-1.1.0 (05 Mar 2005)
diff --git a/app-misc/detox/Manifest b/app-misc/detox/Manifest
index ce046f169de5..e17a63106410 100644
--- a/app-misc/detox/Manifest
+++ b/app-misc/detox/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c40ed5d0b5bd59957990a12d37fc78d2 detox-1.1.0.ebuild 1053
+MD5 c8f4edf11aec610ffddf8a96606113e4 detox-1.1.0.ebuild 863
MD5 c606001a83e8e321038d9f6eaf97fa3c ChangeLog 336
MD5 59a60cdc8808a819079d812201932f0a metadata.xml 262
MD5 1d0744431cb2efc1a65dd1e56b11d41c files/digest-detox-1.1.0 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFCKirhLLFUmVNQ7rkRAjYIAJ9uUNlriEdlKU7nPDXzNyeg+2xYvACg0Yjq
-AfXXsh5cC8TTZ+ecukBhUzI=
-=kQpr
------END PGP SIGNATURE-----
+MD5 61eb83c84fbace15d61c315160ca0e5e files/detox-1.1.0-parallel_build.patch 564
+MD5 add7e896e354520ac846d697a60a06fc files/detox-1.1.0-destdir.patch 1041
diff --git a/app-misc/detox/detox-1.1.0.ebuild b/app-misc/detox/detox-1.1.0.ebuild
index 02a0e5ccad1a..ba11e1c07c16 100644
--- a/app-misc/detox/detox-1.1.0.ebuild
+++ b/app-misc/detox/detox-1.1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.1.0.ebuild,v 1.1 2005/03/05 21:55:55 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.1.0.ebuild,v 1.2 2005/03/06 13:57:51 ciaranm Exp $
+
+inherit eutils
DESCRIPTION="detox safely removes spaces and strange characters from filenames"
HOMEPAGE="http://detox.sourceforge.net/"
@@ -21,17 +23,12 @@ src_unpack() {
unpack ${A}
cd ${S}
- # make DESTDIR installs work
- sed -i -e '/\${INSTALL}/s,\(^.*\)\$,\1${DESTDIR}/$,g' Makefile.in \
- || die "Makefile.in fix 1 failed. That isn't supposed to happen."
+ epatch ${FILESDIR}/${P}-destdir.patch
+ epatch ${FILESDIR}/${P}-parallel_build.patch
}
src_compile() {
econf --with-popt || die "econf failed"
-
- # The lengths I go to to get parallel make to work. Ain't I kind?
- emake -j 1 config_file_l.c
- emake -j 1 config_file_y.h
emake || die "emake failed"
}
diff --git a/app-misc/detox/files/detox-1.1.0-destdir.patch b/app-misc/detox/files/detox-1.1.0-destdir.patch
new file mode 100644
index 000000000000..29f2e25eee82
--- /dev/null
+++ b/app-misc/detox/files/detox-1.1.0-destdir.patch
@@ -0,0 +1,29 @@
+--- detox-1.1.0/Makefile.in.orig 2005-03-05 21:58:20.021389152 +0000
++++ detox-1.1.0/Makefile.in 2005-03-05 21:59:01.885024912 +0000
+@@ -90,16 +90,16 @@
+ #
+
+ install: detox
+- ${INSTALL} -d ${bindir}
+- ${INSTALL} -d ${mandir}/man1
+- ${INSTALL} -d ${mandir}/man5
+- ${INSTALL} -d ${sysconfdir}
+- ${INSTALL} -d ${datadir}/detox
+- ${INSTALL} detox ${bindir}
+- ${INSTALL} detox.1 ${mandir}/man1
+- ${INSTALL} detoxrc.5 detox.tbl.5 ${mandir}/man5
+- ${INSTALL} detoxrc ${sysconfdir}
+- ${INSTALL} iso8859_1.tbl unicode.tbl ${datadir}/detox
++ ${INSTALL} -d ${DESTDIR}/${bindir}
++ ${INSTALL} -d ${DESTDIR}/${mandir}/man1
++ ${INSTALL} -d ${DESTDIR}/${mandir}/man5
++ ${INSTALL} -d ${DESTDIR}/${sysconfdir}
++ ${INSTALL} -d ${DESTDIR}/${datadir}/detox
++ ${INSTALL} detox ${DESTDIR}/${bindir}
++ ${INSTALL} detox.1 ${DESTDIR}/${mandir}/man1
++ ${INSTALL} detoxrc.5 detox.tbl.5 ${DESTDIR}/${mandir}/man5
++ ${INSTALL} detoxrc ${DESTDIR}/${sysconfdir}
++ ${INSTALL} iso8859_1.tbl unicode.tbl ${DESTDIR}/${datadir}/detox
+
+ clean:
+ rm -f *.o core *~ a.out *.core
diff --git a/app-misc/detox/files/detox-1.1.0-parallel_build.patch b/app-misc/detox/files/detox-1.1.0-parallel_build.patch
new file mode 100644
index 000000000000..743016ff36b4
--- /dev/null
+++ b/app-misc/detox/files/detox-1.1.0-parallel_build.patch
@@ -0,0 +1,18 @@
+--- detox-1.1.0/Makefile.in.orig 5 Mar 2005 05:02:12 -0000 1.24
++++ detox-1.1.0/Makefile.in 6 Mar 2005 05:19:41 -0000
+@@ -72,11 +72,14 @@
+ ${LEX} config_file.l
+ mv lex.yy.c config_file_l.c
+
+-config_file_y.h config_file_y.c: config_file.y
++config_file_y.c: config_file.y
+ ${YACC} -d config_file.y
+ mv y.tab.c config_file_y.c
+ mv y.tab.h config_file_y.h
+
++# In case some future rule depends on config_file_y.h
++config_file_y.h: config_file_y.c
++
+ detox_path.h: config.status
+ > detox_path.h
+ echo "char default_etc_dir[]=\"${sysconfdir}\";" >> detox_path.h