summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-01-03 22:34:48 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-01-03 22:34:48 +0000
commit0adb8fb69ddb57422681043a5e61a8a5fd351554 (patch)
treea9d3aa155ade801a150b8afbdc9be277bb7df530 /app-misc/geneweb
parentocamlopt use flag for app-misc/geneweb (diff)
downloadgentoo-2-0adb8fb69ddb57422681043a5e61a8a5fd351554.tar.gz
gentoo-2-0adb8fb69ddb57422681043a5e61a8a5fd351554.tar.bz2
gentoo-2-0adb8fb69ddb57422681043a5e61a8a5fd351554.zip
Version bump to 5.01 plus optional ocamlopt support. Bug #204110
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-misc/geneweb')
-rw-r--r--app-misc/geneweb/ChangeLog11
-rw-r--r--app-misc/geneweb/files/digest-geneweb-5.013
-rw-r--r--app-misc/geneweb/files/geneweb-5.01-gentoo.patch13
-rw-r--r--app-misc/geneweb/geneweb-5.01.ebuild81
4 files changed, 106 insertions, 2 deletions
diff --git a/app-misc/geneweb/ChangeLog b/app-misc/geneweb/ChangeLog
index d338adc5d101..98f07d18f48b 100644
--- a/app-misc/geneweb/ChangeLog
+++ b/app-misc/geneweb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/geneweb
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/ChangeLog,v 1.2 2007/08/26 20:01:16 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/ChangeLog,v 1.3 2008/01/03 22:34:47 tupone Exp $
+
+*geneweb-5.01 (03 Jan 2008)
+
+ 03 Jan 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/geneweb-5.01-gentoo.patch, +geneweb-5.01.ebuild:
+ Version bump to 5.01 plus optional ocamlopt support.
+ Bug #204110 by Alexis Ballier <aballier@gentoo.org>
26 Aug 2007; Tupone Alfredo <tupone@gentoo.org> geneweb-5.00.ebuild:
Added ~x86 keyword
diff --git a/app-misc/geneweb/files/digest-geneweb-5.01 b/app-misc/geneweb/files/digest-geneweb-5.01
new file mode 100644
index 000000000000..0d96a15d18a4
--- /dev/null
+++ b/app-misc/geneweb/files/digest-geneweb-5.01
@@ -0,0 +1,3 @@
+MD5 a1a763213d08bc0e0f547dff9b6f2ee4 geneweb-5.01.tgz 1388008
+RMD160 75507bb35df74b92becc8514c9ad82c8f4ef886e geneweb-5.01.tgz 1388008
+SHA256 dcc6b2ea4659e8dc816ab3ea573d9177bdd83597c36d8628f9ce1dbc30a28e6c geneweb-5.01.tgz 1388008
diff --git a/app-misc/geneweb/files/geneweb-5.01-gentoo.patch b/app-misc/geneweb/files/geneweb-5.01-gentoo.patch
new file mode 100644
index 000000000000..fa3001aec4b9
--- /dev/null
+++ b/app-misc/geneweb/files/geneweb-5.01-gentoo.patch
@@ -0,0 +1,13 @@
+--- setup/setup.ml.old 2007-08-07 19:25:13.000000000 +0200
++++ setup/setup.ml 2007-08-07 19:24:59.000000000 +0200
+@@ -5,8 +5,8 @@
+
+ value port = ref 2316;
+ value default_lang = ref "en";
+-value setup_dir = ref ".";
+-value bin_dir = ref "";
++value setup_dir = ref "/usr/share/geneweb";
++value bin_dir = ref "/usr/bin";
+ value lang_param = ref "";
+ value only_file = ref "";
+
diff --git a/app-misc/geneweb/geneweb-5.01.ebuild b/app-misc/geneweb/geneweb-5.01.ebuild
new file mode 100644
index 000000000000..d10d8c501513
--- /dev/null
+++ b/app-misc/geneweb/geneweb-5.01.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/geneweb/geneweb-5.01.ebuild,v 1.1 2008/01/03 22:34:47 tupone Exp $
+
+inherit eutils
+
+EAPI="1"
+
+DESCRIPTION="Genealogy software program with a Web interface."
+HOMEPAGE="http://cristal.inria.fr/~ddr/GeneWeb/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/Projects/cristal/${PN}/Src/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml
+ dev-ml/camlp5"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt
+ then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:/usr/share/${PN}:" \
+ setup/setup.ml || die "Failed sed for gentoo path"
+}
+
+src_compile() {
+ econf
+ if use ocamlopt; then
+ emake || die "Compiling native code executables failed"
+ else
+ emake OCAMLC=ocamlc OCAMLOPT=ocamlopt out \
+ || die "Compiling byte code executables failed"
+ # If using bytecode we dont want to strip the binary as it would remove
+ # the bytecode and only leave ocamlrun...
+ export STRIP_MASK="*/bin/*"
+ fi
+}
+
+src_install() {
+ # Install binaries
+ dobin src/{consang,check_base,gwc,gwd,gwu} \
+ ged2gwb/ged2gwb gwb2ged/gwb2ged setup/gwsetup \
+ || die "Failed installing binaries"
+ # Install manpages
+ doman man/* || die "Failed installing man pages"
+
+ # Install doc
+ dodoc ICHANGES etc/LISEZMOI.distrib.txt etc/README.distrib.txt \
+ CHANGES etc/a.gwf etc/LISEZMOI.distrib.txt README.distrib.txt
+ insinto /usr/share/doc/${PF}/contrib
+ doins -r contrib/{misc,templ} || die "Failed installing contributions"
+
+ make distrib || die "Failed making distrib"
+ insinto /usr/share/${PN}
+ doins -r distribution/gw/{doc,etc,gwd.arg,images,lang,only.txt,setup} \
+ || die "Failed installing data"
+ insinto /usr/lib/${PN}
+ doins -r distribution/gw/gwtp_tmp/* || die "Failed installing CGI program"
+
+ newinitd "${FILESDIR}/geneweb.initd" geneweb
+ newconfd "${FILESDIR}/geneweb.confd" geneweb
+}
+
+pkg_postinst() {
+ enewuser geneweb "" "/bin/bash" /var/lib/geneweb
+ einfo "A CGI program has been installed in /usr/lib/${PN}. Follow the"
+ einfo "instructions on the README in that directory to use it"
+}