summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-09-04 21:14:10 +0000
committerJeroen Roovers <jer@gentoo.org>2014-09-04 21:14:10 +0000
commit68c30c6b6e5de1a9f9d3dd7832ed1c62404c941c (patch)
tree9593cc84cf3af268409a2c24e93f529a1a1c0703 /app-misc/gtypist
parentVersion bump. (diff)
downloadgentoo-2-68c30c6b6e5de1a9f9d3dd7832ed1c62404c941c.tar.gz
gentoo-2-68c30c6b6e5de1a9f9d3dd7832ed1c62404c941c.tar.bz2
gentoo-2-68c30c6b6e5de1a9f9d3dd7832ed1c62404c941c.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/ChangeLog9
-rw-r--r--app-misc/gtypist/gtypist-2.9.5.ebuild70
2 files changed, 77 insertions, 2 deletions
diff --git a/app-misc/gtypist/ChangeLog b/app-misc/gtypist/ChangeLog
index 15c7bf57a344..178cda1473dc 100644
--- a/app-misc/gtypist/ChangeLog
+++ b/app-misc/gtypist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gtypist
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.34 2013/01/13 14:58:18 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.35 2014/09/04 21:14:10 jer Exp $
+
+*gtypist-2.9.5 (04 Sep 2014)
+
+ 04 Sep 2014; Jeroen Roovers <jer@gentoo.org> +gtypist-2.9.5.ebuild:
+ Version bump.
*gtypist-2.9.2 (13 Jan 2013)
diff --git a/app-misc/gtypist/gtypist-2.9.5.ebuild b/app-misc/gtypist/gtypist-2.9.5.ebuild
new file mode 100644
index 000000000000..71c7273f49ed
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.9.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.9.5.ebuild,v 1.1 2014/09/04 21:14:10 jer Exp $
+
+EAPI=5
+inherit eutils elisp-common
+
+DESCRIPTION="Universal typing tutor"
+HOMEPAGE="http://www.gnu.org/software/gtypist/"
+SRC_URI="mirror://gnu/gtypist/${P}.tar.xz
+ http://colemak.com/pub/learn/colemak.typ"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="nls emacs xemacs"
+
+DEPEND="
+ >=sys-libs/ncurses-5.2
+ emacs? ( virtual/emacs )
+ xemacs? ( !emacs? ( app-editors/xemacs app-xemacs/fsf-compat ) )
+"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
+}
+
+src_configure() {
+ local lispdir=""
+ if use emacs; then
+ lispdir="${SITELISP}/${PN}"
+ einfo "Configuring to build with GNU Emacs support"
+ elif use xemacs; then
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/lisp/${PN}"
+ einfo "Configuring to build with XEmacs support"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ EMACS=$(usev emacs || usev xemacs || echo no) \
+ --with-lispdir="${lispdir}"
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_install() {
+ default
+
+ insinto /usr/share/gtypist
+ doins "${DISTDIR}"/colemak.typ
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}