summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-06-07 23:40:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-06-07 23:40:24 +0000
commitc2095bc1ae21f50a6f7f38321dff2b5d36e3b955 (patch)
treebc5e3cac834aa5087c6924f433b75d3c0d264c6f /app-misc/ktoblzcheck
parentFix use invocation (Manifest recommit) (diff)
downloadgentoo-2-c2095bc1ae21f50a6f7f38321dff2b5d36e3b955.tar.gz
gentoo-2-c2095bc1ae21f50a6f7f38321dff2b5d36e3b955.tar.bz2
gentoo-2-c2095bc1ae21f50a6f7f38321dff2b5d36e3b955.zip
Fixed install to solve bug #53211. Added test routine too. Thanks carlo@g.o
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ChangeLog5
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/app-misc/ktoblzcheck/ChangeLog b/app-misc/ktoblzcheck/ChangeLog
index f645f759555d..29dd0b3306bd 100644
--- a/app-misc/ktoblzcheck/ChangeLog
+++ b/app-misc/ktoblzcheck/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/ktoblzcheck
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.4 2004/06/07 13:08:42 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ChangeLog,v 1.5 2004/06/07 23:40:24 dragonheart Exp $
+
+ 08 Jun 2004; Daniel Black <dragonheart@gentoo.org> ktoblzcheck-0.7.ebuild:
+ Fixed install to solve bug #53211. Added test routine too. Thanks carlo@g.o
07 Jun 2004; Daniel Black <dragonheart@gentoo.org> ktoblzcheck-0.7.ebuild:
no 0.7 yet - access violation - bug #53211
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
index 5c451b3cb053..6d42e0ef362d 100644
--- a/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
+++ b/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild,v 1.2 2004/06/07 13:08:42 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ktoblzcheck/ktoblzcheck-0.7.ebuild,v 1.3 2004/06/07 23:40:24 dragonheart Exp $
DESCRIPTION="Library to check account numbers and bank codes of German banks"
HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
@@ -17,10 +17,15 @@ DEPEND="${RDEPEND}
sys-devel/gcc"
src_compile() {
- econf || die
- emake || die
+ econf || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- einstall || die
+ emake DESTDIR=${D} || die "install failed"
+}
+
+src_test() {
+ cd ${S}/src/bin/
+ ./check_ktoblzcheck || die "self check of accounts failed"
}