summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2008-09-12 23:58:55 +0000
committerRobert Buchholz <rbu@gentoo.org>2008-09-12 23:58:55 +0000
commitbfcc41ef1517f7b3e96822680203ebc7a880bd28 (patch)
treeaa570385400d050171a800d80e30d56666a2a7fc /app-misc/lcdproc
parentadd games-strategy/smac to no-multilib mask (diff)
downloadgentoo-2-bfcc41ef1517f7b3e96822680203ebc7a880bd28.tar.gz
gentoo-2-bfcc41ef1517f7b3e96822680203ebc7a880bd28.tar.bz2
gentoo-2-bfcc41ef1517f7b3e96822680203ebc7a880bd28.zip
Add imonlcd to support Antec iMON LCD modules (bug #232328), lcdproc init
script should start after ntp-client (bug #234084), fix quoting. (Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc6 x86_64)
Diffstat (limited to 'app-misc/lcdproc')
-rw-r--r--app-misc/lcdproc/ChangeLog10
-rw-r--r--app-misc/lcdproc/files/0.5.2-r2-lcdproc.initd22
-rw-r--r--app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild8
-rw-r--r--app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild8
-rw-r--r--app-misc/lcdproc/lcdproc-0.5.2-r2.ebuild186
5 files changed, 225 insertions, 9 deletions
diff --git a/app-misc/lcdproc/ChangeLog b/app-misc/lcdproc/ChangeLog
index 3ece6d3d7e94..75e9be83db6b 100644
--- a/app-misc/lcdproc/ChangeLog
+++ b/app-misc/lcdproc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/lcdproc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.63 2008/07/31 16:31:50 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/ChangeLog,v 1.64 2008/09/12 23:58:55 rbu Exp $
+
+*lcdproc-0.5.2-r2 (12 Sep 2008)
+
+ 12 Sep 2008; Robert Buchholz <rbu@gentoo.org>
+ +files/0.5.2-r2-lcdproc.initd, lcdproc-0.5.1-r4.ebuild,
+ lcdproc-0.5.2-r1.ebuild, +lcdproc-0.5.2-r2.ebuild:
+ Add imonlcd to support Antec iMON LCD modules (bug #232328), lcdproc init
+ script should start after ntp-client (bug #234084), fix quoting.
31 Jul 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/app-misc/lcdproc/files/0.5.2-r2-lcdproc.initd b/app-misc/lcdproc/files/0.5.2-r2-lcdproc.initd
new file mode 100644
index 000000000000..aa161a93991c
--- /dev/null
+++ b/app-misc/lcdproc/files/0.5.2-r2-lcdproc.initd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/files/0.5.2-r2-lcdproc.initd,v 1.1 2008/09/12 23:58:55 rbu Exp $
+
+depend(){
+ use LCDd
+ after ntp-client
+}
+
+start() {
+ ebegin "Starting lcdproc"
+ start-stop-daemon --start --background \
+ --exec /usr/bin/lcdproc
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lcdproc"
+ start-stop-daemon --stop --exec /usr/bin/lcdproc
+ eend $?
+}
diff --git a/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild b/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild
index 3c53e83f5e56..4c046f9453f5 100644
--- a/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild
+++ b/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild,v 1.6 2007/05/06 21:26:27 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.5.1-r4.ebuild,v 1.7 2008/09/12 23:58:55 rbu Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -135,12 +135,12 @@ src_compile() {
if use doc; then
ebegin "Creating user documentation"
- cd ${S}/docs/lcdproc-user
+ cd "${S}"/docs/lcdproc-user
xmlto html lcdproc-user.docbook
eend $?
ebegin "Creating dev documentation"
- cd ${S}/docs/lcdproc-dev
+ cd "${S}"/docs/lcdproc-dev
xmlto html lcdproc-dev.docbook
eend $?
fi
diff --git a/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild b/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild
index 0760c06a7ab8..6041c44c0895 100644
--- a/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild
+++ b/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild,v 1.7 2007/08/14 21:08:27 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.5.2-r1.ebuild,v 1.8 2008/09/12 23:58:55 rbu Exp $
WANT_AUTOMAKE="1.9"
inherit eutils autotools multilib
@@ -131,12 +131,12 @@ src_compile() {
if use doc; then
ebegin "Creating user documentation"
- cd ${S}/docs/lcdproc-user
+ cd "${S}"/docs/lcdproc-user
xmlto html lcdproc-user.docbook
eend $?
ebegin "Creating dev documentation"
- cd ${S}/docs/lcdproc-dev
+ cd "${S}"/docs/lcdproc-dev
xmlto html lcdproc-dev.docbook
eend $?
fi
diff --git a/app-misc/lcdproc/lcdproc-0.5.2-r2.ebuild b/app-misc/lcdproc/lcdproc-0.5.2-r2.ebuild
new file mode 100644
index 000000000000..094048e47e06
--- /dev/null
+++ b/app-misc/lcdproc/lcdproc-0.5.2-r2.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.5.2-r2.ebuild,v 1.1 2008/09/12 23:58:55 rbu Exp $
+
+WANT_AUTOMAKE="1.9"
+inherit eutils autotools multilib
+
+DESCRIPTION="Client/Server suite to drive all kinds of LCD (-like) devices"
+HOMEPAGE="http://lcdproc.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${PF}-patches.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc debug nfs samba seamless-hbars usb lirc irman joystick"
+
+# The following array holds the USE_EXPANDed keywords
+IUSE_LCD_DEVICES=(ncurses bayrad cfontz cfontz633 cfontzpacket
+ cwlinux eyeboxone g15 graphlcd glk
+ hd44780 icpa106 imon imonlcd iowarrior
+ lb216 lcdm001 lcterm
+ md8800 ms6931 mtcs16209x mtxorb noritakevfd
+ pyramid sed1330 sed1520 serialvfd sli
+ stv5730 svga t6963 text tyan
+ ula200 xosd ea65 picolcd serialpos )
+
+# Iterate through the array and add the lcd_devices_* that we support
+NUM_DEVICES=${#IUSE_LCD_DEVICES[@]}
+index=0
+while [ "${index}" -lt "${NUM_DEVICES}" ] ; do
+ IUSE="${IUSE} lcd_devices_${IUSE_LCD_DEVICES[${index}]}"
+ let "index = ${index} + 1"
+done
+
+RDEPEND="
+ usb? ( dev-libs/libusb )
+ lirc? ( app-misc/lirc )
+ irman? ( media-libs/libirman )
+
+ lcd_devices_graphlcd? ( app-misc/graphlcd-base app-misc/glcdprocdriver )
+ lcd_devices_g15? ( dev-libs/libg15 >=dev-libs/libg15render-1.1.1 )
+ lcd_devices_ncurses? ( sys-libs/ncurses )
+ lcd_devices_svga? ( media-libs/svgalib )
+ lcd_devices_ula200? ( >=dev-embedded/libftdi-0.7 dev-libs/libusb )
+ lcd_devices_xosd? ( x11-libs/xosd x11-libs/libX11 x11-libs/libXext )
+ lcd_devices_cfontzpacket? ( dev-libs/libusb )
+ lcd_devices_cwlinux? ( dev-libs/libusb )
+ lcd_devices_pyramid? ( dev-libs/libusb )
+ lcd_devices_picolcd? ( dev-libs/libusb )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/xmlto )"
+RDEPEND="${RDEPEND}
+ lcd_devices_g15? ( app-misc/g15daemon )"
+
+pkg_setup() {
+ if [ -n "${LCDPROC_DRIVERS}" ] ; then
+ ewarn "Setting the drivers to compile via LCDPROC_DRIVERS is not supported anymore."
+ ewarn "Please use LCD_DEVICES now and see emerge -pv output for the options."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/${PF}-patches/${PV}-imonlcd-0.3.patch
+
+ epatch "${WORKDIR}"/${PF}-patches/${PV}-picolcd.patch
+
+ sed -i "79s:server/drivers:/usr/$(get_libdir)/lcdproc:" LCDd.conf
+ einfo "Patching LCDd.conf to use DriverPath=/usr/$(get_libdir)/lcdproc/"
+
+ eautoreconf
+}
+
+src_compile() {
+ # This array contains the driver names required by configure --with-drivers=
+ # The positions must be the same as the corresponding use_expand flags
+ local DEVICE_DRIVERS=(curses bayrad CFontz CFontz633 CFontzPacket
+ CwLnx EyeboxOne g15 glcdlib glk
+ hd44780 icp_a106 imon imonlcd IOWarrior
+ lb216 lcdm001 lcterm
+ MD8800 ms6931 mtc_s16209x MtxOrb NoritakeVFD
+ pyramid sed1330 sed1520 serialVFD sli
+ stv5730 svga t6963 text tyan
+ ula200 xosd ea65 picolcd serialPOS)
+
+ # Generate comma separated list of drivers
+ COMMA_DRIVERS=""
+ FIRST_DRIVER=""
+ local index=0
+
+ while [ "${index}" -lt "${NUM_DEVICES}" ] ; do
+ if use "lcd_devices_${IUSE_LCD_DEVICES[${index}]}" ; then
+ append-driver "${DEVICE_DRIVERS[${index}]}"
+ fi
+ let "index = ${index} + 1"
+ done
+
+ # Append the not-lcd-drivers (input)
+ use lirc && append-driver "lirc"
+ use irman && append-driver "irman"
+ use joystick && append-driver "joy"
+
+ if [ -z "${COMMA_DRIVERS}" ] ; then
+ ewarn "You are compiling LCDd without support for any LCD drivers at all."
+ else
+ # Patch the config to contain a driver that is actually installed instead of the default
+ elog "Compiling the following drivers for LCDd: ${COMMA_DRIVERS}"
+ elog "Setting Driver=${FIRST_DRIVER} in LCDd.conf"
+ sed -i "44s:curses:${FIRST_DRIVER}:" LCDd.conf
+ fi
+
+ local ENABLEUSB
+ if use lcd_devices_cfontzpacket || use lcd_devices_cwlinux || use lcd_devices_pyramid; then
+ ENABLEUSB="--enable-libusb"
+ else
+ ENABLEUSB="$(use_enable usb libusb)"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable nfs stat-nfs) \
+ $(use_enable samba stat-smbfs ) \
+ $(use_enable seamless-hbars) \
+ ${ENABLEUSB} \
+ "--enable-drivers=${COMMA_DRIVERS}" \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ ebegin "Creating user documentation"
+ cd "${S}"/docs/lcdproc-user
+ xmlto html lcdproc-user.docbook
+ eend $?
+
+ ebegin "Creating dev documentation"
+ cd "${S}"/docs/lcdproc-dev
+ xmlto html lcdproc-dev.docbook
+ eend $?
+ fi
+}
+
+append-driver() {
+ [[ -z $* ]] && return 0
+ if [ -z "${COMMA_DRIVERS}" ] ; then
+ # First in the list
+ COMMA_DRIVERS="$*"
+ FIRST_DRIVER="$*"
+ else
+ # Second, third, ... include a comma at the front
+ COMMA_DRIVERS="${COMMA_DRIVERS},$*"
+ fi
+ return 0
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ # move example clients installed to /usr/bin
+ rm -f "${D}"/usr/bin/{tail,lcdmetar,iosock,fortune,x11amp}.pl
+ insinto /usr/share/lcdproc/clients
+ doins clients/examples/*.pl
+ doins clients/metar/
+
+ newinitd "${FILESDIR}/0.5.1-LCDd.initd" LCDd
+ newinitd "${FILESDIR}/0.5.2-r2-lcdproc.initd" lcdproc
+
+ dodoc README CREDITS ChangeLog INSTALL TODO
+ dodoc docs/README.* docs/*.txt
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}/lcdproc-user
+ doins docs/lcdproc-user/*.html
+ insinto /usr/share/doc/${PF}/lcdproc-dev
+ doins docs/lcdproc-dev/*.html
+ fi
+}
+
+pkg_postinst() {
+ ewarn "IMPORTANT: Please update your /etc/LCDd.conf"
+ ewarn "As of lcdproc-0.5.1-r2, the DriverPath changed from /usr/share/lcdproc to /usr/$(get_libdir)/lcdproc ."
+}