summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-02-24 11:56:57 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-02-24 11:56:57 +0000
commit0f41ada60c030479686130292183cedd37473fb6 (patch)
tree40eb50744a6d9b444d0e1a88de4578dfbfcccb52 /app-misc/lockfile-progs
parentMove -j1 to emake install since this caused the parallel-build issues. (diff)
downloadgentoo-2-0f41ada60c030479686130292183cedd37473fb6.tar.gz
gentoo-2-0f41ada60c030479686130292183cedd37473fb6.tar.bz2
gentoo-2-0f41ada60c030479686130292183cedd37473fb6.zip
Add a test suite.
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'app-misc/lockfile-progs')
-rw-r--r--app-misc/lockfile-progs/ChangeLog5
-rw-r--r--app-misc/lockfile-progs/files/Makefile29
2 files changed, 29 insertions, 5 deletions
diff --git a/app-misc/lockfile-progs/ChangeLog b/app-misc/lockfile-progs/ChangeLog
index 6bdfd728b8a0..30f80042a1a2 100644
--- a/app-misc/lockfile-progs/ChangeLog
+++ b/app-misc/lockfile-progs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/lockfile-progs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lockfile-progs/ChangeLog,v 1.3 2010/02/06 11:40:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lockfile-progs/ChangeLog,v 1.4 2010/02/24 11:56:57 phajdan.jr Exp $
+
+ 24 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> files/Makefile:
+ Add a test suite.
06 Feb 2010; Markos Chandras <hwoarang@gentoo.org>
lockfile-progs-0.1.13.ebuild:
diff --git a/app-misc/lockfile-progs/files/Makefile b/app-misc/lockfile-progs/files/Makefile
index 07ff7d5dd476..77b41608c275 100644
--- a/app-misc/lockfile-progs/files/Makefile
+++ b/app-misc/lockfile-progs/files/Makefile
@@ -1,5 +1,7 @@
all: lockfile-create
-.PHONY: all
+
+lockfile-create: lockfile-progs.o
+ ${CC} -o $@ ${CFLAGS} ${LDFLAGS} $^ -llockfile
install: all
install -d $(DESTDIR)/usr/bin
@@ -24,7 +26,26 @@ install: all
ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-lock.1
ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-unlock.1
ln -s lockfile-progs.1 $(DESTDIR)/usr/share/man/man1/mail-touchlock.1
-.PHONY: install
-lockfile-create: lockfile-progs.o
- ${CC} -o $@ ${CFLAGS} ${LDFLAGS} $^ -llockfile
+test: all
+ lockfile-create testfile
+ lockfile-check testfile
+ lockfile-touch --oneshot testfile
+ lockfile-check testfile
+ lockfile-remove testfile
+ ! test -e testfile
+ ! lockfile-check testfile
+
+ lockfile-create --lock-name test.lock
+ lockfile-check --lock-name test.lock
+ ! lockfile-check test.lock
+ ! test -e test.lock.lock
+ lockfile-touch --oneshot --lock-name test.lock
+ lockfile-check --lock-name test.lock
+ ! lockfile-check test.lock
+ lockfile-remove --lock-name test.lock
+ ! test -e test.lock
+ ! lockfile-check --lock-name test.lock
+ ! lockfile-check test.lock
+
+.PHONY: install test