summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Silva <r3pek@gentoo.org>2006-06-28 22:55:20 +0000
committerCarlos Silva <r3pek@gentoo.org>2006-06-28 22:55:20 +0000
commit94ff99b3a7ef325513310f5dcde78e9aa9da92a3 (patch)
tree91bc327767808696f207fee1742a7aae1ce7d21d /app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild
parentMarking nut-2.0.3-r1 ppc64 stable for bug #138389 (diff)
downloadgentoo-2-94ff99b3a7ef325513310f5dcde78e9aa9da92a3.tar.gz
gentoo-2-94ff99b3a7ef325513310f5dcde78e9aa9da92a3.tar.bz2
gentoo-2-94ff99b3a7ef325513310f5dcde78e9aa9da92a3.zip
Added support for a new MX300 ID. wrt bug #134186, thx to Samuli Suominen. Rev bumped and removed the other revision.
(Portage version: 2.1-r1)
Diffstat (limited to 'app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild')
-rw-r--r--app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild b/app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild
new file mode 100644
index 000000000000..ed0989237a4d
--- /dev/null
+++ b/app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/logitech-applet/logitech-applet-0.4_pre1-r2.ebuild,v 1.1 2006/06/28 22:55:20 r3pek Exp $
+
+inherit eutils
+
+MY_P=${P/_pre/test}
+MY_P=${MY_P/-applet/_applet}
+
+DESCRIPTION="Control utility for some special features of some special
+ Logitech USB mice!"
+HOMEPAGE="http://freshmeat.net/projects/logitech_applet/"
+SRC_URI="http://www.frogmouth.net/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc
+ dev-libs/libusb"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/logitech_applet-mx518.patch" || die "Failed to apply
+ patch"
+ epatch "${FILESDIR}/add-new-id-of-mx300.patch" || die "Failed to apply
+ patch"
+}
+
+src_install() {
+ dosbin logitech_applet
+ dodoc AUTHORS ChangeLog README doc/article.txt
+}