summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 12:22:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 12:22:28 +0000
commit0f740f024a341c93ce0ef4a17493a0a8163e442d (patch)
tree7851e40b6984c907b840a993247c1e1ed479c495 /app-misc/mc
parentInitial commit of Goo-Canvas perl module (diff)
downloadgentoo-2-0f740f024a341c93ce0ef4a17493a0a8163e442d.tar.gz
gentoo-2-0f740f024a341c93ce0ef4a17493a0a8163e442d.tar.bz2
gentoo-2-0f740f024a341c93ce0ef4a17493a0a8163e442d.zip
Upstream patch for undelfs configure flag.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog6
-rw-r--r--app-misc/mc/files/mc-4.7.0_pre1-undelfs_configure.patch16
-rw-r--r--app-misc/mc/mc-4.7.0_pre1.ebuild10
3 files changed, 28 insertions, 4 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 191eca561550..41e40c3980f0 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.154 2009/08/03 11:00:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.155 2009/08/05 12:22:28 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mc-4.7.0_pre1.ebuild,
+ +files/mc-4.7.0_pre1-undelfs_configure.patch:
+ Upstream patch for undelfs configure flag.
03 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> mc-4.7.0_pre1.ebuild,
+files/mc-4.7.0_pre1-tbz2_filetype.patch:
diff --git a/app-misc/mc/files/mc-4.7.0_pre1-undelfs_configure.patch b/app-misc/mc/files/mc-4.7.0_pre1-undelfs_configure.patch
new file mode 100644
index 000000000000..e2bc8d71c85b
--- /dev/null
+++ b/app-misc/mc/files/mc-4.7.0_pre1-undelfs_configure.patch
@@ -0,0 +1,16 @@
+http://www.midnight-commander.org/ticket/1459
+
+Patch from upstream git
+
+diff -ur mc-4.7.0-pre1.orig/configure.ac mc-4.7.0-pre1/configure.ac
+--- mc-4.7.0-pre1.orig/configure.ac 2009-07-31 19:36:24.000000000 +0300
++++ mc-4.7.0-pre1/configure.ac 2009-08-05 15:16:25.000000000 +0300
+@@ -535,7 +535,7 @@
+ AM_CONDITIONAL(USE_EDIT, [test -n "$use_edit"])
+ AM_CONDITIONAL(USE_VFS, [test "x$use_vfs" = xyes])
+ AM_CONDITIONAL(USE_VFS_NET, [test x"$use_net_code" = xtrue])
+-AM_CONDITIONAL(USE_UNDEL_FS, [test -n "$use_undelfs"])
++AM_CONDITIONAL(USE_UNDEL_FS, [test -n "$enable_vfs_undelfs"])
+ AM_CONDITIONAL(USE_SAMBA_FS, [test -n "$use_smbfs"])
+ AM_CONDITIONAL(ENABLE_MCSERVER, [test x"$enable_mcserver" = "xyes"])
+ AM_CONDITIONAL(CHARSET, [test -n "$have_charset"])
diff --git a/app-misc/mc/mc-4.7.0_pre1.ebuild b/app-misc/mc/mc-4.7.0_pre1.ebuild
index 391648f3a076..8ab73f02517b 100644
--- a/app-misc/mc/mc-4.7.0_pre1.ebuild
+++ b/app-misc/mc/mc-4.7.0_pre1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0_pre1.ebuild,v 1.6 2009/08/03 11:00:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.7.0_pre1.ebuild,v 1.7 2009/08/05 12:22:28 ssuominen Exp $
EAPI=2
-inherit eutils
+inherit autotools eutils
MY_P=${P/_/-}
@@ -18,6 +18,7 @@ IUSE="gpm nls samba +slang X"
RDEPEND=">=dev-libs/glib-2.6:2
gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
samba? ( net-fs/samba )
slang? ( >=sys-libs/slang-2 )
!slang? ( sys-libs/ncurses )
@@ -34,7 +35,9 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${P}-ebuild_syntax.patch \
- "${FILESDIR}"/${P}-tbz2_filetype.patch
+ "${FILESDIR}"/${P}-tbz2_filetype.patch \
+ "${FILESDIR}"/${P}-undelfs_configure.patch
+ AT_NO_RECURSIVE="yes" eautoreconf
}
src_configure() {
@@ -45,6 +48,7 @@ src_configure() {
econf \
--disable-dependency-tracking \
--enable-vfs \
+ --enable-vfs-undelfs \
--enable-charset \
$(use_with X x) \
$(use_with samba) \