summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2011-11-30 07:21:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2011-11-30 07:21:30 +0000
commit3fcebf876be01dcb44cb7f5af651688ae4cdf8bc (patch)
treeb7aa8d77384029dbb4c5453357629c3878bb7626 /app-misc/mc
parentVersion bump. Add multiuser use flag to control launcher behavior. (diff)
downloadgentoo-2-3fcebf876be01dcb44cb7f5af651688ae4cdf8bc.tar.gz
gentoo-2-3fcebf876be01dcb44cb7f5af651688ae4cdf8bc.tar.bz2
gentoo-2-3fcebf876be01dcb44cb7f5af651688ae4cdf8bc.zip
Fix annoying leading spaces in ftp directories (upstream patch)
(Portage version: 2.2.0_alpha77_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog8
-rw-r--r--app-misc/mc/files/mc-4.8.0-fix-ftp-spaces.patch32
-rw-r--r--app-misc/mc/mc-4.8.0-r2.ebuild83
3 files changed, 122 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 22fb26d86f6d..36d2bf9db38d 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.230 2011/11/11 13:23:20 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.231 2011/11/30 07:21:30 slyfox Exp $
+
+*mc-4.8.0-r2 (30 Nov 2011)
+
+ 30 Nov 2011; Sergei Trofimovich <slyfox@gentoo.org> +mc-4.8.0-r2.ebuild,
+ +files/mc-4.8.0-fix-ftp-spaces.patch:
+ Fix annoying leading spaces in ftp directories (upstream patch)
11 Nov 2011; Naohiro Aota <naota@gentoo.org> mc-4.7.5.3.ebuild,
mc-4.7.5.5.ebuild, mc-4.8.0.ebuild, mc-4.8.0-r1.ebuild:
diff --git a/app-misc/mc/files/mc-4.8.0-fix-ftp-spaces.patch b/app-misc/mc/files/mc-4.8.0-fix-ftp-spaces.patch
new file mode 100644
index 000000000000..8944690261ad
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.0-fix-ftp-spaces.patch
@@ -0,0 +1,32 @@
+commit 95c553c46770f89f09c4408cbdf61ed76b4a8766
+Author: Sergey <sergemp@mail.ru>
+Date: Thu Oct 20 14:28:39 2011 +0300
+
+ Ticket #2635: mc adds spaces an the beginning of all files/dirs at the ftp server
+
+ For FTP servers, that do not send ".." in directory listing, mc adds one space to the name of every file and directory. Attached patch should fix this problem.
+
+ Steps to reproduce:
+ cd /#ftp:ftp.symantec.com
+
+ Expected result:
+ Correct list of files/directories
+
+ Actual result:
+ File/directory names with leading spaces
+
+ Signed-off-by: Slava Zanko <slavazanko@gmail.com>
+
+diff --git a/lib/vfs/parse_ls_vga.c b/lib/vfs/parse_ls_vga.c
+index 8091c14..5424ee9 100644
+--- a/lib/vfs/parse_ls_vga.c
++++ b/lib/vfs/parse_ls_vga.c
+@@ -657,7 +657,7 @@ vfs_split_text (char *p)
+ void
+ vfs_parse_ls_lga_init (void)
+ {
+- vfs_parce_ls_final_num_spaces = 0;
++ vfs_parce_ls_final_num_spaces = 1;
+ }
+
+ /* --------------------------------------------------------------------------------------------- */
diff --git a/app-misc/mc/mc-4.8.0-r2.ebuild b/app-misc/mc/mc-4.8.0-r2.ebuild
new file mode 100644
index 000000000000..c2206bc7629f
--- /dev/null
+++ b/app-misc/mc/mc-4.8.0-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.0-r2.ebuild,v 1.1 2011/11/30 07:21:30 slyfox Exp $
+
+EAPI=4
+
+inherit base flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="http://www.midnight-commander.org"
+SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm mclib +ncurses nls samba slang test X"
+
+REQUIRED_USE="^^ ( ncurses slang )"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ ncurses? ( sys-libs/ncurses )
+ samba? ( net-fs/samba )
+ slang? ( >=sys-libs/slang-2 )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=("${FILESDIR}/${PN}"-4.8.0-fix-nls.patch
+ "${FILESDIR}/${PN}"-4.8.0-fix-ftp-spaces.patch
+ )
+
+src_configure() {
+ local myscreen=ncurses
+ use slang && myscreen=slang
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-vfs \
+ $(use_enable kernel_linux vfs-undelfs) \
+ --enable-charset \
+ $(use_with X x) \
+ $(use_enable samba vfs-smb) \
+ $(use_with gpm gpm-mouse) \
+ --with-screen=${myscreen} \
+ $(use_with edit) \
+ $(use_enable mclib) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver ||
+ die "setting cons.saver's owner failed"
+ fperms g+s /usr/libexec/mc/cons.saver ||
+ die "setting cons.saver's permissions failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}