summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-05-03 14:47:46 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-05-03 14:47:46 +0000
commita326ffddb6d373c82d4d03bc9d0644ea6048418b (patch)
treea8fccca632aefa4341cbae50db9aea531987cf5c /app-misc/mc
parentAdded python eclass to pre-compile the python modules, and added a warning ab... (diff)
downloadgentoo-2-a326ffddb6d373c82d4d03bc9d0644ea6048418b.tar.gz
gentoo-2-a326ffddb6d373c82d4d03bc9d0644ea6048418b.tar.bz2
gentoo-2-a326ffddb6d373c82d4d03bc9d0644ea6048418b.zip
Add patch, thanks to hansmi, to fix bug #127411.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog8
-rw-r--r--app-misc/mc/files/digest-mc-4.6.1-r19
-rw-r--r--app-misc/mc/files/mc-4.6.1-nonblock.patch11
-rw-r--r--app-misc/mc/mc-4.6.1-r1.ebuild141
4 files changed, 168 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 1aa6927e4b30..722fc5f304a5 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/mc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.100 2006/04/27 13:17:17 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.101 2006/05/03 14:47:46 exg Exp $
+
+*mc-4.6.1-r1 (03 May 2006)
+
+ 03 May 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/mc-4.6.1-nonblock.patch, +mc-4.6.1-r1.ebuild:
+ Add patch, thanks to hansmi, to fix bug #127411.
27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-mc-4.6.0-r12,
files/digest-mc-4.6.0-r13, files/digest-mc-4.6.0-r14,
diff --git a/app-misc/mc/files/digest-mc-4.6.1-r1 b/app-misc/mc/files/digest-mc-4.6.1-r1
new file mode 100644
index 000000000000..17b4ba9611d2
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.1-r1
@@ -0,0 +1,9 @@
+MD5 becd9c9ecefbaed5bfb453cad2e4725a mc-4.6.1-utf8.patch.bz2 30401
+RMD160 f23680c85328b4b0435065f9e5cf430e0cd6b0c4 mc-4.6.1-utf8.patch.bz2 30401
+SHA256 dbc0f41059c4010665027d6ab756c4ca6d65584bcfb771afa120da3219e8e61b mc-4.6.1-utf8.patch.bz2 30401
+MD5 18b20db6e40480a53bac2870c56fc3c4 mc-4.6.1.tar.gz 3928370
+RMD160 d565ee95a8916d73fad5e0defeb9f2f57e50962b mc-4.6.1.tar.gz 3928370
+SHA256 086ab03daaac28a28c0ddb9a709040b59e1322f6bfa68e39d004d9c66b119e7e mc-4.6.1.tar.gz 3928370
+MD5 60a8e4524554a550472622db7fcf728f u7z-4.16beta.tar.bz2 3041
+RMD160 4a682b3b4bc6c09c7414f8d585829763f6c112ea u7z-4.16beta.tar.bz2 3041
+SHA256 668ed6a0484358e51de1be8d8581cc36dd3c915872fb1082550437a2d7aa67dd u7z-4.16beta.tar.bz2 3041
diff --git a/app-misc/mc/files/mc-4.6.1-nonblock.patch b/app-misc/mc/files/mc-4.6.1-nonblock.patch
new file mode 100644
index 000000000000..eca34aaf5289
--- /dev/null
+++ b/app-misc/mc/files/mc-4.6.1-nonblock.patch
@@ -0,0 +1,11 @@
+--- mc-4.6.1/src/cons.saver.c.old 2006-04-30 20:45:11.725128977 +0200
++++ mc-4.6.1/src/cons.saver.c 2006-04-30 20:45:55.545063247 +0200
+@@ -134,7 +134,7 @@
+
+ if (seteuid (uid) < 0)
+ die ();
+- console_fd = open (tty_name, O_RDONLY);
++ console_fd = open (tty_name, O_RDONLY | O_NONBLOCK);
+ if (console_fd < 0)
+ die ();
+ if (fstat (console_fd, &st) < 0 || ! S_ISCHR (st.st_mode))
diff --git a/app-misc/mc/mc-4.6.1-r1.ebuild b/app-misc/mc/mc-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..295ba8abfd2d
--- /dev/null
+++ b/app-misc/mc/mc-4.6.1-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.1-r1.ebuild,v 1.1 2006/05/03 14:47:46 exg Exp $
+
+inherit flag-o-matic eutils
+
+U7Z_PV="4.16"
+U7Z="u7z-${U7Z_PV}beta.tar.bz2"
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-utf8.patch.bz2
+ 7zip? ( http://sgh.nightmail.ru/files/u7z/${U7Z} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="7zip X gpm ncurses nls pam samba slang unicode"
+
+PROVIDE="virtual/editor"
+
+RDEPEND="kernel_linux? ( >=sys-fs/e2fsprogs-1.19 )
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ pam? ( >=sys-libs/pam-0.72 )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( >=sys-libs/slang-1.4.9-r1 )
+ samba? ( >=net-fs/samba-3.0.0 )
+ X? ( || ( (
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM
+ )
+ virtual/x11
+ )
+ )
+ x86? ( 7zip? ( >=app-arch/p7zip-4.16 ) )
+ ppc? ( 7zip? ( >=app-arch/p7zip-4.16 ) )
+ amd64? ( 7zip? ( >=app-arch/p7zip-4.16 ) )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ unpack ${U7Z}
+ fi
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-find.patch
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ epatch ${FILESDIR}/${PN}-4.6.0-7zip.patch
+ fi
+ epatch ${FILESDIR}/${P}-largefile.patch
+ if use slang && use unicode; then
+ epatch ${DISTDIR}/${P}-utf8.patch.bz2
+ fi
+ epatch ${FILESDIR}/${P}-nonblock.patch
+}
+
+src_compile() {
+ append-flags -I/usr/include/gssapi
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ if ! use slang && ! use ncurses ; then
+ myconf="${myconf} --with-screen=mcslang"
+ elif use ncurses && ! use slang ; then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ myconf="${myconf} `use_with gpm gpm-mouse`"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_with X x`"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba --with-codepagedir=/var/lib/samba/codepages --with-privatedir=/etc/samba/private" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-ext2undel \
+ --with-edit \
+ --enable-charset \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
+ ${S}/lib/mc-wrapper.sh
+
+ einstall || die
+
+ # install cons.saver setuid, to actually work
+ chmod u+s ${D}/usr/lib/mc/cons.saver
+
+ dodoc ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+
+ insinto /usr/share/mc
+ doins ${FILESDIR}/mc.gentoo
+ doins ${FILESDIR}/mc.ini
+
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ cd ../${U7Z_PV}
+ exeinto /usr/share/mc/extfs
+ doexe u7z
+ dodoc readme.u7z
+ newdoc ChangeLog ChangeLog.u7z
+ fi
+
+ insinto /usr/share/mc/syntax
+ doins ${FILESDIR}/ebuild.syntax
+ cd ${D}/usr/share/mc/syntax
+ epatch ${FILESDIR}/${PN}-4.6.0-ebuild-syntax.patch
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=71275
+ rm -f ${D}/usr/share/locale/locale.alias
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "allow mc to chdir to its latest working dir at exit"
+ einfo ""
+ einfo "# Midnight Commander chdir enhancement"
+ einfo "if [ -f /usr/share/mc/mc.gentoo ]; then"
+ einfo " . /usr/share/mc/mc.gentoo"
+ einfo "fi"
+}